除了可以通过“新建 SQL 语句”向导创建 SQL 语句以外,还可以在 SQL 编辑器中创建 SQL 代码片断编辑测试窗页面。一个 SQL 代码片断编辑测试窗页面可以包含一个或多个 SQL 语句。
SQL 代码片断编辑测试窗页面的使用方式与通过“新建 SQL 语句”向导创建的 SQL 语句的使用方式在很多方面都相同。但是,还是存在一些限制。下表总结了 SQL 代码片断编辑测试窗页面与通过“新建 SQL 语句”向导创建的 SQL 语句之间的比较。有关更详细的信息,请参阅用来描述特定功能的相应主题。
表 1. SQL 代码片断编辑测试窗页面与通过向导创建的 SQL 语句之间的比较| 功能 |
SQL 代码片断编辑测试窗页面 |
通过向导创建的 SQL 语句 |
| 可用的工具 |
SQL 编辑器 |
SQL 构建器和 SQL 编辑器 |
| SQL 语句类型 |
数据定义语言(DDL)和数据操作语言(DML) |
- SQL 构建器:只能使用 DML
- SQL 编辑器:如果具有模板,则只能使用 DML;如果没有模板,则可以使用 DML 和 DDL
|
| 创建文件 |
- 任何开发透视图:文件菜单
- “数据”透视图和“数据库资源管理器”视图:工具栏按钮和弹出菜单
|
- 任何开发透视图:文件菜单
- “数据”透视图和“数据项目资源管理器”视图:数据项目中的弹出菜单
- “数据”透视图和“数据库资源管理器”视图:工具栏按钮和弹出菜单
|
| 是否提供了语句模板 |
否 |
是,为 DML 语句提供了语句模板 |
| 是否多个 SQL 语句存在于同一个文件中 |
是 |
- SQL 构建器:否
- SQL 编辑器:是,但是仅为第一个语句提供 DML 模板
|
| 已保存文件的格式 |
XML |
原始 SQL |
| 已保存文件的扩展名 |
.sqlpage |
.sql |
| 编辑文件 |
SQL 编辑器:除了“数据”透视图之外的任何开发透视图 |
- SQL 构建器:仅“数据”透视图
- SQL 编辑器:任何开发透视图
- 其他文本编辑器:除了“数据”透视图之外的任何开发透视图
|
| 运行文件 |
在 SQL 编辑器中运行 |
- 在 SQL 构建器中运行
- 在 SQL 编辑器中运行
- 在“数据”透视图的“数据项目资源管理器”视图中运行
|
| SQL 语句中是否允许存在主变量 |
否 |
- 是否可从 SQL 构建器中运行:是
- 是否可从 SQL 编辑器中运行:否
- 是否可从“数据”透视图的“数据项目资源管理器”视图中运行:是
|
| 是否可将 SQL 语句导入存储过程或用户定义的函数中 |
否 |
是 |