C++ から UML への変換の構成

変換で予想どおりの出力を生成するために使用する情報を指定するには、構成のガイドをする新規変換構成ウィザード変換構成エディターを使用します。

このタスクについて

変換構成は、ファイル名拡張子 .tc を持ち、変換が予想通りの出力を生成するために使用する情報が含まれます。また、変換構成には、 特定のタイプの変換に固有の情報も含まれています。既存の変換構成を編集するには、ワークスペース・リソースを示すビューで変換構成ファイルをダブルクリックし、変換構成エディターを開きます。

変換構成ファイルに関する作業を簡略化するには、変換する要素を含むプロジェクトに構成ファイルを保存します。

手順

  1. 作業しているビューに応じて、以下のステップのいずれかを実行します。
    • 「パターン・エクスプローラー」ビューで変換を右クリックし、「新規構成」をクリックします。
    • その他のビューで、「ファイル」 > 「新規」 > 「変換構成」をクリックします。「変換構成」がメニュー項目でない場合は、「ファイル」 > 「新規」 > 「その他」 > 「変換」 > 「変換構成」をクリックします。
  2. 構成の詳細を指定します。新規変換構成ウィザードの「構成名および変換の指定」ページで、以下のステップを完了します。
    1. 名前フィールドに、構成の名前を指定します。
    2. 構成ファイル宛先フィールドで、変換構成ファイルの宛先を指定します。宛先は、現行ワークスペース内の相対パスです。完全修飾プロジェクト名またはフォルダー名を指定できます。プロジェクト内のフォルダーを指定する場合は、フォルダー名の前に接頭部としてスラッシュ (/) を付ける必要があります。
    3. 変換リストから変換を選択します。
      注: インストールされていても使用可能になっていない変換を表示するには、すべての変換の表示をクリックします。 変換は、このリストに表示するには、機能にバインドする必要があります。
  3. プロトコル」セクションでモデリング・プロトコルを指定します。 これは、設計規約管理プロトコル (DCMP) とも呼ばれています。 選択する値によって、変換のソースとターゲットを同期するかどうかが決定されます。
    • ソース・モデルが基本技術成果物の場合は、概念を選択します。 ソース・モデルへの変更はすべてターゲット・モデルに波及します。
    • ソース成果物が表すアーキテクチャーがターゲットとは独立して発展する場合は、調整を選択します。このオプションを選択すると、ソースとターゲットの比較や変更の調整に利用できる後方変換を使用できるようになります。また、他のチームによって該当のアーキテクチャーが 実装、開発、または保守される場合にも、このオプションを選択することができます。
      注: このオプションを選択すると、「メイン」ページの「後方変換」セクションで、追加のプロパティーが使用可能になります。 一部の変換では、変換構成エディターで追加のオプションまたはページが使用可能になります。 後方変換の構成について詳しくは、下の関連リンクを参照してください。
  4. 「次へ」をクリックします。
  5. 変換のソース要素とターゲット要素を指定します。有効なソース要素とターゲット要素のリストについては、この変換に関する関連概念のトピックを参照してください。 「ソースとターゲット」ページで、以下のステップを実行します。
    1. 選択済みソース」ペインで、変換対象の変換用にソース要素を選択します。
    2. 選択済みターゲット」ペインで、変換出力の宛先を選択します。出力の新規の宛先を作成するには、ターゲット・コンテナーの作成をクリックします。
  6. 「次へ」をクリックします。
  7. オプション: 変換で UML 操作に変換する C++ 要素を指定し、 また、変換によってクラス内のメンバー変数に UML 関連や UML プロパティーを生成するかどうかを指定することができます。 これらのオプションを使用することで、変換によってターゲット UML モデルに生成される UML 要素をより細かく制御できます。 デフォルトの変換では、変換ソースに指定したクラスごとに、 C++ の getter および setter メソッドの UML 操作、デフォルトのコンストラクターおよびデストラクター、 コピー・コンストラクター、および代入演算子が生成され、メンバー変数の UML 関連が作成されます。 「C++ から UML への変換オプション」ページで、以下の 1 つ以上のステップを実行します。
    • UML 操作を作成するには、変換する C++ 要素の横にあるチェック・ボックスを選択します。
    • メンバー編集の UML 関連を作成するには、「モデルを検査して C++ メンバー変数に UML 関連を生成する (Generate UML associations for C++ member variables by peeking into the model)」チェック・ボックスを選択します。変換でターゲット・モデルが検査され、関連関係の一部をなすメンバー変数に関連関係が作成されます。 メンバー変数が UML 関連の一部でない場合、変換によって UML プロパティーが作成されます。
  8. オプション: 変換ターゲットの有効範囲外にある UML 要素への参照を解決するには、C++ 要素と UML 要素間のリンクを定義する関連ファイルを作成します。 この機能は、変換対象の要素が複数の C++ プロジェクトにあり、またそれらの相互依存性が、構成する変換の有効範囲外にある場合に役立ちます。 関連ファイルを作成するには、「C++ から UML への変換の関連」ページで、以下のステップを実行します。
    1. 「C++ から UML への関連を有効にする」チェック・ボックスを選択します。
    2. 「C++ から UML への関連ファイル名」フィールドで、ファイル名を指定します。
    3. 「C++ から UML への関連」セクションで、 表の横にあるボタンをクリックして、 ファイルに関連を追加するか、またはファイルから関連を削除します。
    関連の順序によって、C++ 要素がどのように UML 要素にマップされていくかが決まります。複数のプロジェクトとそれらの相互依存性のサポート について詳しくは、下記の関連する C++ から UML への変換の概念トピックを参照してください。
  9. 「終了」をクリックします。 変換構成エディターが開くと、構成の内容が表示されます。
  10. オプション: デバッグ情報を生成するには、「メイン」ページでデバッグ・ログの生成チェック・ボックスを選択します。 次回変換を実行したときに、ログ・ファイルが XML ファイルとして、変換の設定で指定したフォルダーに生成されます。 ログ・ファイルの場所を指定していない場合は、変換によりワークスペースの .metadata フォルダーにログ・ファイルが生成されます。
    ヒント: 変換の設定を行うには、「ウィンドウ」 > 「設定」とクリックし、「モデリング」を展開して、「変換」をクリックします。

    ログ・ファイルは、ソース要素、ターゲット要素、および変換によってソース要素が変換されるときに適用される規則に関する情報を提供します。変換が多数の要素を変換する場合、変換がログ・ファイルを生成している間はパフォーマンスが低下することがあります。そのため、ログ・ファイルを生成するのは、デバッグ目的の場合のみにしてください。

  11. オプション: 変換の実行中に新規ダイアログ・ボックスが開かないようにするには、「メイン」ページでサイレント・モードで前方変換を実行チェック・ボックスを選択します。

    サイレント・モードで変換を実行すると、変換によって生成されるすべてのダイアログ・ボックスが抑制されます。 変換ではデフォルトの規則と振る舞いが適用され、予期しない変換出力や不正確な変換出力が生成されることがあります。サイレント・モードでの変換の実行は、変換出力の検証ではなく、変換の実行を検証する場合のみ実行してください。例えば、自動化されたタスクや自動化されたテスト・スイートの一部として、変換をサイレント・モードで実行することがあります。

    変換がサイレント・モードで実行されるよう設定すると、指定したファイル上書きオプションがオーバーライドされ、必要に応じてファイルが上書きされます。

    UML から C++ への変換、またはその逆方向の変換が使用可能な場合、サイレント・モードで後方変換を実行チェック・ボックスを選択することができます。サイレント・モードで後方変換を実行するよう指定すると、変換構成で指定したファイル上書きオプションがオーバーライドされます。変換は、必要に応じてファイルを上書きします。

  12. 変換のソースおよびターゲットの要素の間に追跡可能な関係を作成するには、「メイン」ページでトレース関係を作成チェック・ボックスを選択します。C++ のソース・コードをターゲットの UML モデルと同期させるため、調整されたモデリング環境で C++ から UML への変換を初めて実行するときに、通常このチェック・ボックスを選択します。変換を実行した後、「マージ」ウィンドウで、提案されている変更のうち受け入れた各変更に対して、ターゲットの UML モデルに対応する表記があるコード要素に @generated タグおよび固有 ID が変換によって追加されます。追跡可能な関係を生成すると、変換により変換のターゲットで重複した要素が生成されることを防げます。

    追跡可能な関係を作成できる要素のリストを表示するには、このトピックの最後にある、関連する変換の概念トピックへのリンクを参照してください。

    「マージ」ウィンドウで提案された変更のうち、受け入れなかった各変更に対しては、変換はこれらの注釈をコード要素へ追加しません。次回 UML から C++ への変換を実行すると、モデル要素とコード要素の間の関係が存在しないので、変換によって重複したコード要素が生成されます。

  13. オプション: 変換の実行時に発生したエラーを表示するには、「メイン」ページで変換の完了時に「レポート」ダイアログ・ボックスを開くチェック・ボックスを選択します。このチェック・ボックスを選択すると、生成されたエラーのみが表示されます。同じ情報はエラー・ログにも書き込まれます。このエラー・ログは「ウィンドウ」 > 「ビューの表示」 > 「エラー・ログ (Error Log)」の順にクリックすることで表示できます。

    変換の実行時に発生した警告を表示するには、「レポート」ダイアログ・ボックスに警告を表示チェック・ボックスを選択します。

  14. オプション: 変換構成に関する文書を指定します。このフィールドは、複数のユーザーが共有する構成に関する情報を伝達する場合に便利です。「メイン」ページの文書フィールドに、変換構成についての追加情報を指定します。
  15. 「ファイル」 > 「保存」をクリックします。

タスクの結果

オプションは次回変換を実行したときに適用されます。

フィードバック