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Maintain an ILE RPG application using Remote System
Explorer

This tutorial teaches you how to maintain a payroll application written in ILE RPG
using the Remote System Explorer.

Learning objectives

» Start the product and open the Remote System Explorer perspective

+ Use tools and views in this perspective to connect to an iSeries™ system
» Edit, verify, compile and debug a payroll application

* Customize Remote System Explorer

» Design screens and reports

Time required

3 hours

Introduction

Learning objectives

» Start the product and open the Remote System Explorer perspective

» Use tools and views in this perspective to connect to an iSeries system
» Edit, verify, compile and debug a payroll application

* Customize Remote System Explorer

» Design screens and reports

Time required

This tutorial should take approximately 180 minutes to finish. If you explore other
concepts related to this tutorial, it could take longer to complete.

Skill level
Introductory
Audience
iSeries programmer

System requirements

 IBM® WebSphere® Development Studio Client for iSeries, V7 and all software
updates through the IBM Installation Manager.

+ i5/05® V5R3 or V5R4
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Prerequisites

+ Basic Microsoft® Windows® operations such as working with the desktop and
basic mouse operations such as opening folders and performing drag-and-drop
operations

* Restore the RSELABXX savefile (RSELABXX.savf) on an iSeries system:
[Import the RSELABXX project into your workspace]

Open the Project Explorer view by clicking Window » Show View ~» Other »
General » Project Explorer.

Expand the rselabxx project.
Right-click the rselabxx.savf savefile, and select Restore on iSeries.

It will also help if you understand DDS and ILE RPG.

This tutorial is divided into a number of modules, each with its own learning
objectives. You can choose to skip the modules on Screen design and RSE
introduction and you can complete the modules on Debug, Customizing, Screen
Design and RSE Introduction in any order after the module on Verify and compile.
Each module contains several lessons that must be completed in order for the
tutorial to work properly.

Expected results

Upon completion of this tutorial you will know how to edit, compile and debug an
iSeries application from the Remote System Explorer. You will also know how to
customize the Remote System Explorer.

Conventions used in this tutorial

» Bold font for user interface controls

* Mono-spaced font for user input and code blocks
« ltalic font for variable names and glossary terms

Starting the product and the Remote System Explorer

This module teaches you about the workbench, the workspace, a perspective and
specifically the Remote System Explorer perspective.

Learning objectives
» Start the product
* Set the default workspace

» Access unique tools and views targeted towards iSeries application development
tasks

Time required
This module should take approximately 10 minutes to complete.
Starting the product

If you want to know more about the product before you get started you can read
[“Introducing the product and Remote System Explorer (optional)” on page 190

First you must start the product. Follow these steps to start the product:
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1. Click Start on the task bar of your desktop.

2. Select Programs > IBM Software Development Platform> IBM WebSphere
Development Studio Client for iSeries> WebSphere Development Studio
Client for iSeries

&) 1BM Suppart Assistant
@ webSphere Development Studio Chent Ady
£] Releass Notes

& Advanced Edition For [Serizs

If you are working with the Advanced Edition of the product you will see the
words Advanced Edition in the product name.

A dialog will appear. Here you specify the directory of the workspace where
your projects and other resources such as folders, subfolders and files that you
are developing in the workbench will reside.

€ Workspace Launcher B3
Select a workspace

16M Websphere Development Studio Chent Advanced Edition for iSeries stores your projects in a folder called a workspace.,
Choose a workspace folder ko use For this session.

Workspace: |C:'|,Documentsand Settingstidbox\IBMirationalsdp? Oty selsboce _VJ Erowse... |

I Use this as the default and do not ask again

[ ] cancel |

3. (Optional) Change the field in this dialog and use a unique directory name, for
example, RSELABxx (where xx is a unique number).

4. Click OK to open the workbench.
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# Remote System Explorer - IBM Websphere Development Studio Client Advance.
File Edit Mavigate Search Project Data Run  Window Help

m@ i¥eicome. X

5. Click the X next to the Welcome tab to close the Welcome page

#0 Plug-in Development - IBM Websphere Development

File Edit Navigate Search Project Data Run Window

Closing the Welcome page will take you to the Remote System Explorer
perspective.

Tip: To open the Welcome page again, select Help » Welcome.
6. Click the maximize button to maximize the workbench.
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#0 Remote System Explorer - iSeries RSE Getting Started - IBM Websphere Development Studio C... [H{[=] E3
File Edt MNavigate Search Project Data Run Window Help

| B | 4 ] s l 9 5 | remate Syste. ..
|/ B iseries RSE Getting Started Zﬂx"\.,x S O} 8= OEE‘“\\::' 8
- ianaunesm:

iSeries Remote System |SURAREIR

B-£ W Explorer Introduction
| o iSeties. ..

= Introduction

[+ Windows. ..

& & T Welcome to WebSphere Development Studio

F Client for iSeries and the Remote System

= & Power Linux... Explorer (RSE). The RSE provides an

B unix Unix... integrated development environment for

& By AlX.., iSeries programmers, It allows you to work

&5 Local with your libraries, objects, members, jobs

& Q%4 and IFS files, as well as edit source members,
#-Ef Local compile programs and debug applications.

We recommend that you Follow the steps
below to quickly get started using the RSE.
This overyiew is meant to help vou find some :J

| 48 Remote Syst.., ﬁ“"--_jasksIiSerl'esTabIe... iSeries Com... I =0

24

i} | |

; Q‘._; q'.}' |

[ Properties 53 . Remote 5. | T O

Elli=
Property | value Al
Mame Mew Connection —
Miimher of child 7 z
| »
] LI #n expandable prompt for. . .nnection: New Connection ]

You have started the product and opened the workbench. The workbench refers to
the desktop development environment. The workbench aims to achieve seamless
tool integration and controlled openness by providing a common paradigm for the
creation, management, and navigation of workbench resources. Each workbench
window contains one or more views and an editor.

Lesson checkpoint

You learned the following:
* About workspaces

* About the workbench

* How to start the product

Opening the Remote System Explorer perspective

Now you are ready to open the Remote System Explorer (RSE) perspective.
1. Check for the name of the perspective.

# Remote System Explorer - iSeries RSE Getting Started - IBM Websphere Development Studio C... [H[=] E3
File Edit Mavigate Search Project Data Run  Window Help

|- |3 -0 - Q- E T RS B | £ Remote Syste...

wiﬁa iSeries RSE Getting Started 232 \\_‘ —im | EE 052 ‘__D g ]
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A perspective defines the initial set and layout of views in the Workbench
window. Within the window, each perspective shares the same set of editors.
Each perspective provides a set of capabilities aimed at accomplishing a specific
type of task or working with specific types of resources. For example, the Java™
perspective combines views that you would commonly use while editing Java
source files, while the Debug perspective contains views that you would use
while debugging a program. Perspectives contain views and editors and control
what appears in certain menus and tool bars.

If you see a different perspective, not the Remote System Explorer open in the
workbench or no perspective:

2. Click Window > Open Perspective > Remote System Explorer from the
workbench menu.

€0 Remote System Explorer - iSeries RSE Getting Started - IBM Websphere Development Studio C... =]
File Edit Navigate Search Project Data Run | Window | Help

MNew Window = _m
MNew Editor

Open Perspective » L'=3 i5eries Projects
Show View System Explarer

Customize Perspective.., .05 WebFacing
Save Perspective As...

Basnk Raisnmabiin

Other,..

The Remote System Explorer perspective opens.

You work in the Remote System Explorer perspective in the workbench. This
perspective is for an iSeries programmer to display the connections that you
have already configured, create a new connection, connect to and disconnect
from the connections that you have defined, work with iSeries files, commands,
jobs, and integrated file system files.

This perspective will be active when you start the product with a new
workspace. If you had used the workspace before then, the workbench would
come up with the perspective that you last opened. You will learn more about
the Remote System Explorer perspective in the coming exercises as this is
where you launch the iSeries programmer tools and use the views from the
workbench.

You have opened the Remote System Explorer perspective.
Lesson checkpoint

You learned the following:

* About perspectives

* About the RSE perspective

* How to open the RSE perspective

Module summary
You have learned how to start the product, and open the RSE perspective.
Lessons learned

By completing this module, you learned about the following concepts and tasks:
* About workspaces
* About the workbench
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* About perspectives
* About the RSE perspective
* How to start the product

* How to access unique tools and views targeted towards iSeries application
development tasks

Assessment

* What is a workspace?

* What is the workbench?

* What are perspectives?

* What is the RSE perspective?

* How do you start the product?

* How do you open the RSE perspective?

Configuring a connection to an iSeries system and connecting to an
ISeries

This module teaches you how to create a connection to an iSeries server, find a
library in your library list, select objects from a library and finally open a member
in the Remote Systems LPEX Editor. You also learn about several views such as the
Remote Systems view, iSeries Table view, and the Outline view.

Learning objectives

* Create a connection to an iSeries system

» Connect to an iSeries system

* Add a library to your library list

* View libraries in your job’s library list from the Remote Systems view
* Find a source physical file in your library

* View members in a source physical file using the iSeries Table view

* Customize the columns in the iSeries Table view

* Open a member for edit from the iSeries Table view or the Remote Systems view
* Maximize the editor window

* Open another member for edit

« Switch from one edit session to another edit session

* Open multiple views of the same source member

» Display a structural outline of items defined in a source member

Time required

This module should take approximately 10 minutes to complete.

Configuring a connection to an iSeries system

When you first open the Remote System Explorer, you are not connected to any
system except your local hard drive on your workstation. To connect to a remote
iSeries system, you need to define a connection. When you define a connection,
you specify the name or IP address of the remote system and you give your
connection a unique name that acts as a label in your workspace so that you can
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easily connect and disconnect. When you connect to the iSeries system, the
workbench prompts you for your user ID and password on that host.

The first time you connect to an iSeries system, you need to specify a profile. All
connections, filters, and filter pools belong to profiles. Filters are described in a
later lesson. Profiles are discussed when you create your first connection.

Remember you have already opened the Remote System Explorer perspective in
the previous module.

1. In the Remote Systems view, New Connection is automatically expanded to
show the various remote systems types you can connect to through the Remote
System Explorer.

= onnection

; ~ E—
; B iSeries. ..

[+] CE Linux. ..
3] ﬁi Power Linux...
B unix Uni, ..
By ALX...
#-E Local...
3] ﬁ Local

Click the plus sign + beside iSeries to configure a connection to an iSeries

system.
The Name personal profile page opens.

Name personal profile

Uniquely name user prafile :&:

‘Welcome to Remote Systems, Connections can be sharable by the team or
private to you, Enter a profile name to uniquely identify you from your team
members, You will decide for each new connection whether it is owned by the
team profile or your profile.

Profile: | pleiades

< Back I |Ne:<t >| I Finish | Cancel I

2. Click Next to accept the default value. The profile defaults to the name of the
workstation. Your profile will be different from the one shown here.

=)
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The Remote iSeries System Connection page opens.

Remote iSeries System Connection

Define connection information :g:

Parent profile: Ipleiades ﬂ
™
Eomection nanme: |s4DDa
st name: |54DOa| ) :]
Description: |

v erify host name

) <pack | mext> [[] Fmsh []  cancel |

On this second page you specify the information for your connection. The
cursor on this page is positioned in the Host Name field.

3. In the Host name field, type the IP address or the name of your host system.

The Connection name is automatically filled with the host name. Leave it this
way. This name displays in your Remote Systems view and must be unique to
the profile.

Leave the Parent profile default value. You don’t need to change it.
Leave the Verify host name check box selected.
6. Click Finish to define your system.

S

You have configured a connection to an iSeries system.
Lesson checkpoint

You learned the following:
» About configuring a connection
* How to configure a connection to an iSeries system

Connecting to an iSeries system

After you configure a connection to an iSeries system, you can easily connect and
expand your new connection to reveal your subsystems. Subsystems are
pre-defined filters grouping the various types of remote resources that can be
explored in the remote system. There are four subsystems.

iSeries Objects
A PDM-like group, allowing access to libraries, objects and members.

iSeries Commands
Contains predefined commands and allows you to create command sets
each of which contain one or more often used commands. When run, all
commands in a command set are sent to the remote system and executed,
and the results are logged in the iSeries Commands log.

Maintain an ILE RPG application using Remote System Explorer 9



iSeries Jobs
Allow you to see various jobs, subset by job attributes, and to perform a
number of operations on those jobs.

IFS Files
Allow you to explore folders and files in the Integrated File System of the
remote iSeries system.

.15 Remate Systems X Team =B
£ | < | B% Y
=& Mew Connection
| =-Ea series...
v Connection created successfully, E>
EI(F Windows. ..
P ,ﬁ Linux...
@Y Power Linux...
E"Un:x Unix...
My ALK
¢ @B Local...
* E’ Local
=@ s400a

ioE Jis Work with libraries. ..
. 22 work with objects...
= Xﬁ Wark with members., ..
- ;p Library list

L H i'f-‘ User libraries

EE) iSeries Commands

E é‘l iSeries Jobs
- Ty IFS Files

-8 Qshells

< | |

To connect to an iSeries system:

1. In the Remote Systems view, your new connection is expanded to reveal your
subsystems. The iSeries Objects subsystem is the subsystem you will use most
often! It is very similar to PDM, in that it allows you to access objects in the
QSYS file system, and perform actions on those objects.

Notice the first three entries under the iSeries Objects subsystem are named
after the PDM options, because they have similar capabilities:

* Work with libraries (similar to WRKLIBPDM)
* Work with objects (similar to WRKOBJPDM)
* Work with members (similar to WRKMBRPDM)
In addition there are entries for working with library lists and user libraries:

— Library list (to simulate PDMs WRKLIBPDM you can start with the
pre-defined Library list filter, that when expanded lists all libraries in your
library list.)

— User libraries (allows you to work with all user libraries you can access
on that iSeries server.)

You also have more entries to work with under the connection itself and you
can see from these entries that Remote System Explorer goes well beyond
PDM! It allows you to explore iSeries jobs and commands and the IFS file
system.

2. Now let’s work with a library in your library list and add the library that you’ll
be using in this tutorial:
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a. Right-click iSeries Objects and click Properties on the pop-up menu.

‘work With s
& & | ¥ Refresh
=142 New Connection Change Password.,
L B EE ngrias... Fel Irteractive Job
") Connection ‘erify Connection..,.
E 8 windows. .. et
- Linux... Flear Pa N
ClearFassiword
£ ,& Power Lindx, ..
-unix Unie... Remote Servers 4
[ ALK, =
i B Local... Show Log
B Local Run Command. ..
= s4002
S-S 5 FE
- As Work with libraries. .. the

b. Select Initial Library List on the left pane.
c. Type RSELABxx where XX is a unique number in the Library field and click

Add.
#0 Properties for iSeries Objects Hi=1E3
[type Fiter text Initial Library List i ¥
- Command Execution
—ERikaRFReRE-arables —leraylst
- Initial Library List Library: []
Refactonng Fistory
" Subsystem Library | Library Positian
RSELABKX *LAST

Change

Remove

Move Up |

[Meve Ciewn

« | 2

Current library: I *USRPRF _:]

Initial command:

Restore Defaults | Apply |
@ RN

d. Click OK.

This will add the library RSELABXxx to your library list every time you use
this connection.

Tip: You can also change your library list using the pop-up menu items
Add Library List Entry or Change Current Library on the Library list
folder in the iSeries Objects subsystem. These changes are only valid until
you disconnect.

3. Expand the Library list folder.
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=& Mew Connection
. E-Ba iseries...
o v Connection created successfully, E>
-8 Windows. ..
B A Linux...
B0 Power Linux...
Bl unix Unix...
-y ATK...
¢ BB Local..,
#-Ef Local
= Ba s400s
L [H-Ae Work with ibraries...
A3 Work with objects. ..
|31 A werk with members, .,
|
| ¥ User libraries
(3] ap iSeries Commands
& iSeries Jobs
- Ty IFS Files
-3 shells

4 | i3

Now the connection will be activated and you will be prompted for a user 1D
and password.

# Enter Password B3

System type: iSeries
Host name:  TORAS33E

User ID: l wilabiex

Password:

| oK I Cancel I

Enter your user ID and password.
Select the Save user ID check box.
Select the Save password check box.
Click OK.

As you know, you can use the properties of any of the subsystems to set
connection information such as adding a library to the library list.

Back in the workbench in the Remote Systems view you will see the libraries in
your job’s library list.

N o gk
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: ~| Connection created g.lccessﬁ.llh':_l
BB Windows. .
© B Linux...
e power Linux...
. B-unic Unix...
BB ATX..
i BB Local.,
EIE Local
= s400a
=& iseries Objects
| B 3 Work with libraries. .
-5 work with objects...

+

! .‘.'..j Work with members. ..
= ¢ Library list

- BEm, Q5V52924.%b.prod-sys

| EEL Q5VS.Hib.prod-sys

BB QSVS2 b, prod-sys
- B, QHLPSYS, Mib, prod-sys

. E-m QUSRSYS.Mb.prod-sys T
[+ e, WRLABK, b, test-usr

| E-Eh ADTSLAB.*ib.prod-ust

' 'EJ ﬂw’- User libraries b
4| | »

Notice that the s400a folder now has a small green arrow in the icon to indicate
it is an active connection.

For each library, you can right-click and select from a number of actions. For
example, there is an action to create a new source file within the selected
library. Common actions like delete, move, copy, etc. are valid for all kinds of
objects.

You have connected to an iSeries system and used the Remote Systems view to
view libraries in the library list.

Lesson checkpoint

You learned the following:

* About subsystems

* About the iSeries Objects subsystem
* How to connect to an iSeries system

Viewing and accessing objects in the Remote System Explorer
Now you are ready to view and access objects in your library RSELABXxX.

To view and access an object:

1. Expand library RSELABxx.
You will see all objects in this library appear in the Remote Systems view. For
each object you can right-click and select from a number of actions. The list of
actions depends on the object selected and whether you selected one or
multiple objects. For example, for a source file the pop-up menu has an action
to create a new member within the selected file.

2. Drill-down through the files in the Remote Systems view until you find
QDDSSRC source file and then expand it.
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3. Scroll down through the files in the Remote Systems view until you find
QRPGLESRC source file and expand it as well.

= ||
5 MyYCOMPILE. *pgrm.clle _4_|
[F paYROLL, *pam.rpale

1 PAYROLLD.*pam. chlle

[# PAVROLLG *parn.rpale

[ COMPARE. *file.p-src

= EMPMST *file.pf-dta

5} EVFEVENT.*ile.pF-dea

6] MSTDSP, *ile.dspf

&1 6% MSTDSP2, *file.dspf

@[5 PRIMST *file.pf-dta

=+ [50) QCBLLESRC. *Flle,pf-src

- [5 QCLSRC *file.pF-src

LETS

@ E R
&

][4

1[5 QDDSSRC *file.pf-src
-t EMPMST.of
-+ MSTDSP. dspf
€ PRIMST.pf
i By REFMST.pf

LGt
[ =) |5 QRPGLESRC, *file. pf-sre
L PAYROLL.rpole
-0 PAYROLLG.rpgle
| el QFI{PGLESRCP."‘fiIe.pf—sr >
1 »

Now you can see and access the members in these two source files. For each
member you can right-click and select from a number of actions. The exact list
of actions depends on whether the member is a data file or source file and
whether you select one or multiple members. For a RPG source member, the
pop-up menu actions include:

* open with

* browse with

* verify

« compile

Before you go ahead and work with these members, let’s see the members in
the iSeries Table view as well because that is similar to the view you are used
to from PDM. You use this view to display a list of items, for example,
members or objects, in a table format similar to PDM. You can also perform
actions against these items such as editing and compiling.

4. Right-click the QDDSSRC file and then click Show in Table on the pop-up
menu.
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=) =Ry
eam| (T Paste
=] | | = rLMo\.-e, ;
(5 MYCOMPILE, *pgm 9% Delete...
F-[H PAYROLL.*pgm.rpr
# - [4 PAYROLLD *pam.c
B[ PAYROLLG *pam.r
-5y COMPARE. *file.pf- » Find String...
®-[5 EmMPMST *file.pf-dt  Change...
# [5] EVFEVENT *file.pf-  Save..,
® 6 MSTDSP.*file.dspf  Restore...
® 6] MSTDSP2.*file.dsp Uiser Actions »
#-[F PRIMST *file.pF-de =
- 5B QCBLLESRC.*Fie.r Add To iSeries Project. ..
50 QCLSRC *fle.pf-si Make Available OFfline
%[5 QMDSRC *Fie-pf:  properties

= |.[.-I:I'Eu'_’uF:_l.:.*fiIE.pF-;_ru_ 1M

15 Remote Systems X QLI

Cache file Descriptions

the RSF. Farh <ter

The iSeries Table view takes the selected object in the Remote Systems view as
input, and displays the contents in the table. For source physical files, this

step displays the members inside, their names, types, attributes, and text
descriptions.

| ) |
L(: QODSSRC. *fik._ || [Remote System ... ble iSeries Command... | = OJ
G empmsT.p hme\maxx;'qmssnc (s Members) Q@ ¥
- O msTDSP. O - £l
C: promsT.pf ||| Name__# Type | atmbute [ Text O S
LB REFMST I CEMPMST PR SRC
i cL RSNMST.p CmsSTDSP  DSPF SRC
= LB ORPGLESRC.* CopriMsT PR SRC -
-8 pavrowr 14 | 2

The top of the iSeries Table view contains a lock icon |&% that controls the
correlation between the Remote Systems view and the iSeries Table view. If
the lock is disabled then whenever you click an object or library in the
Remote Systems view, the associated contents of that item automatically
populate the iSeries Table view. If the lock is enabled then when you click on
various items in the Remote Systems view, this view does not change the
content of the iSeries Table view. To enable or disable the lock, you can click it
once to change its state. You can click on the columns heading to sort the
view by column.

5. In the iSeries Table view toolbar make sure the lock/unlock button | &% is in
the unlock position. Leave the mouse pointer over the tool button for a second
or two to display the flyover help. That way you can check if the view is
locked or unlocked.

This means now the table will automatically be updated when a different
object is selected in the Remote Systems view. This is a shortcut to open the
pop-up menu for an object in the Remote Systems view and to select Show in
Table.

You can also modify which specific columns you want to see in the iSeries
Table view.

6. To modify the iSeries Table properties:
a. Click Window > Preferences from the workbench menu.
The Preferences Window opens.
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& Preferences H=]1E3

] kype filker bext Table View 5w
& Profiing and Logging | [ Rl tom o it s
a Remote Systems
Conilcations ¥ Use the command line For action parameters
[+ Debug
HiaCactis | Specify columns and colurn order
i Files
! I Type: IMember
Cache Avallable columns
- Command Execution
Commands Subsystem
- IFS Files Subsystem
Jobs Subsystem
- Objects Subsystem

& Program Verifiers
(Tl ]
Logging
Passwords
[+ Remote Systems LPEX Editor
Screen Designer (Technical Pre
55L

- Reguirement Management =
@ Dy imNakin
‘1 o | _’IJ Restore Defm.l:sl Bpply |

[ ox | concel |

(

(=3

b. In the left pane of the Preferences window, expand Remote Systems.

c. Expand iSeries under Remote Systems.

d. Click Table View under iSeries.

e. In the right pane of the Preferences window, select Last modified in the
Available columns list.

f. Click the Add button.

g. Click OK.

h. Now, let’s update the iSeries Table view. Click the down arrow on the
iSeries Table view title bar.

Remate System D... B, iseries Table yiew X iSeries Command, .. | = |m|
File RSELABYY/QDDSSRC (S Members) el 1 Q
Name Type Attribute | Text Work with v L
C-jEMPMST PR SRC
B
G, MSTDSP  DSPF SRC ?:I:s“*l
C4PRIMST  PF 5 e
EH REFMST  PF SRC Customize
CRSMMST PR SRC
Print...
ol Export to File... -.-I
Hide Commands
Command |E| | Preferences... J

Messages | _:l Detafs, ., | Show Log |

i. Click Show columns > Customized in the pop-up menu.
Now you’ll see the extra column that you’ve added.
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7.

Remake System D..

B, iSeries Table view X,

File RSELABXX,!'QDDSSRC (5 Members) =S Q>
Name | Type |N:trh.i:e | Text | Last modified | |

C-iEMPMST PF
Gy msTDSP DSPF
GopRIMST FF
O REFMST PF
CoRSMMST  PF

4]

SRC
SRC
SRC
SRC

July 23, 2003 1:28:22 FM
July 23, 2003 1:28:25 PM
July 23, 2003 1:28:29 PM
July 23, 2003 1:28:33 PM
July 23, 2003 1:28;37 PM

S

Command E |

j Pr-:m:r".,.l Rur-l

Messages |

;‘ D»;-tar's...l ShnwLog]

You can also sort the objects in the iSeries Table view by column.
j- To sort the objects in ascending order by Last modified, click on the

heading.

Remake System D, ..

P iseries Table view X

Flle RSELABY/QDDSSRC (smmwﬁ\ E & | @ v

Name | Type

C-ipsmumsT PF
O REFMST PF
Gy pRIMST FF
0 msTDSP DSPF
O EmpMST FF

4]

| attribute TNext
SRC “a | July 23, 2003 1:28:37 PM
SRC July 23, 2003 1:28:33 PM
SRC July 23, 2003 1:28:29 PM
SRC July 23, 2003 1:28:25 PM
SRC July 23, 2003 1:28:22 PM

.

Command E |

j P:-:un:n"‘.,.l Rur-l

Messages |

ﬂ Detar’s...l ShnwLogl

k. If you click the heading the second time, it will sort it in descending order.
In the Remote Systems view, select QRPGLESRC.
The table shows the members in QRPGLESRC.

#1-[5) QCBLLESRC. *file. pf-stc

QCLSRC,*file.pf-src

- [5) QCMDSRC *file pf-src
H QDODSSRC, *file.pf-sre

SR} URPGLESRC. *file.pf-src
-0 paYROLL.rpgle

i q.u PAYROLLG.rpgle

- [5) QRPGLESRCP. *file.pf-src

%[5 REFMST *File.pf-dta
1Bl RSNMST *file. pf-dta

B MYCOMPILE. *cad

2
Remaote System | [ s iseries Table view 52 iSeries Command, ., | ==
File RS%I!.AB)WQRPG.ESRC (2 Members) 5 ()

| -NaTe [Type | attribute | Text | Last modified I

U5 payROLL  RPGLE SRC February 22, 2006 1:51...
el'_:] PAYROLLG  RPGLE SRC October 20, 2006 11:32..,
4| | |

Now you are ready to use the Remote Systems LPEX Editor to edit the
member MSTDSP found in QDDSSRC.

From the Remote Systems view double-click member MSTDSP in the
QDDSSRC source file.

You can do this in the Remote Systems view or in the iSeries Table view.
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The Remote Systems LPEX Editor opens. It is built right into the workbench,
with rich editing functions and is iSeries aware! It is a superset of SEU! The
syntax checker is ported from SEU, and the reference manuals are built-in and
F1 cursor sensitive.

9. Double-click the MSTDSP tab to maximize the Editor window.
10. Double-click the MSTDSP tab again to return the view to its original size.

I|# msTose pspe 52 [~ 1 = 0O|( 8= outine 2\ = O
{ - | = -

Line 1 Column 1 E| = EM| MSTDSP,DSPF
es AT L s lavsatiasads
-G e, 8
| [T
= Tiepieta 000002 ar :

- 50 QUBLLESRC, *file,pf-src
= b QCLSRC, *file.pf-src
&[5 QCMDSRC. *file,pf-src

000003 ArrEs
000004 A* THIS DIS
= ooooos A* TIME REFOR
= 57} QDDSSRC.*HIe.pf-src 0ooo0s6 AT
A ,

You have viewed and accessed objects in the RSELABXxx library.

Lesson checkpoint

You learned the following:
e About member actions
e About the iSeries Table view

Opening a second source member and multiple views
Next let’s open a second member in the editor.

To open a second source member:

1. In the Remote Systems view, double-click member PAYROLL in the
QRPGLESRC source file.

3. Click on each tab to switch from one edit session to another edit session.

4. You can open multiple views of the same source member while editing in the
Remote Systems LPEX editor. To open multiple views of a your RPG source.

a. Double-click the PAYROLL tab in the editor to maximize the Editor
window.

b. Right-click this source in the Editor view and click View > Open new view.

Tip: You can open a maximum of five views of the same source.
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/ WSTDSP.DSPF : _

Line 1 Column 1 Replace

...... R TN, P EARI PR RN LI PN PR P
Dﬂuluu F’."l':‘.":'l’."l':‘.":'l%‘K?:t*x?:t*x?:t*x?:xtwK::IKK::T*K!'}:I*K?KIK*KWI
000200 F* PROGRAM NAME - Payroll
000300 F* DESCRIPTION - Time rennrring waster f£ile maintenance
000400 Fr Hew }» Fibed workstation proces
DGOSBD Fressxsas: FrE AR AN T AN ANTRAAANATANNNN D

Proi F

000600 F* INDIC. T& .
000700 Fro S0 - 1) operation
000800 F* 60 - ¢ Gaye
0oos00 F+* 950 -1 E request
001000 Fr EC - ]Gt Gl
001100 F* KD - ] =opy Cirislnsert fection
001200 F* KE - 1 Paste Chel+y tion
001300 F* KF - 1 ion
001400 F* KG - I8 e P hection
001500 Fr LR - |jjeeskesd 7
001600 Fhressxsss: Deselect Akl XX R T XA R AR RAATENARTE
001700 FT SUBROL firer yigy S )
001500 F* EDITS] =t &l Gl Fction display (SELECT)
001900 F* ACDES] all maintenance reguest
DDZDDD Fressewas: Swm | 20 Rl e B i R e i e e i o e
002100 F* This ,% Open new view Ctrl+2
002200 F* used &re - — mEINCENE  Mexbview Chrl+Alt-Right
002300 F* — EMPHST - emplovee  previousview (chisalerlert
4 | Hatizanta! solit

c. Right-click a source view and select View > Next view or View > Previous
view to navigate among the views.

. F

...... Losiow ik e wla e st e ud e
ouninn F‘\‘\l’ntﬁ!w!wﬂ%ﬁl‘ﬂ'lﬂ“ﬂﬂ't‘!ﬁl‘?‘.ﬂ'wﬁxlA
ooozoo F* PROGRAM NAME - Payroll :j
000300 F* DESCRIPTICN - Time repor
000400 F* externally
000500 F‘Hﬂ?fﬂ‘ﬂ"k#?ﬁﬂfﬂﬂ?%ﬂ?ﬂﬁ'?“fﬂ‘ﬂ!‘k
000600 F* INDICATORS USED
000700 F* 50 - No record found on
ooos00 F* 60 - General error condi
000300 F* 90 - Protect display on
001000 F* EKEC - End of job requeste
001100 F* KD - Return to applicati
001200 F* KE - Return to enployee
001300 F* FKF = Return to project s
001400 F* EKEG - Return to reason co
001500 F* LR - Last record
uulsun F%‘H‘ﬂ:!‘HW*??X?E:!?HWH:‘JH’.‘EHH:‘
001700 F* SUEBRCOUTINES USED
001800 F* EDITSL - Edit applicatio:
001500 F* LACDESR - Edit action cod
ouzuuo 1.—1?:‘.1?:#:e*‘;#xgt::k'ﬁx:.‘.iz:::x*
00z 100 F* This program uses all ex
oDzzo0 F* used are - MSTDSP - mai

h g
< | .’IJ

#/ MSTDSP.DSPR m !

........ Lo otiaada i
noo100 Frearsastreassessen
000200 F+* PROGRAM NAME -
000300 F+ DESCRIPTION -
000400 F* [
03050“ F'X‘.‘.“X:‘t'tﬁtﬂ'?:‘t‘xﬁ‘.‘.'t‘x‘x
DO0&00 F* INDICATORS USE]
000700 F* 50 - No record
000800 F* 60 - General e)
000300 F* 90 - Protect d
001000 F* EKC - End of jol
001100 F* KD - Beturn to
001200 F* KE - Return to
no1300 F* EKEF - Return to
001400 F* EG - Return to
001500 F* LR - Last recol
001600 Fﬁ*ﬁ‘t#‘ﬁﬂ“tfﬁ*ﬂk#t#ﬂ'
001700 F+ SUBROUTINES US]
001800 Fs EDITSL - Edic ¢
001300 F* ACDESR - Edit :
002000 FHErez st o x a2 0dE4%"
002100 F* Thi= program w
002200 F* used are - HMST
4] |

Note: Any changes made in one of the views will automatically update all
other views of the same source.

Scroll down and place the cursor at line 33 in the left view of the source.

Press Enter.
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Replace 1 chang

..... DNfjne +++++++++++ETDsFrom+++To/L4 oe.. Dffemetsssssssss
002200 F* used are - MSTDSP - main:_:_l 002300 i -1
002300 F* - EMPMST - emplc 002400 F* -1
002400 F* - PRIMST - prc:‘eJ 002500 e -1
002500 e — RSNMST - reasc 002600 |t E A T
002600 T e i e e i e vk e e i e ol e e o e i e e oy ol o e ol e e e 002700 FMSTDSP CF
002700 FMSTDSP CF E 002800 FEMPMST UF &
002800 FEMPMST UF A E K 002900 FPRJMST UF &
002500 FPRJMST UF AE K 003000 FRSMMST UF &
003000 FRSNMST UF A E K 003100 D#
0032100 D* 003200 D* Compile time
003200 D* Compile time array contair |p03300 D ERR
003300 D ERR 5 003301 D
003301 D 003400 D EMESS
003400 D EMESS 3 003500 E¥*
003500 Ew 003600 53 e e e e e e
003600 A A R AR AR AR AR AR 003700 C* MAINLINE CR]
003700 C* MAINLINE CALCULATIONS 003800 P L —
003800 ot B R AR TR R R R R R R L R R L 003900 o* This mainlii

A new line is inserted in both views and since the previous line is a D-spec,
the new line is also marked as a D-spec.

f. Define a new variable, i as shown in the screenshot below, with length 10:

# MSTDSP.DSPF =
RSELABXX/Q LL): 1 REELABTN JORFGLES
Line 33 Column 2 HAeplace 2 changes Line 384 Column 1 Replace 2 change:
I . . Diame +++++++++++ETDaFromi++Io/L+++IDc. Keywt I . . . DName+++++++++++ETD3From+++To/L++
002000 037200 c -
002100 035000 C* The following code checks e
002200 josg100 C* ensure that it is either '
002300 1038200 c*
002400 (038300 c IFNE
002500 038400 c RMDNE Lk
002600 038500 c HOVE
002700 038600 c MOVE E
002800 038700 c END
002900 (038200 c IFHE .
003000 (038300 C RNDNE :
goaseo b 033000 c MOVE '
003200 D* Compile time array containing error « [IS910D c MOVE E
C END
I 003301 039300 c IFNE i
4] 1039400 c ANDNE -
003500 039500 c MOVE |
003600 033600 c MOVE E
003700 039700 C END
003800 039800 cw ENDSR
0039300 059300 Cc*
004000 b
4] | | *
I

Now, in the view on the right, you can start using the new variable while
being able to maintain your view on the left on the definition of the
variable.

g. Right-click a source view and select View > Horizontal split to change from
a vertical split of the views to a horizontal split of the views.
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oooz00
000300
000400
000500
000600
oooroo

4

'/ WSTDSP DSPF M PGLE

vaassateceaFeienticeaBiasatiicaSeiiatiiaabaias
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F* DESCRIPTION - Time reporting master file maintenance us
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F+* INDICATORS USED

F* 50 - No record found on CHAIN operation

000100
0oozo0
000300
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000500
D00&00
000700

4]

RSELABXXICRPELESRC(PAYROLL): 2

Column 1 Replace
........ TevesFtennsBennsFennsTunnsFesssFevnsFersaTensatensebonas
F#a'.‘.'ﬁk.‘:a‘ﬁ'ﬁf.‘:'xﬁ'ﬁf.‘:‘xtﬁk:‘xtﬁk.‘-‘ﬁ'#ﬁk:"‘:tﬁkﬂ'ﬁ*ﬁﬁ:f;ﬂ'ff;:‘f;**ﬁ:‘f;.‘.‘ff;.‘.‘f;ﬁ

F* PROGRAM NAME - Payroll

F* DESCRIPTION - Time reporting master file maintenance us
F* externally described workstation processi
FHz‘ﬂR?.'HRTRH:RTRH:RHRH:RTRH:R".H?.':z‘-ﬁ?.':2‘.*?.'#*1‘??.‘#*1‘2?.‘#*1‘??.‘#*1
F* INDICATORS USED

F* 50 - No record found on CHAIN operation

h. Right-click the source view that you want to close (RSELABXX/
QRPGLESRC(PAYROLL): 2) and select View > Close view

Tip: This option is not available on the first view.

You have opened another member for edit and seen multiple views of a member.

Lesson checkpoint

You learned the following:

* About multiple views

* How open a second source member
* How to open multiple views

Displaying an outline of a source member

The Outline view acts as an excellent resource when you want to edit RPG,
COBOL and DDS source in the Remote Systems LPEX editor. The Outline view
displays a structural outline of items defined in the file that you currently have
open in the Remote Systems LPEX editor window. With the editor active, you can
expand the file structure in the Outline view, and click various elements in the
view to jump to that location in the source itself.

To see an Outline view of your RPG source:
1. Click the PAYROLL tab in the editor and click Refresh on the Outline view

toolbar.

Tip: If you have closed the Outline view, you can reset the perspective by
selecting Window > Reset perspective from the workbench menu or Show
view > Other then expand Basic and click Outline in the Show view dialog.
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The Outline view contains your source program in a tree view without the lines
containing logic.

=L Global Definitions
&[] Files

I~ Figlds

(L5 Indicators

=1 Lg% Main Procedure
L Subroutines

Now you want to see more details of your source member.
Expand Files.

Expand the MSTDSP workstation file.

Expand the EMPSEL record format.

Double-click on any of the entries in the Outline view.
This will position the source editor accordingly.

a s~ DN

A VSTDSPDSPE | # PAYROLLRFGLE 52 =0d s =0}
Line 187 Column 1 Replace H ] -EDEPT:Characte;l
I. «+ CLONO1Factor 1+++++++0pcode (E) +Facto ! [+ I:I | ELOCN : Characte
018400 c dou sINall| @ D0 EMCAT : Characte
018500 C HOVE ‘o’ & [ EMESS : Characte
018600 c MOVE *BL #- EMPAPL ; Charact—
018700 c Z-2DD 0 | =00 EMPNO : Packed
018800 C MOVE *BL Pl L@ 47 (M)
018900 C* grror loop start S O
019000 C dou not P Ja \
019100 c HOVE *BLo|ll | k o
4 | _’l—l © B ENAME ; Characte

© @ ENERS ¢ Packed £x |
| 4| | »

6. Stay in the PAYROLL tab to get the PAYROLL Editor window in focus for the
next lesson.

You have displayed an outline of a source member while editing RPG or DDS
sources.

Lesson checkpoint

You learned the following:
* About the Outline view
* How to display an outline of a source member

Module summary

You have learned how to create and configure a connection to an iSeries system
and access libraries, files and members in that system. You have also learned about
several views such as the Remote Systems view, iSeries Table view and the Outline
view.
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Lessons learned

* Create a connection to an iSeries system

» Connect to an iSeries system

* Add a library to your library list

* View libraries in your job’s library list from the Remote Systems view
* Find a source physical file in your library

* View members in a source physical file using the iSeries Table view

* Customize the columns in the iSeries Table view

* Open a member for edit from the iSeries Table view or the Remote Systems view
* Maximize the editor window

* Open another member for edit

* Open multiple views of the same source member

» Switch from one edit session to another edit session

» Display a structural outline of items defined in a source member

Assessment

* How do you connect to a remote iSeries system?

* What are subsystems?

* What is the iSeries Objects Subsystem?

* How do you add a library to your library list?

* How do you find files in your library?

* What is the iSeries Table view?

* What does the lock icon do in the iSeries Table view?
* How do you view members in the iSeries Table view?
* How do you open a member of edit?

* How do you maximize the Editor window?

* What is the Outline view?

* How do you display an outline of a source member?

Editing source

This module teaches you how to edit ILE RPG source member PAYROLL, which
should already be open, and learn about some of the Remote Systems LPEX
Editor’s language features.

Learning objectives

* Change the default settings of the LPEX Editor Parsers
* Change the color settings and font used by the Editor
* Change the default behavior of the Enter key

* Use SEU commands to edit source

* Undo and redo source changes

* View language sensitive help for the MOVE operation code
* View a list of all help contents

» Limit the search of help to specific documents

» Search the help

* Request a prompt for a specification line
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» Display context sensitive help for any field in the iSeries Source Prompter
* View the beginning and ending of constructs in your source

* Use the Find and Replace window to search for an item in your source
 Filter or subset your source

 Filter lines based on line type

» Search through members in a source physical file

* Compare different versions of a program and identify the differences

» Syntax check source by line

* View help on syntax errors

» Use the Application Diagram view to understand your program code

Time required

This module should take approximately 45 minutes to complete.

Introducing the editor

Your program editing tasks are simplified with the Remote Systems LPEX Editor.
The editor can access source files on your workstation or your iSeries system
directly. When a compilation results in errors, you can jump from the compiler
messages to an editor containing the source. The editor opens with the cursor
positioned at the offending source statements so that you can correct them.

Here is a list of some of the basic editor features that you would expect in a
workstation editor:

» Cut, copy, and paste

* Block marking of lines, characters, or rectangles with copy, move, and delete
operations

» Powerful find and replace function
* Unlimited undo and redo

In addition there are a few more functions that you may not have seen in a
workstation editor:

» Token highlighting where different language constructs are highlighted using
different colors to help identify them in a program

* SEU-like format-line rulers to show the purpose of each column for
column-sensitive languages like RPG and DDS. These rulers can automatically
update themselves to reflect the current specification.

» SEU-like specification prompting for CL, RPG, and DDS

» Sequence numbers, which allow SEU-style commands in the prefix area
* Intelligent tabbing between columns for column-sensitive languages

* Automatic uppercasing for languages that expect uppercase

» Settings for column-sensitive languages that simplify text insertions and
deletions

* On-line language reference

You have learned about the features of the editor.
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Lesson checkpoint

You learned the following:
» About the LPEX Editor

Changing default editor settings

The LPEX Editor has predefined settings, but also has an associated preferences
page containing settings that you can modify. The name of the category is LPEX
Editor and it appears in the left pane of the Preferences window.

You will change the default settings of LPEX Editor Parsers, Appearance and User
Key Actions.

LPEX provides special support for insertion and deletion in column-sensitive
languages. When column-sensitive editing is selected, each column is considered as
a separate entry space. For example, in an RPG source member, if you are inserting
or deleting characters into a string that is in the Factor 2 entry, the Result field
entry does not move. The default editor preference is that column-sensitive editing
is off. You can switch this support on by going to the workbench preferences
window.

1. To set column sensitive editing:
a. Click Window > Preferences from the workbench menu.
The Preferences window opens.
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# preferences [_ (O] x]
| type filter text Remote Systems LPEX Editor <~ ~ e

' Package Maming Preferences :__I I

: V¥ Autosave
[#- Flug-in Development
[ Porkal Minutes between saves (1 - 60) [5
i ™ show date area
= Remote Systems [ Column sensitive editing
i Communications
[# Debug Resequence start at (1-9999): 100
il Cack Resequence increment by (1-9999): | 100
El iSeries ™ Resequence lines at save
o Cache
- Command Execution
~- Commands Subsystem
i~ IF5 Files Subsystem
; Jobs Subsystem

- Objects Subsystem
[ Program Verifiers
- Table View
Logging

- Screen Designer (Technical Pre

i S5L
- Requirement Managemenk

[#-Run/Debug
(- Server o
- Spell Check
[+ Team
‘&i Test | = r’v Restore Defaults | Apply |
0] oK I Cancel I

b. In the left pane of the Preferences window, expand Remote Systems.
Select Remote Systems LPEX Editor under iSeries.
The right pane allows you to set preferences for this feature.

d. In the right pane of the Preferences window, select the Column sensitive
editing check box.

When selected, each column is considered as a separate entry space.
e. Click Apply.

Other interesting preference settings are located under LPEX Editor.
Appearance allows you to modify color settings and font used by the
Editor.

2. To change the editor appearance:

In the left pane of the Preferences window, expand LPEX Editor.
Select Appearance under LPEX Editor.

Select formatLine under the Styles list.

Change the Foreground color to dark green.

Change Font to 12.

Change Background color to light green.

Notice how your changes are reflected in the sample edit view.

~® a0 0w
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0 preferences

I type filter bext

7 General -

[#)- Active Correlation Tec |
[#- Agent Controller

[#]- Analysis

- Ant

- Application Diagram

- Backward Compatibilits
- Crystal Reports

- Data

[+ EMFT JET Transformat_|
L HATSwWebFacing

0 Help

[ Importer

[#- Install/Update

[+ Internet

[+ iSeries Projects

- J2EE

# Java

([ n{n||wln
: Appeararice
: Block
~ Compare
Controls

Find Text
[+l Parsers

: Print el
A1 4

Appearance = B

Palette
Iwhte i I | Caurier New-regular-12

Styles

Jefadk »l[rv Foreground NN | Background |:|]

deletedlines

emphasis

il J Effects

messageline I~ Underline I” squigale
rDefault ’ .

x:;mz:asage = I~ Strikeout 7 Gutiine

Preview

Line 1 Column 1 Replace
B+ 1 . 2 T 3 $——-

Emphasis, current line, default texnt

ERRO0L Embedded parser message.

Jeshledsl Text in parser default style
Compare added line text

B Compare deleted line text

4| | 2

LPEX 3.2.2 (build 12-Dec-2006)

Reset I ‘Restnre Defaults I Apply |

|-\J /]

OK | Cancel I

g. Select currentLine under the Styles list.

This option highlights the line that the cursor is on. The option applies to
all source files opened in the editor area.

h. Change the Background color to light yellow.

i. If you don’t like the changes you made, you can click Restore Defaults to
return to the original settings.

3. To autosave while editing source:

To enable or disable autosave while editing source in the Remote Systems LPEX
Editor, you need to change an editor preference. You use the Window >
Preferences > Remote Systems > Remote Systems LPEX Editor and click the

check box Autosave.

The default value for the minutes is set to 5. You can specify a value between 1

and 60 minutes.

4. To modify the default behavior of the Enter key:
a. Expand LPEX Editor if not already expanded then select User Key Actions.
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0 preferences (O] x]
[tvpe Fiter text User Key Actions = -

¥l Crystal Reports :J I
- Data | Key. | action |
[ EMFT JET Transformat
- HATSWebFacing
[+ Help
[ Importer
[+1- Install/Update
[ Internet
[#-i5eties Projects
- JZEE
- Java
- Jython
* - Logging
i Appearance

Block
Compare
Controls
- Find Text
[+ Parsers
Print
Save
Tabs
- ser Actions

User Mouse Actior

User Profile LIL' Reset: | Restare Defadts| Apply |

@) | OK I Cancel I

]

Enter

b. Type enter in the Key field.

Tip: The Key and Action fields are case sensitive. Make sure that the values
typed in the Key and Action fields are exactly as shown above.

c. Type splitLine in the Action field.
d. Click Set.

The LPEX Editor has a predefined behavior for the Enter key. For the Enter
key to use the new split line action, you need to change this behavior for
the ILE RPG language. This is to prevent the specification type from being
automatically added on a new line.
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0 preferences

I type filter bext

Cache _A_]
Command Execution
Commands Subsystem
-~ IFS Files Subsystem
Jobs Subsystem
Objects Subsystem
= Program Verifiers
- DDS PRTF
[#- ILE COBOL
[+ ILERPG
Table Wiew
Logaing
Passwords

|[%!-- Remote Systems LPEX Edt\-l
' [=] iSeries Parsers I
L3

b CL
[+ COBOL

oD
=1 ILE RPG

Free-Form SQL
~ Templates
- RPG{400
-Screen Desianer (Technical
~55L
Requirement Management
-RunjDebug
Server
SIP
Spell Check
Team

Test -
4 3

ILE RPG e

[V Automatic syntax checking
¥ Automatic syntax checking of SOL statements (performed o
[~ Automatic uppercasing

' [~ Repeat previous specification tvpel

eration code (IF on Fixed Form &-Specificatin

asiton
[ Set free Form C-Specitication cursor pasition
Fasitian I’_
™ | Seb D -Specification cursor pastion
Faosition m
¥ Autamatic ndent
¥ Autematic closure of control Block

[~ User defined tabs(G)

|=: Control i I

|. -:..HEeywords++t++it+++tdt i+ttt +td+e+4444

find every: I 1]

Restore Defaults | Apply |

(-’;.h

[ |

Cancel I

e. Expand Remote Systems, then Remote Systems LPEX Editor, and then

iSeries Parsers.
f. Select ILE RPG.

g. Clear the Repeat previous specification type check box.
h. Click OK on the Preferences window.

i. Return to the Editor window.

Next let’s see the results of column sensitive editing.

To see the results of column sensitive editing:

Notice that the line the cursor is on is now highlighted in the color you

selected for it in the preference setting for highlight current line.
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& MSTDSP,DSPF =

Line 27 Column 1 Replace

B. .. .FFilename++IPEASFRlent+LKlentAIDevice+.Keyword
00Z700 FMSTDSP CFE E WORKSTN Al
oozs00 FEMPMST UF A E K DISK —!
002900 FPRJMST UF A E K DISEK
003000 FRSNMST UF A E K DISK
003100 D*
003200 D* Compile time array containing error des

-

003300 D ERR s 50 DIM (1 +|
< |

I

a. Move the cursor to line 27, column 10.

b. Make sure the editor is in Insert mode. If the status area shows Replace
press the Insert key.

c. Press the spacebar 3 times.

Notice that only the filename is shifted but none of the other columns to the
right are effected.

Line 27 Column 13 Insert
.....FFilenafe++IPEASFRlen+LKlen+AIDevice+. Keyword

002700 (FMsT  DSP cF | E WORKSTN 4|

002800 FEMPMST UF A E K DISK —

002300 FPRJIMST UF A E K DISK

003000 FRSNMST UF A E K DISK

003100 D*

003200 D* Compile time array containing error des

003300 D ERR 5 50 DIM_l[:I

4 | »

I

d. Press the Backspace 3 times. Once again the filename is shifted but no other
columns are effected.
Next let’s see the results of splitLine
6. To see the results of splitLine:

a. Place the cursor somewhere on a line and press Enter. The text to the right
of the cursor is moved to the next line.

You have changed some of the default editor settings.
Lesson checkpoint

You learned the following:
* How to change some of the default editor settings

Entering SEU commands

You can configure the LPEX Editor to adopt the keyboard and command
personalities of many popular editors. Most editor profiles differ only in the keys
and commands used to perform various editor tasks. Some base editor profiles,
listed below, also add prefix information and a command area at the start of each
line:
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o ispf
* seu
+ xedit

The editor recognizes prefix commands used by these editor profiles. Depending
on which profile you are using, you can enter SEU, XEDIT, or ISPF commands
when the prefix area is active.

If you are an SEU expert you will appreciate the ability to use SEU commands.

To enter SEU commands:
1. Move the cursor into the gray sequence number area to the left of the edit area.

7 wosposer  [EETEIRITOM, =]
Line 31 Column 1 Insert 1 change
........ i e o shenre wizehie it srawe wicehie i o Wi et e 20
dd FMSTDS CF E WORKESTHN _‘}J
oozsoo FEMPMST UF A E K DISK !
002900 FPRJMST UF A E K DISEK
o0o3000 FRSNMST UF A E K DISK
Dtt
D* Compile time array containing error des
003300 D ERR 5 50 DIM (1~
4 | r
I

2. On any sequence number type dd.
3. Go down a few lines and type dd again and press Enter.
Notice that the lines have been deleted.
4. Now type i5 in the sequence number area.
Make sure the cursor is within the sequence number area.
6. Press Enter.
Five new lines are inserted.

o

You have learned how to use SEU commands in the editor.
Lesson checkpoint

You learned the following:
* About editor profiles
* How to use SEU prefix area commands

Requesting undo and redo operations

The editor records each set of changes you make to a file in the Editor window.
The number of changes made since the last file save is displayed on the status line.
If you want to undo a set of changes made to a file you use the Undo operation.
You can also cancel the effects of an Undo operation by using the Redo operation.

Now you are going to undo some of the changes you just made to the file. Then
you will cancel the Undo operation by using the Redo operation. Finally you will
reload the source so that it is back to its original content.

To undo and redo edit changes:
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1. Click Edit > Undo from the workbench menu. Notice that the 5 new lines
disappear.

2. Press Ctrl+Z to undo the last change. Notice that the deleted lines reappear.

3. Click Edit > Redo from the workbench menu. Notice that the lines are deleted
again.
At this point you will reload the source from the iSeries to make sure that it is
back in its original form.

4. Click File > Close on the workbench menu.

Tip: You can also click the X on the PAYROLL tab.

/ MSTDSP.DSPF PAYR ==

Line 21 Column 1 Inzert 1l change
B g e O = ol g T N
00lso0o0 F* EDITSL - Edit application selection dis4|
ogoiso0 F* ACDESR - Edit action code for all maint—
DDZDBD 'E‘"T1‘71‘71‘7“T1‘71‘71‘71‘71‘7"T1‘7“T1‘7"71‘7"T1‘7ftffffftffftffftftfftfft
ooz100 F* This program uses all externally descri.
«| il »
A Save Resource dialog opens asking if you want to save the latest changes.
€ |, PAYROLL.RPGLE' has been modified. Save changes?
\.._.

5. Click No.

6. Go back to the workbench to the Remote Systems view and open the PAYROLL
member in the QRPGLESRC file.

You have learned how to undo and redo changes that you made to a file.
Lesson checkpoint

You learned the following:
* About undo and redo operations
* How to undo and redo editing changes

Invoking language-sensitive help

Inside the editor, there is cursor-sensitive language-reference help available.

This help is invaluable if you cannot remember the order of fields in an RPG
specification or the allowed values for a variable field. This help is available from
the LPEX Editor window.

To receive language sensitive help, press F1 in an Editor window. If the cursor is
on an operation code, you receive help for that operation code; otherwise, you
receive help for the current specification.

1. To access language sensitive help:
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a. Position the cursor over the word MOVE in line 112 of the ILE RPG source.
b. Press F1. Language-sensitive help for the MOVE operation code appears in

a Help window.

Text marked in blue in the Help window contains the link to detailed
information about the topic in blue.

& Help - IBM Websphere Development Studio Client Advanced Edition for iSeries

Search: | |ET]  Searchscope: Alltopics
Contents ., [ || Websphere Development Studio Client foris . | 5 ol iz O
_.] EVALR (Evaluate & MOVE {Move) -
# (1 EVAL-CORR (Assi
Ul EXCEPT (Calculat Free-Form (not allowed - use the EVAL or EVALR operations, f—
1 EXEMT (Write The Syntax or bult-in functions such as %SCHAR, %DATE, %
: DEC , %DECH, S%GRAPH, 6INT, %INTH, %TIME, %
=1 EXSR (Invoke Sut —F' s = b i o . B
B EXTRCT (Extract | TIMESTAMP , %UCS2, %UNS, or %LUNSH )
Sl FEOD (Force End Result
=) FOR (For) Code  Factor 1 Factor 2 Field Indicators
o) FORCE(Farceac | | move | Date Sorcefiski  laget <+ - I8
5l GOTO (Go To) (P) Attributes field
= IF (IR
E IFxx (I
AL J : The MOWVE operation transfers characters from factor 2 to the result
=) IN (Retrieve a De field. Movi ith the Hak h £f 5
_] ITER (Iterate) ie oving starts with the rightmost character of factor 2.
] KFLD (Define Parl -
) KLIST (Define a C When moving Date, Time or Timestamp data, factor 1 must be
2l LEAVE (Leave aC blank unless either the source or the target is a character or numeric
B LEAVESR (Leave || field.
&) LOOKUP (Look Ug—
.J MHHZO (Move Ha Otherwise, factor 1 contains the date or time format compatible with
=1 MHLZO (Mave Hic the character or numeric field that is the source or target of the
21 MLHZO (Move Lov operation. For information on the formats that can be used see Dale
£l MLLZO {Move Low Data Type, Time Data Type, and Timestamp Data Type.
=) MOMITOR (Begin
ve) Ifthe source or target is a character field, you may optionally indicate
i L MOVEA (Move Ar the separator following the format in factor 1. Only separators that are
P g ¥y sep
=l MOVEL (Move Lef || walid for that format are allowed.
S MULT (Mulkiphy )y
= WRT(:‘:\?"":\RE‘“E, If factor 2 is "DATE or UDATE and the result is a Date field, factor 1 is
il = N'T &% ,l‘ l not required. If factor 1 contains a date format it must be compatible
N — 5 1 T wprith tha farnat af *FOATE ar L INATE Ac cnacifind bhe the DATENIT _r‘;l
B (& [ [ @ | | 3

c. Click the link Date Data Type.
The Help page for Date Data Type is displayed.
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& Help - 1BM Websphere Development Studio Client Advanced Edition for iSeries

Search: | [ searchscope: Alltopics
Contents “. B | Websphere Development Studio Client for - ., [} | i < () O

EI ELSE(EBE]
[ ELSEIF (Else If) =l Date Data Type =
1 ENDyy (End & Structure
[ ENDSR (End of Subrout Date fields have a predetermined size and format. They can be
[ EVAL (Evaluate express defined on the definition specification. Leading and trailing zeros are
[ EVALR (Evaluate expre: required for all date data.

[+ L1 EVAL-CORR (Assign cor
[ EXCEPT (Caleulation Tir Date constants or variables used in comparisons or assignments do
1) EWFMT (WritefThen Rez not have to be in the same format or use the same separators. Also,
[ EXSR (Invoke Subroutir dates used for IO operations such as input fields, output fields or
[ EXTRCT (Extract Date/" key fields are also converted (if required) to the necessary format for
[* FEOD (Force End of Dal the operation.
[ FOR (For)
£l FORCE (Force a Certair The default intemnal format for date variables is *IS0. This default
£l GOTO (Go To) internal format can be overridden globally by the control specification
= IF (If) keyword DATFMT and individually by the definition specification
L TFx (IF) keyword DATFMT
L IN (Retrieve a Data Ared
£ ITER (Iterate) The hierarchy used when determining the internal date format and
B KFLD (Define Partsofa || gonarator for a date field is
=) KLIST (Define & Compos
E ii:;s(;ﬁ:::?:z 1 E;ZEr:g:uE:TFMT keyword specified on the definition
B ;ﬁgﬁoﬁxﬁgt 2. From the DATFMT keyword specified on the control
Bl MHLZO (Move Highto L Specification
[2 MLHZO (Move Low to H 3. 7180
[21 MLLZO (Move Low to Le
[5 MONITOR (Begin a Mon There are three kinds of date data farmats, depending on the range
- v| of years that can be represented. This leads to the possibility of a

4l » date overflow or underflow condition occurring when the result of an &
g (8 [ [d |4 ] ﬂ_l

d. Explore the Help window to see what else is available.
e. Minimize the Help window.

f. Select Help > Help Contents on the workbench menu and expand
WebSphere Development Studio Client for iSeries book to see a list of all
help that is available in the product.
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& Help - 1BM Websphere Development Studio Client Advanced Edition for iSeries

Search: m Search scope: All bopics
Contents “. B || WebSphereDevelor . . {5 | v ¢ ¢ 0
g Introduction to £
& [0 Information Map
# [ Accessibility Features We bsp here
= 18M and accessibility Develo pmen t

# [ Installing and migratin = =
=m0 Cnnnac:ng ko Ligux. L?NIX, Windows, and iSeries servers ?t“ d_ 1o c I 1en t fﬂ r
1 [ Developing iSeries server applications using Remote Syst iSeries
# [ Developing iSeries Web applications and services
Developing iSeries Java applications The information in this

# L1 Developing iSeries database applications section describes the

23] Eﬁ Testing and publishing applications to an iSeries server components in the

# (1 pebugging iSeries applications WehSphere Deviopment

B LU Troubleshooting and support Studio Client for iSeries
L Reference product, and how to use

d Glossary them to achieve your
# LI Extending the Remote System Explorer application development

%> Rational Developer product documentation goals.

If you have not already done
so, take a few minutes to
explore the product welcome
infarmation. Click Help =
Welcome.

Feedback

4| | »

g [ & | % | @ .

g. In the left pane of the Help window, click Reference.
h. Expand Language Reference.

i. Expand iSeries programming information.

j- Expand High-level languages.

k. Expand ILE RPG.

I. Expand Language Reference.
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& Help - IBM Websphere Development Studio Client Advanced Edition for Series ] =10 x|

Search:[ [[3) searchscone: Altopics

4 [ Connecting to Linux, UNIX, Windows, and iSeries se
& ([ Developing iSeries sarver applications using Remote
7 L Developing iSeries Web apphcations and services

& U Developing HATS applications

&1 [ Developing iSeries Java apphcations

# U Developing iSeries database applications

& U3 Testing and publishing applications to an iSesies sery
% 1 Debugging Series applications

= I iSeries programming information
= L High-evel languages
= PDF versions of the highdevel langy
®EHLEC/cH+
# L0 cosoLf400
1 [ ILE coBOL
[+ L DB2 UDE for iSeries SQL Reference

+ L RPG IV Concep
#1 L niefinitinns
4 | >

E | 8 | %5 |

i . O | WebSphere Development Studio Chentfort . . [, | 1 ¢| )
B 18M and accessbity <l About This Reference 2]
& [ Installing and migratng

This reference provides inf ion about the RPG IV language as it
is implemented using the ILE RPG compiler with the IBM i5/0S®)
(iSFOSm’} operating system, formerly Operating Systerrh’wﬂm)
(0s/400®)).

This reference covers

« Basics of RPG IV:
o RPG IV character sel
o RPG IV resered words
o Compiler directives
o BPG IV program cycle
o Indicators
o Emor Handling
o Subprocedures
« Definitions:
o Defining Data and Prototypes
o Data types and Data formats
* RPG IV specifications:
o File description
o Definition
o Input
o Calculation
o Output
o Procedure
* Ways to manipulate data or devices:

Having the latest version of the manuals at your fingertips will make it easier
to find programming information. There is also the option to search the help by
specifying a search string. By default, the complete help will be searched.

To limit the search scope:

Tip: If you are using WDSC Lite, you can limit the search scope, however, you
must choose another topic instead of the Reference topic shown.

To limit the search to specific documents;
a. Click Search scope. The Select Search Scope dialog opens.
b. Select Search only the following topics radio button.
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% Help - 18BM Websphere Development Studio Client Advanced Edition for iSeries
Search: | | [ Search scope: Jal topics
Contents “. [ || WebSphereDevelor . [y ] % <l = O
-] WebSphere Development Studio Client for iSeric— About This Reference =
& [ Information Map —
5 0 Accessiity features [T S 1. i1, about the
[ 18M and accessibility  Gasrct implemented using
# [ Instaling and migrating i th the IBM iﬁl'DS(R)
# L8 Connecting to Linusx, UNI * Search only the Following topics:
i L Dewveloping iSeries server em, formerly
# (1] Develoging iSeries Web a ) (0s100%,
& [ peveloping iSeries Java a
[# [ Developing iSeries databs:
[# [ Testing and publishing ap
# [ Debugging iSeries applica :
# [ Troubleshooting and supg aractap el
= LA Reference e e
ek eved words
B o giencs (] | | Jrclues
= Ediit. Remave
5 8 [Seres programm pgram cycle
=1 I High-level lar
. EJl_.:l :’gc“}ecr: ures
- Ok
=0 COBOLJ< .J_I Cm—ndl
& 0 1LE COB fata and'ProlDtmes
@ (T] DB2 LIDE for iSeries SOL Reference o Data ty_ pes and Data formats
B Java e RPG IV specifications:
& L reG/400 o Control (.
= M nERPG o File descrption
= [ Language Refererce o Definition
R oot This Referance o |nput
# [T RPG 1V Concepts - o Calculation
4 | » o Output
(& [ 5 T @ © Procedus .
c. Click New.
The New Search List dialog opens.
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List name:
PyList
Topics ko search:
=l ¥ webSphere Development Studio Client For iSeL®
[™ Infarmation Map
[T Accessibility features
[T 180 and accessibility
O Installing and migrating
£ Connecting bo Linux, UNIX, Windows, and

£ Developing iSeries server applications usin
& Developing iSeries Web apphications and s¢
& Developing HATS applications

5 Developing iSeries Java applications

™ Developing iSeries database applications
[ Detecting and analyzing runtime problems
[ Testing and publishing applications to an i

™ Debugging iSeries applications o
T Tro ing and support

-
™= -
4 | ;I_I

rm_l Cancel I

d. In the List name field, type MyList for example.

e. Expand WebSphere Development Studio Client for iSeries.
f. Select the Reference check box.

g. Click OK on the New Search List dialog.

The Select Search Scope dialog reopens again with MyList selected in the
topic list.

€0 Select Search Scope [ %]

" search all topics
¥ Search orly the Following topics:

New.. | Edt.. | Remove |

[Tok[ | concel |

h. Click OK on the Select Search Scope dialog.
i. In the Search field, type iSeries and programming for example.
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0 Help - IBM Websphere Development Studio Client Advanced Edition for iSeries

| Search: | iseries and programming| |ig:i ISearch scope: Mylist

j. Searching requires a help index and it takes approximately 10 minutes to
create the index in your workspace. If you want to complete the search
query, click GO.

The search results display.

€0 Help - 1BM Websphere Development Studio Client Ad

Search; | iseries and programming JE Search scope: My
Search Results s A

-

5 iSeries programming information
The iSeries proaramming information is organized into
high-level language, data definition, and contral
language categories. Feedback. ..

B Program call definitions
‘fou need to select one of the follawing three options
on this page of the wizard before proceeding: Use an
iSeries™ program or procedure Use a Java™ bean Mo
program call Use...

2 iseties Program Yerifiers
Cption Description Defaulk Local Files Prompt for
connection: Manually specify an Series™ connection,
in a prompt dialog box, to use to verify local files. The
conneckion...

You have accessed language sensitive help.
Lesson checkpoint

You learned the following:
* About language sensitive help
* How to access language sensitive help

Prompting language specifications

Instead of entering or changing code directly in the Editor window, you can use
prompts. When you request a prompt for a specification line, a window appears
where you can enter or change that line using entry fields.
1. To access prompts:
a. Return to the workbench. In the Editor window move your cursor to the
D-spec on line 33.
b. Press F4 (You can also click Source from the workbench menu and then
click Prompt.)
You see the iSeries Source Prompter at the bottom of the workbench. The
iSeries Source Prompter shows the specification line broken down into its
individual fields.
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[ £ parmoupeae x PO =0|Ezox =0
Line 33 Column 9 Replace &
..... DNafle+++++++++++ETDSErom+++To/Lt++ = [ cobal Defin
003300 D ERR 8 Al B0 Fles
003400 D EMESS 8 a=il : — Fields
003500 E* P L Indicato
003600 Crrrhkhhhhhhhhkhhhhhhhhrhhhhrhhri + L&}Maianced
003700 c* MATNLINE CALCULATIONGS
003800 C*‘k*‘k*‘k*‘k*‘k*‘k‘k**‘k*‘k***‘k*‘k*‘k*‘k*‘k*'
003800 C* This mainline routine contro.
004000 C* editting. Using the functio:
004100 Cc* format, vou can transfer frol,
« | i3
| 4] | =i
rl-'lmbe System Details [ [Series Table Yiew l iSeties Commands Log (E{ iSeries Source Prompter 332 \‘\H =im
Line bype: iD: Definition ;I I V‘{B App‘yll <oy Revert}
Externally Data structure Definition Internal':'
Name described type type  From TofLength data typ
| ERR W N B | sol §
.....DName+++++++++++ETDsFrom+++To/ L+++IDc. Reywords++++4
D ERR 8 50 DIM(10) CTDAT_
4 | ﬂ‘l

On the iSeries Source Prompter toolbar you can use the three push buttons
to: Disable source prompt view, Disable syntax checking, and Change to
insert mode.

2. To display context sensitive help for any field in the iSeries Source Prompter:
a. Tab to the Keywords field.
b. Press F1 to see help for this field.

The Help window with help for the D spec keywords opens. If it doesn’t
appear automatically, you might have to bring it to the foreground by
clicking on its icon on the Windows taskbar.
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& Help - 1BM Websphere Development Studio Client Advanced Edition for iSeries

Search: | [ searchscope: mylist
Contents i, [ | WebSphere Development Studio Client . . [ | & <) ¢ O
- Summary According to Definition Sp 4 || Definition-Specification Keywords =
=1 Definition Specification Help ALIGN
) Definition Specifications * —T‘— ariel
%) Definition of Externally Described D ST Vi\rI‘FrP:J]E
) Externally Described Data Structure : W
:l Definition of Program-Described Dal . masmq pointer name)
=1 Program-Described Data Structure | CeSDinumber | DF
) Definition of Externally Described D . —H’_L’AQS[P&&; i \
| Externally Described Data Structure * CIOI"JTST‘ e N - ta; wlae
=1 Definition of Program-Described Dal : mﬁmﬁ
—J ng_a_m.oemlh&j D_at ikt s DATFMTformat{separator])
1 Definition of Named Constant « DESCEND
1 Named Constant Keyword PRGN
) Definition of Standalane Field . %ﬁ%&ﬁﬁ%ﬁﬂiﬂ{l -
J Standalone Field Keywords . ':XPDF!.T{rewterr:.al na:neji
| Definition of Prototype or Procedur E‘{TFLD feld n
1 Prototype and Procedure Interface : —[__—IE;{TFMT ::E;wde A
= i { 1
e e e Ll o o EXTMAME(file-name| format-name}- “ALL

C) Fratatyiies Paramecs/ Kehon “INPUTFOUTPUTIKEY))

Defi ation 5 il I
nput Specifications . Wﬂ e ) .
Calculation Specifications » —WRIUCII CLFCWIDENFCNOWIDEM] [FJAVA: class-

name: iname
1::;5?5m?§0m e FROMFILE(file_name)
ations, Expressions, and Functions . ’MEQRTHB{IQJA@ namej}
ndixes o INZ{(initial value
ner's Guids o LIKE name
scumentation I . LH‘fEEli:il’dlata structure_name) ) ‘
information o LIKEREC(intrecname{:*ALLFINPUTI*OUTPUT [*KEY))
v o NOOPT

El} | 3 o OCCURS(numerc_constant)
@ .‘}.I Em —..E—EEEWE—EMMCWJ

You will see words in the help that appear in a different color than the
regular text. These are help links, and they show that there is additional
help available on that word or phrase.

c. Click on any link to see specific help for that item.
Minimize the Help window.

In the workbench, double-click the PAYROLL tab to return the Editor
window to its original size.

You have used prompts to enter code.
Lesson checkpoint

You learned the following:
* About prompts
* How to use prompts to enter code

Indenting source

When editing ILE RPG source, it can be difficult to determine the beginning and
ending of constructs. The iSeries Indent view allows you to see your source with
constructs in an indented mode.

To indent source:

1. Click Source > Show Indentation from the workbench menu. You can display
the iSeries Indent view as a full view.
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Line 34 Column o
i E1-L5 Global Defin
D* Compile time array containindalfj | E{@ﬁm
D ERR 8 | | ® = Fields
D EMESS 5 : | BLg Indicato
E* - (& Main Proced
C'k*‘k't‘k*‘k*******‘k***‘k***‘t*‘kt**‘k**'
C* MAINLINE CALCULATIONS
c*******************************'
C* This mainline routine contro.
0 o] C* editting. Using the functiols
Al J »
L kil | 2
[R5t ot et ol e sries Conmercs o s irt. 35 ]
Column 16 Insert Browse

Compile time array containing error descra

D#*

D ERR s 50 DIM(10)—
D EMESS ] 50
E*

(et b b S R e e e R e R R R R R

al | -

1L

Column 1 Inzert

Determine update mode and perform

C

C | | | Select

C | | | WHEN ACODE = "TAT a)
ad | | | | MOVE L =
cC | | | | WRITE RCRSN

o*

cC | | | WHEN ACODE = TAT a
c | | | | MOVE TAT

(@ | | | | UPDATE RCRSN

o*

C | | | When ACODE = DT

G | | | | MOVE i b

c | | | | UPDATE RCREN

C‘k

c | | | WHEN ACODE = 'C7

G | | | | UPDATE RCRSN

=

0le7l | | | ENDSL @
4| | _I"
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3. Scroll down to line 150. The Row shown on the status bar is the cursor
position. In the iSeries Indent view you see some nested conditions with
indented lines. As you will notice this helps to recognize the beginning and
ending of these conditions.

Tip: The Indented view is Browse mode only and cannot be edited.
4. Click the X in the top right corner of the view to close the iSeries Indent view.
5. This returns you to the Editor window with the PAYROLL program.

You have used the Indent view to see the beginning and ending of constructs.
Lesson checkpoint

You learned the following:
e About the Indent view
* How to indent source

Finding and replacing text

The LPEX Editor also has a powerful find and replace text feature. You use the
Find and Replace window to search for an item. You can search for a word, a
partial word, or a sequence of such. You can also enter a pattern you want to
match, provided that the pattern follows the rules of regular expression. You can
replace the found search item. If the entered text or pattern is found, the cursor
moves to either the next or previous occurrence of the search item, according to
your chosen search direction, and replaces the found text according to your
selections.

To find and replace text:

1. Press Ctrl+Home to go to the top of the file. Tip: When you press Ctrl+Home
to go to the top of a file or Ctrl+End to go to the bottom of a file, a quick mark
is set at your cursor position. This allows you to return to that line by pressing
Alt+Q. Ctrl+Q will set a quick mark.

2. Click Edit > Find/Replace from the workbench menu or press Ctrl+F.
The Find/Replace window opens at the bottom of the Editor window.
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[ Zpamou peaie. x LR =5

Line 52 Column 26 Replace

..... CLDNDlFactor1+++++++lpccde(E)+Factor2+++++++Resul
005000 € eval *INLR = *on Al
005100 * MATIN SUEROQUTINE
005200 c MATN =
005300 c dou *INKC
005400 c EVAL *ING0 = *OFF
005500 c EVAL EMEESES = *BLANK
005600 c EVAL EMPAPL = *BLANK
005700 C EVAL PRJAPL = *BLANK
005800 C EVAL RSNAPL = *BLANK
005900 o
006000 C* Write the SELECT format to display. If end
006100 c*
006200 c*
006300 C alali not *IN60
006400 C EXFMT SELECT
0o0es500 c *INKC IFEQ L I

-

4] | _b_I_J
H'ldll_ﬂEﬁiE.Ll Previous | &l
Replace | Replace | Replace al
[~ Case sensitive [~ Wholeword [~ Regular expression ¥ Wrap [ Select found text
I~ Restrict search to selection |~ Restrict search to columns Start colurn [1 &nd colurn [50 ‘

At the bottom of this window, you will notice that you have some options to
select from, for example, search only in certain columns, etc. You want to find
the first occurrence of BEGSR.

3. In the Find field, enter BEGSR to find the start of a subroutine.
4. Make sure the Replace field is blank.
You would use this field for text replacement.

The Editor moves the active line to line 52, which contains the first BEGSR
phrase in the file.

5. Click Next to go to the next location of BEGSR in the file.
6. Click in the Editor window to close the Find/Replace window.

You have searched for an item in your source using the Find/Replace window.
Lesson checkpoint

You learned the following:
* About the Find and Replace window
* How to find text in source

Filtering lines by string
The editor allows you to filter or subset your source so that you see only lines
containing a given string. Filtering lines makes it quick and easy to find lines

without having to scroll through your source.

To filter source by string:
1. Double-click the variable EMPAPL in the Editor window.
2. Select Edit > Selected > Filter Selection from the workbench menu.
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./ PAYROLL RPGLE X =8
Line 56 Column 35 Replace
..... GLDND1Eactor1+++++++0pc0de(E]IExtended—factor2+
005600 (e EVAL EMPAPL = *BLANK
oo7900 c* If EMPAPL (employee maintenance) equals X,
o0ss0o0 c when EMPAPL = "X'
035800 c IFEQ iy
036000 C OREQ et
037300 o IFEQ T
038300 c IFNE Lot
f] 038400 c ANDNE T}

3. Move the cursor down a few lines to line 79.
4. Expand line 79. This expands the section up to the next instance of EMPAPL.

rowore  [URNTETED. e
Line 789 Column 1 Replace
B.......2....4.. .20 00400300 ik bkl L5
00se00 c EVAL EMPAPL = *BLANK
DU?QDDl c* If EMPAPL (employee malintenance) esquals ¥,
o0s000 C* branches to label EMPTAG.
goelon Cc* If PRJAPL (project maintenance) equals ¥, t
00sz00 C* branches to label PRJTAG.
008300 C* If the prior two tests were not successful,
008400 C* reason code maintenance. The program will
gogsoon C* next executable operation.
008600 c*
008700 c SELECT
gogsoo C when EMEPAPL = TX¥T7
035800 c IFEQ gy
036000 (2 OREQ e &
037300 C IFEQ v
036300 c IFNE S
ff o3s400 C ANDNE rXT

Now you want to show the entire source again.
5. Click Edit > Show all from the workbench menu or press Ctrl+W.

Your cursor is still positioned on the same line that you moved the cursor to,
even though all lines are now showing.

You have filtered your source so that you see only lines containing a given string.
Lesson checkpoint

You learned the following:
* About filtering source
* How to filter source

Filtering lines by type

To help you navigate quickly through your ILE RPG source the editor allows you
to filter lines based on the line type. Imagine you want to see where all the
subroutines are defined in your source.
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AL PAIROLLRPGLE XN i
Line 1 Column 1 Replace

UuDlDQI E‘**********************************************1ﬂ
ooozoo F* PROGRAM NAME - Payroll
000300 F* DES  New » brting master file ma:
oopo400 F# lv described workstat:
DDQEGD Fr*x®x®tx Pl‘mt F4 et bt b S e A S S
000600 p* INDEEREE e
000700 F* 50 Saye In CHAIN operation
0ooeoo F* &0 = <0 dition
000900 F* 90 ng C;rl+l;“-s|=;rt n delete regquest
001000 F* KC Paste CEri Y t‘?d .
001100 F* ED tion selection
001200 F* KE Select bl selection
001300 F* KF | _ | selection
001400 F* KG Deselect i l-ode selection
goisoo £ 1R GEECD -
001600 B ko ok B Chrl W Code i B T e
001700 F* §UB e . Comments
po1eaon F* EDI . Contral ion display
poisoo F*  ACD 1 maintenanc
UUZUDU F***********%‘************1‘ kxhtkhkhthkhthkhhkta
00zioo F* This program uses all  Ermos described is
4| | »
|

To filter lines by type:
1. Right-click in the Editor window with the PAYROLL program.
2. Click Filter view > Subroutines on the pop-up menu.

All source lines with BEGSR or ENDSR are displayed allowing you to move
quickly and easily to the desired subroutine in your file.
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Line 52 Column 1 Replace
I...rCLUNDlFactorl+++++++OpCode(E)+Pactor2+++++++Res

+

# ooszoofl c MAIN BEGSR
i 010200 c endsr
u g0li000 C RENTAG BEGER
i 017600 C ENDsr
i 018300 C EMEPTAG BEGER
it 025700 c ENDSR
it 026400 C PRITAG begsr
H 033500 C endsr
H 034700 c BEGSR
| 040400 c BEGSR
i 042700 e ENDSR
i 043100 C : CDE BEGER
i+ 044000 C ENDSR
H 044400 C CHGCDE BEGER
it 045400 o ENDSER
H 046100 BEGSR DELCDE;

H 047200 ENDSR;

tH 047600 BEGSR INVCDE;

H 047900 ENDSR;
I

3. Move your cursor to the line with the subroutine declaration CHGCDE (line
444).

4. Expand the declaration to show all lines in this subroutine. Now you could
work with the source inside this subroutine.

5. Right-click in the Editor window and click Show all on the pop-up menu.
You have filtered lines in your source by line type.
Lesson checkpoint

You learned the following:
» About filter source by line type
» How to filter source by line type

Searching multiple files

If you would like to search through the members in a source physical file or
through the files in a local directory, you can use the Search tool. The Multi-File
Search utility allows you to search for a particular string of text in many members
on the host. This function can also be used on local files.

To search multiple files:
1. Click Search > iSeries from the workbench menu.
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0 Remote System Explorer - PAYROLL.RPGLE - IBM Websphere Development Studio Client Advanced ... !]__i‘lm
Fle Edt Source Compile(G) Navigate Project Dats Run Window Help

5 search.. Qi L. | Ei'IERemote Syste...

£ Remote. ., |
: - Text » 1
Line 1 Colutt—s z P e e
SRR R 12 e raralchra) e ket € pietlstinithiniral whis 3 aaLiatiey e in o R ela b R i e e
uﬂuluu F?*E‘:*?_’*‘.‘.‘*R’:**t‘:’.‘***?**’.’*‘.‘-*?*?**‘f?*:‘**?*ﬂ'ﬂ'?‘x*':."::*‘.ﬂ
goozo0 F* PROGRAM NAME - Pavroll
non2nn ™ T STCT TUTCT T Masiom srntmmamdsamm slmmds nas a1 a swuwma
The Search window opens.
2. In the Search string field, type ENHRS.
B iSeries Search |l'3 Data Model Search | ' Fie Search | 4 BusinessObjects Enterprise Search | U, Java sear 4] »
Search string: | EN-RS | =] a| ™ Case sensitive
Cornection: [s400a =] NawI

~ Target

Library: f| RSELABXX ~| 4| Browse...
5 :I _! _l

File: QDDSSRC v| 4| Browse...
[ =14 |
Member:| *ALL| ;I:l Browse... I

¥ |Source members [T Dsta membets

1~ Columns
& all columns

" Between I 1 and(G) I:_:._:

C petween(H) [ and end of line

Search Cancel

g
:

The Connection field should contain your iSeries server name, otherwise enter
it there.

3. Under Target in the Library field, type RSELABxx.

4. Under Target in the File field, type QDDSSRC to search all members in this
source physical file.

5. Under Target in the Member field, select *ALL.
6. Click Search.

The Multi-File Search window lists all the lines in all the files that reference
ENHRS.
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& Remote Search X,

.
Remote Syste.,, |Esrles Table .., |iSeries Comm,., |iSeries Indent

"ENHRS" - 3 Occurrences in 3 Members m Sﬁ =
=0 RSELABKXQDDSSRC(EMPMST) (1 match)
| {Line 18) & ENHRS R
=G RSELABRXIQDDSSRC(MSTDSP) (1 match)
[ (Line 99) & ENHRS R B 11 37REFFLD{RCEMP/ENHRS *LIBLJEMPMST)
= B RSELABXX/QDDSSRC(REFMST) (1 match)
b [' (Line 27) & ENHRS 3 1  TEXT(EMPLOVEE NORMAL WEEK HOURS') ]

7. Double-click the last line in the list.
A ENHRS 3 1

TEXT('EMPLOYEE NORMAL WEEK HOURS')

The member REFMST is automatically loaded into the editor and the cursor is

placed on the correct line.

~

[/ MSTOSP.OSFE |/ PAYROLLRPGLE m =S
Line 27 Column 1 Replace
[ N R e Name++++++RLen++TDpE. . . ...Functions+

000024 A COLHDG (' 14]
00o02s A EUSRI 8 TEXT (" EM]
000026 A COLHDG ("]
[oooo27 A ENHRS 3 1 TEXT ("EM] |
000028 A COLHDG ('t
000029 A EPHRC 5 4 TEXT (" PR(
0ooo030 A COLHDG ("1
000031 A EPHRY 74 TEXT (" PR(
000032 A COLHDG (" |
000033 A EPHRP 7 1 TEXT (" PR(
000034 A COLHDG ('
000035 A EPNRC 5; & TEXT ("NO!
000036 A COLHDG ('t
00p037 A EPNRY 7 TEXT ("NOI
000038 A COLHDG ('?
000038 A EPNEP 7 1 TEXT ("NOI
000040 A COLHDG ('?
000041 a EHWRK 5 4 TEXT (TEMI
000042 A COLHDG ('}
000043 A* PROJECT MASTER RELATED FIELDS
000044 A PRCDE 8 TEXT (' PRiw
< | L[_I
|

8. Click the X in the REFMST tab to close the REFMST file.
You have searched through members in a source physical file.
Lesson checkpoint

You learned the following:
* About search
* How to search through members in a source physical file
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Comparing file differences from the Remote Systems view

If your product undergoes many changes, you will find the Compare utility useful.
It allows you to compare different versions of a program and find the differences.
There are two ways to do a compare: use the Compare utility in the workbench or
use the Compare utility in the CODE tool. The compare in the CODE tool is more
intuitive but requires you to start the CODE Editor outside of the workbench.

Using the compare utility in the workbench you can view the differences between
two files by comparing them. You can compare different files, and you can
compare versions in the Workbench with versions in the repository or with the
local edit history.

After a comparison is carried out, the Compare Editor opens in the editor area. In
the compare Editor, you can browse through all the differences and copy
highlighted differences between the compared resources. You can save changes to
resources that are made in the comparison editor.

Using the compare utility in CODE you can also view the differences between two
files by comparing them. You enter a name of a file to compare against the file in
the CODE Editor view. You can type the name of a file, or you can select one from
the list of files already open in the editor. If you type the name of the file that is
not already open in the editor, it is loaded into the editor. If no file is specified, the
current file is compared against a new, untitled file. The current file appears on the
left side of the Compare view, and the specified file on the right. You use the
Compare menu to view the next and previous mismatch and to select options such
as ignore case, font, protect view and show mismatches only.

Tip: Make sure all lines show in the source before starting the Compare tool.

To compare files in the workbench:

1. Click Window > Preferences from the workbench menu. The Preferences
window opens.

2. In the left pane of the Preferences window, expand LPEX Editor.
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% Preferences

| type filker bext

B Internet

- iSeries Projects
|- J2EE

[+ Java

- Jython

- Logging

=] E3

Compare =
al ¥ lanore leading blanks

v Ignore trailing blanks

[+ Ignore all blanks

[~ Ignore case

™ Ignore comments

i=|- LPEX Editor

Appearance
Block
Controls
Find Text
[ Parsers
Print
Save
Tabs
User Actions
User Commands
User Key Ackions
User Mouse Actions
Resel

[V Ignore sequence numbers

[T Column restricted compatisan

atart columr ] |

Apply

‘l | _'lj | Restore Defadlsl
@) | oK [

Cancel

Click Compare under LPEX Editor. In the right pane of the Preferences
window make sure that the Ignore blanks check boxes are selected.

Click OK in the Preferences window.

Back in the Editor window of the PAYROLL member double-click the
PAYROLL tab.

Click Edit > Compare to file on the workbench menu.
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# Remote System Explorer - REFMST.PF - IBM Websphere Development Studio Client Advanced Editi... [H[=] E3
File [ Edit |Source Compile{G) Navigate Search Project Data Run Window Help

I i & Urica Chl+Z ] 3 i & I i ] ] 12| iﬁgem Syste..,
l W nedo Gy,
| iekcn ciriey
Ay CtriTrnsert = 8
CEris=Y
Replace
W Delete Delete ame++++++RLen++TDpB. . ... .Functions+
Select All Chrh+a COLHDG (" 1]
T
Find/Replace. . CHiF USRI B TEXT ( EI:I]
Find Mext Shift+F4 CULHDGL
e INHRS <) ak TEXT (TEMI
S COLHDG ('}
Find Othe >
Sl . PHRC 5 1 TEXT (" PRC
Show Al Chrigil
COLHDG (71
Add Bookmark, .. PHRY i A TEXT (T PR(
Add Task... COLHDG (71
] T
15 ey
Selected » - ,
o AL ENRC 5 1 TEXT ("NOI
i COLHDG ('}
ENRY 7 1 TEXT ( TNOM
COLHDG ("}
FNEP 7 1 TEXT ("NOI
=——— —— COLHDG ("1
-_.-_{I'lt':'-ﬁ Assist :lr".-_i,;r:-.: HWRE 5 1 TEXT (' EMI
show Tooltip Description CEr-5Hft+-Spate COLHDG ("}
000043 AT PROJECT MASTER RELATED FIELDS
oooo44 A PRCDE 8 TEXT (T PR(w
4| | »
|

The Compare window opens.
7. Expand your connection.
8. Expand *LIBL.
9. Expand RSELABXxX.
10. Expand QRPGLESRC.
11. Select member PAYROLLG.
12. Click OK.
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# Compare File [i5¢]

Select a member

| PAYROLLG

B QHLPSYS.¥ib.prod-sys ]
[#-Ey QUSRSYS.*ib.prod-sys
By WFLABXY . *lib.test-usr
[# B, ADTSLAB.*ib.prad-usr

-

@[5 EMPMST *file pf-dta
#-[5 EVFEVENT *file.pf-dta
w-[F PRIMST, *file.pf-dta

[+ |5 QCBLLESRC *file. pf-src
[+ 53 QCLSRC *file pf-src
=[5y QCMDSRC #file pf-src

QDDSSRC, *file. pf-src

=[5 QRPGLESRC, *file.pf-src
G pavROLL.rpgle

| oK I Cancel I

The editor now will show the differences of these two members PAYROLL

and PAYROLLG .

You can move from mismatch to mismatch by right-clicking the source and

selecting Compare » Next Mismatch, or by using Ctrl+Shift+N.

Mismatches in PAYROLL and PAYROLLG are highlighted in different colors

so that you know where the mismatched lines are in each file.
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|
& Remote System Explorer - PAYROLL.RPGLE - 1BM Websphere Development Studio Client Advanced ... =] E3

File Edt Source Compile{G) MNavigate Search Project Data Run Window Help
It5- @ |4-0-Q- (G5 )59 iErmsese..
[P e
|
: _ | =8
Line 94 Column 1 Replace :
Bt i i s s e s e et S s e
009200 C EXSR PRITAG A
009300 (1 '
Qo94nn P when ESNADL, = T¥WT
09500 & EXSR RENTAG |
09500 c EXSR RSNTAX |
G966 o B
009700 c* if KC end program
009800 C if *INKC
009900 c leave
010000 c endif
010100 & enddo
010200 5 endsr
010300 C*
nln4nn C*T":‘rﬁ—t*ﬁ':‘.—1‘—:"1‘—‘."ﬁr:‘rﬂr:‘—‘.*ﬂ—:‘r*:‘r:‘r:‘*ﬂ—*:‘r:‘r:‘r?*:‘*:‘+1‘r+*?*+*+."1‘7“7'
010500 C* Reason Code Malntenance,
Olueuu |:+‘k1".*—Tr*-.'r*‘kﬂ'ﬂ—?********T********%**—******:*****4\'*1
010700 c*
010800 C* Housekeeping, clear display fields and reset
010900 c* |
011000 c RENTAG BEGSR
011100 c Dou *INEKC -
4 | of
[one or more mismatches found. |
L ' l
] o° | | |

13. Click Ctrl + Shift + N to find the next mismatch.
Next, end the compare session.
14. Right-click the source and select Compare » Clear.

You have compared different versions of the program and found the differences.
Lesson checkpoint

You learned the following:
* About compare
* How to compare files

Checking syntax
One of the powerful features that the LPEX Editor shares with SEU is its ability to
syntax check your source. Syntax checking can be done either when the cursor
leaves each line of source or all at once on either the currently selected source or
on the entire source member.

Now you will create a syntax error and watch for the prompt to correct it.

To syntax check the file:
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1. In the PAYROLL Editor window move the cursor to line 211 which contains

EXSR ACDESR. You might already be on that line but if not, type the line
number in the sequence number column, or scroll down.

2. Append an X to the EXSR op-code to make it EXSRX.
3. Move the cursor off of the line.
An error message appears to draw attention to the error.

T TINCETEO, / REFHSTRE | G
Line 212 Column 31 Replace 1 change

..... CLONDlFacto r1++++-+++cp:ci>..d| (E)+FactorZ2+++++++Re=zul
021000 = EMPNO CHAIN EMEMST |
1021100 c ACDESR

RNF5014E Operation code 18 not valid; specification :
021200 c ELSE
021300 c LEAVESR
021400 C END
021500 c* end of error loop
021600 c ENDdo
021700 c*
021800 C* Display employee maintenance format 2|
021900 c*
022000 C EXFMT EMPMNT
022100 4 IF *INEKD
022200 C*end of subroutine
022300 LEAVESR
022400 c END
022500 5 IF *INKE
022600 c* End of one loop
022700 C iter
022800 & END
022900 o* =
4| | Lf_l
I

4. Move the cursor onto the pink error message.
5. Press FL.
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D Help - IBM Websphere Development Studio Client Advanced Edition for iSeries

Search: | |EEE]  searchscope: MyList
Esiants % 0| Cohlwelw o
@ WebSphere Development 5 -

%" Rational Developer product

RNF5014
Operation code is not valid, specification is ignhored.
30

Cause ... .: The Operation code is not valid. No further checking
is done on the specification. The operation must start with a valid
Operation Code and can be followed by an optional Operation
Extender. If specified the Operation Extender must be one or mare
of A,D,E.H M, N, P, R, T,orZ and enclosed within parentheses.

Recaovery . . . : Specify a valid operation, or omit the specification.
Compile again.

(C) Copyright IBM Corporation 1992, 2006. All Rights Reserved

4| | »

B (& | % [ W z

This opens a window with second level help for the error.
6. Minimize the Help window.

7. Change EXSRX to EXSR to correct the error. (Similarly, you can use Edit > Undo
to correct this).

8. Move the cursor off the line you just fixed.
The error message is automatically removed from the editor.

Tip: You can toggle automatic syntax checking. Click Window > Preferences
from the workbench menu and then expand Remote Systems, iSeries Parsers.
Now, select the language you want to change the settings for in the left pane of
the Preferences window, select or deselect the Automatic syntax checking
check box and then click OK.

Tip: You can syntax check the whole source member currently in the editor by
clicking Source > Syntax Check All.
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0 preferences

I type filter bext

[# Profiling and Logaing _:_[

|=1- Remate Systems
Communications

=1 B3
ILE RPG

1
4
]

[F" Automatic syntax checking ]
IV Automatic syntax checking of SQL statement

[+ Debug ™ Automatic uppercasing
i F!I e —Enker key behavior
: I Repeat previous specification type
y - Cache - =Y
- Command Execution
- Commands Subsystem — -
: IFS Files Subsvstem Position | FACTOR1
i Jobs Subsystem ]_ Set free form C-specihcation cursor posiHoan
+ Objects Subsystem :
Positicr | 3
= Program Yetifiers el
- DDS PRTF I et 0-Specification cursor position
[ ILE COEOL s | o
Fosition FROM
E-ILE RPG
- Data V| Automatic indent
Defines ¥ Automatic clasure of contral bloch
= PCML
T_able Miew ™ User defined tabs(G)
- Logging
: Pacouunrd II {: Control
i ET"J Remoke Systems LPEX Edit-] -
i Sepe—— 7 I ..... HEeywords+ét++++++++4444+444
: (=] iSeries Parsers
B =
: Andeyvery: | o
7 | | Restore Defaults | Apply |
) oK I Cancel I

You have learned how to check syntax.
Lesson checkpoint

You learned the following:

* About syntax checking

* How to syntax check your source

* How to set syntax checking preferences

Understanding your program code with the Application
Diagram

Important: This lesson only applies to WebSphere Development Studio Client for
iSeries Advanced Edition.

In this lesson, you learn about the Application Diagram view and how to switch to
it, how to view the program topology, and using the viewer to locate a subroutine.

The Application Diagram provides a graphical view of the different resources in an
i5/0S native application and their relationships to each other. There are two
different diagrams that you can look at in the Application Diagram view: a Source
Call Diagram and a Program Structure Diagram. The Source Call Diagram takes
ILE RPG source as input and displays a call graph showing subroutine and
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procedure calls. The Program Structure Diagram takes program and service
program objects as input and displays the binding relationships between them as
well as the modules bound into each program and service program.

To learn more about how to use the Application Diagram, see |Launching the|
[Application Diagram|and |[Using the Application Diagram|

1. Open the PAYROLLG.rpgle source member in the QRPGLESRC source file.
2. Click Source » Visualize Application Diagram

Source Compile(G) Navigate Search Project Dal
New »

Prompt F4

| Syntax Chedk al

|2 Verify Ctrl+5hift+V
2 Verify (Prompt)...

:-i-: Visualize Application Diagram

Convert All To Free-Form u
Select Format Line...

Show Indentation

Shaw felds

JCOPY Member 3

ILE RPG Help »

Resequence All Lines

Eemove Messages

Refresh Ctrl+F5
Refresh Outiine View Cirl+5hift+F5

The Application Diagram opens.
3. Select the subroutine ACDESR.

// PAYROLL RPGLE =0

"'t_l ;I ~—— palette — »
—' INVCDE [% Select
'+, Zoom
i EMPTAG = Note 2

"'I:E' DELCDE

"t—' ADDCDE
[ nl:_l
TF= RsNTAG

C'I:E: ..CHGCDE v
4] [
Notice that the box is now highlighted and all relationship arrows are
highlighted. Arrows pointing away from the subroutine point to subroutines
that ACDESR calls and arrows pointing to the subroutine ACDESR indicated calls
to ACDESR.
4. Right-click the subroutine ACDESR and select Show Properties View.
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L o
=[F~ ACDESR

e o = AddNote

= CHGCLE " ||

The Properties view opens, and displays information about the currently
selected subroutine.

Select the Calls tab to view a list of the respective subroutines which the
subroutine ACDESR calls and the lines where it is called.

(TN, oo ystenotas 1 e Tae V| S conmac o ¥ED
| a
Gmed | -k ACDESR 2
L | Location | & Startine | End line | Type | Language
Called by ADDCDE PAYROLL.RPGLE 431 440 SUBROUTINE RPG
CHGCDE PAYROLL.RPGLE EEN] 454 SUBROUTINE RPG
DELCDE PAYROLL.RPGLE 461 472 SUBROUTINE RPG
INVCDE PAYROLL.RPGLE 476 479 SUBROUTINE RPG

a I_'Iﬂ

The list of subroutines can be used to quickly jump to the specified line in the
source. Likewise, the Called by tab shows the list of subroutines which call the
ACDESR subroutine.

In the Calls tab, double-click the CHGCDE subroutine.
This takes you into the source to the call to subroutine CHGCDE.

/ PAYROLLG.RPGLE X = PAYROLLG l

Line 444 Column 1 Replace

.  CLONO1Factorl+++++++0Opcode (E) +Factor2+++++++Result++
043100 C ADDCDE BEGSR
043200 C IF NOT *INS0 AND ACREC =
043300 c EVAL *INeD = *ON
043400 = MOVE ERE (5) EMESS
043500 C ELSE
043600 C IF NOT *INS0 AND ACREC =
043700 C MOVE ERR(6) EMESS
043800 C ENDIF
043900 C ENDIF
044000 C ENDSR
044100 C*
044200 C* The following code wverifies the change request.
044300 C*
044‘!00. c CHGCDE BEGSR
044500 C IF *IN50
044600 = EVAL *IN6O = *ON
044700 C MOVE ERR(7) EMESS
044800 C ELSE
044900 C IF NOT *INS0 AND ACREC =

Return to the Application Diagram view by selecting its tab. You can also save
the application diagram as a text or image file.

Right-click inside the Application Diagram view, and select File » Save as
Image File or File » Save as Text File
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2 Select P (= Print...
Change Layout...

o5 Arrange Al Save As Text File...
View L4

.+,‘ Zoom »

Find Main Entry Point

Preferences [
[ | Show Properties View
Switch View »

Depending on your selection, the application diagram will be saved as either
saved as an image file, or a text file in the specified directory.

Lesson checkpoint

You learned the following:

* The basics of the Application Diagram view

* How to switch to the Application Diagram view

* How to navigate through the application topology

* How to save the application diagram as an image or text file
Related information
[Launching the Application Diagram|
[Using the Application Diagram|

Module summary

In this module, you learned how to use the LPEX editor’s different features.

Lessons learned

* Change the default settings of the LPEX Editor Parsers

» Change the color settings and font used by the Editor

* Change the default behavior of the Enter key

* Use SEU commands to edit source

* Undo and redo source changes

* View language sensitive help for the MOVE operation code

* View a list of all help contents

» Limit the search of help to specific documents

» Search the help

* Request a prompt for a specification line

» Display context sensitive help for any field in the iSeries Source Prompter
* View the beginning and ending of constructs in your source

* Use the Find and Replace window to search for an item in your source
* Filter or subset your source

 Filter lines based on line type

» Search through members in a source physical file

* Compare different versions of a program and identify the differences

» Syntax check source by line
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View help on syntax errors

Assessment

What does column sensitive editing do?
Where do you define LPEX Editor settings?

How do you configure the LPEX Editor to adopt the keyboard and command
parameters of many popular editors?

What operation must you use to undo a set of changes made to a file?
How do you cancel the effects of changes of an undo operation?
What is language sensitive help?

How do you access language sensitive help?

What do you use instead of entering or changing code directly in the Editor
window?

What view allows you to see source with constructs in an indented mode?
What window do you use to search for an item in the current source?
How do you filter source?

How do you search multiple source files?

How do you compare files?

How do you syntax check source files?

Verifying and compiling source

This module teaches you how to verify and compile RPG in the Remote Systems
LPEX Editor. When errors are found by either the verify or the compile step, the
iSeries Error List appears. The iSeries Error List is a powerful tool that manages
errors found by verify and compile utilities. You will become familiar with these
tools, the various capabilities of the iSeries Error List and the RPG program that
you have created.

Learning objectives

Check for semantic errors on your workstation

Start the Program Verifier tool

Use the iSeries Error list to locate each error in the source
Use content-assist to fix an error

Save your source

Re-verify source

Change compile preferences

Invoke the compile command

Change the current library using the Command field in the iSeries Table view
Start an interactive connection

Invoke the payroll program

Time required

This module should take approximately 20 minutes to complete.
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Verifying the source

Now you get to play with one of the most powerful and unique features of the
Remote System Explorer — the Program Verifier. Before you compile your code on
an iSeries, you can make certain that there are no errors by invoking the Program
Verifier. The verifier checks for semantic (compile) errors on your workstation so
that you can guarantee a clean compile on the iSeries. Think of the host cycles
you’ll save. It is especially handy when you are writing code but you are
disconnected from an iSeries. You can do this because Remote System Explorer
ported the parsing and checking code from the iSeries system compilers to the
workstation. The iSeries Error List view lists the errors that are found and their
severity, displays the error messages directly within the source and helps you to
navigate between the errors.

To invoke the verifier:

1. With the focus on the editor, click Source » Verify from the workbench menu.
(Similarly, you can also use the pop-up menu for the source member in the
Remote Systems View or the Verify tool button — you need the source in the
editor for the button to appear.)

After a moment the verifier will display an iSeries Error List below the Editor

window.
.ﬁsn‘da Syshem ... | iSeries Table View i iSeries Comman... | iSeries Indent ] Remote Search .
<TORASIIB »RSELABXX/QRPGLESRC(PAYROLL) b4 "ﬁ =

[ o | Message [5... ] L... [ Location [ conre... |
L. BNFS178  EMDSR operation is missing for subr,., 30 RSELABRXIQRP,.. <400a
The name or indicator EMES Is not d... 30 RSELABXXIQRP... s5400a
Ll RNF7030  The name or indicator RSNTAX isno,.. 30 RSELABXXIQRP,.. 54003
Il RNF7018  The operand RSNTAY of EXSR is not... 30 RSELABRXIGRP... s400a
) RNFS184  Factor 2 mustbe'D' or 1" whenthe ... 30 RSELABXXIQRP... s400a
Ll RNF7515  Move operands ERR and EMES hav... 30 RSELABXXfQRP... s400a
i RNF7089  RPG provides Separate-Indicator ar,.. 0 RSELABXXSQRP,.. s400a
I RNF7031  The name or indicator RSNTAG isno... 0 RSELABXXIQRP,.,  5400a
1 RNF7031  The name or indicator ¥INO3 isnotr... O RSELABXXJQRP...  s400a
i RNF7031  The name or indicator *INO4isnotr... O RSELABXXIQRP... s400a
1 RNF7031  The name or indicator *INOS isnotr,.. O RSELABXXJQRP,.. =400a
1 RNF7031  The name or indicator *INOG s notr... 0
1 1]

RSELABXXIQRP,.. s400a
RNF7031  The name or indicator ¥INO7 isnot r,.. RSELABXXJORP,.. s400a

el e L L AR - B - R

The error list shows you:
* The error message itself
* The severity
* The line number
* The source location
* The connection name
Next you will fix the errors in your source.
2. To fix an error in your source go to the error list:
a. Double-click the error RNF7030.

You are automatically brought back into the Editor window to the line
where the error occurred. The error on line 365 is a typo. The variable
EMES should be EMESS. One good way of finding the correct name is the
content-assist.
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Grwie | Jrvin TN =
Line 365 Column 50 Replace
-+++++0pcode (E)4+Factor2+++++++flesult++++++++Lent+D+HiLe
036500 MOVE ERR (2) Al
1ds ERR and EMES hav15”55|i=mﬁs
- indicator EMES is Y a5 [EmPHO
036600 ELSE empar,
036700 MOVE g [IEMcaT
036800 END epepr
036900 {ELOCN
037000 ng IF AND combination ens ££NNE

0371001 has been %ENHB

selaected.

037200

037300 IFEQ Q)

037400 ANDEQ g

037500 ANDEQ T

037600 MOVE e 1) —d
037700 MOVE ERR (3)

037800 END

037200

038000 ng code checks each application selection field to =
4 | o
I

Tip: The Outline view must be populated to use content-assist.
Select the misspelled variable and press CRTL+spacebar.

If the variable starts correctly the selection presented contains the correct
name.

Double-click the variable EMESS in the list to correct the variable name.

Another way to find the variable name is to use the Outline view and see
what variables are declared.

- Fields -l

- B ACODE : Character (1)
-1 ACREC : Character (1)
; I | EDEPT : Character (S)

1 ELOCN : Character (30)
1 EMCAT : Character (1)
SE eSS ; Character (50)
11 EMPAPL : Character (1)
¥ 1 | EMPNO : Packed Decimal |
11 ENAME : Character (30)
1 | ENHRS | Packed Decimal (:
{1 EPHRC : Packed Decimal (!
1| EPHRP : Packed Decimal (;

Pl -1 EPHRY : Packed Decimal (: =
i ¥ S L , - % [y
4| | ¥

The next error is a RNF7030 as well.

Double-click RNF7030. Fix it in the editor.

RSNTAX should really be RSNTAG. Make the appropriate change.
Go to the next error RNF5184.

The next error is actually RNF7018 but it is related to the one you just fixed
and can be ignored. It shows the same line number, which is an indication
that both errors are related.

- mE

¥

-

1 E-E

g. Double-click RNF5184.
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h. Fix this by replacing the 2 with a 1.

-

Error RNF7515 is related to the first error you fixed. It has the same line
number. You can ignore it. The only serious remaining error is RFN5178.
This error is caused by a missing ENDSR.

Tip: The verifier could not determine where the ENDSR is missing so the
line number reported is 1, for this reason you can’t just double-click on the
error message. You need to investigate where the missing statement
belongs. You can use the Indent view to determine where the ENDSR is
missing.

Move to line 398 in the editor.

Pwswsoser | revsrer  [RTT TR ™

Line 398 Column 8 Replace 2 changes

T I I e e PR - T
039600 C MOVE ERR (1) |
039700 o END
038800 Br ENDSR
039500 c*
040000 CFhhkEhhhhhrA AT A LA XA LI AR A LA AR AL AL AT AR L H &
040100 C* ACDESR subroutine verifies the time reporti
040200 C* all maintenance selections.
unaau |:'*-‘:'.*..‘-.*:-.‘:-‘:-‘;+*7‘--.‘_‘.—.*--.‘:f-ﬁ%—*.4-*_‘.—+.‘:9.-.‘:ﬂ-*.*-*.‘-—.‘:.‘-—é:.‘:**.*—*.‘:-};-—‘:ﬂ--ké.-;'c
040400 c ACDESE BEGSR
040500 c*
040600 C* Housekeeping, clear display fields and resed
040700 c*
040800 c EVAL EMESS = *BLANKS
040300 c EVAL *ING60 = *OFF
041000 c EVAL *IN90 = *OFF -
041100 i
041200 C* The following statements perform
041300 C

**  two functions. First they determine the ty=
| | b

Undo successful. 2 sets of changes now undone.

I

Remove the asterisk (*) from the C-spec.
You can use the Tab key to quickly move to the appropriate column.
All the non-informational errors are now fixed.

You can filter out messages according to these severities by using the filter
menu.

.Rernore System ... | iSeries Table View I Series Comman. .. | iSeries Indent | Remote Search [ FE Tt I 0.4 =g
<TORAS3I3E>RSELABXX/QRPGLESRC{PAYROLL)

L

ration is missing... | 3.4 1

+ L1 RNWF... Thename orindicator EME.., 3... 3... RSELABXY...
" ] RNF... Thenameorindicator RSM... 3... 9... RSELABXX...
v [l RNF... Theoperand RSMTAX of E...  3... 9... RSELABNY..,
] RNF... Factor2mustbe'0'or'l’... 3... 3.., RSELABXX...
v 1 BNF... MoveoperandsERR andE... 3... 3... RSELABXX... 54003

k. Click the arrow in the iSeries Error List title bar.

Click Show Severity on the pop-up menu.

m. Clear the severities you don’t want to see in the list (Warning for example).

3. You can save the member using one of these ways:

a. Click File > Save from the workbench menu.
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b. Click the Save icon | in the workbench toolbar.
c. Press Ctrl+S.

Changes are uploaded to the iSeries.
d. Verify your source again.

Remate Systerm .., |15erius Table View | [Series Comman. .. ! [Series Indent  Remote Search WI

<TORASIIB>RSELABKX/QRPGLESRC(PAYROLL) % 5z

[ [ | Message [s.]t.tocston | con..

1 | RNF... RPGprovides Separate-In... 0 2., RSELABNX... s400a
RNF..,  The name or indicator *IN..,
RNF... The name or indicator *IN...
RMF.., The name or indicator *IN. .,
RMNF... The name or indicator *IN, ..
RMF... The name or indicator *IM...

RSELABXX.., s400a
RSELABKK,.. 54002
RSELABXX.., s400a
RSELABXX... s400a
RSELABXX... s400a

e s s
200 oo
S o =

Everything should be ok. You should see only severity 0 messages. You are
ready to compile the program.

You have verified your source and fixed any errors.
Lesson checkpoint

You learned the following:
* About program verifier
* How to verify programs

Compiling source remotely

The remote compile capability is part of the Remote System Explorer. It gives you
a workstation interface to submit requests to compile, bind, or build objects on the
iSeries host. It allows for easy access to all the compile options available for all the
supported CRTxxx commands.

If you used the local program verifier, then your host compiles should be
successful -- no wasted iSeries cycles. However, if there are errors, the host
compiler will send the error information back to the workstation and they will be
loaded into the iSeries Error List view, which behaves just as it did when you did
a program verify.

The default for compiling programs is to submit the compile to the batch job
queue. Here in this exercise you can run the compile interactive.

1. To change the preferences to run the compile interactive:
a. Click Window > Preferences from the workbench menu.
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0 preferences

I type filter text

®

- Requirement Management

Maodel Validation
Modeling
Package Maming Preferences

- Plug-in Development

Portal
Process

+ - Profiling and Logging

Remote Systems
- Communications
[+ Debug
File Cache
Files
=l iSeries
- Cache
- Command Execution
- Commands Subsystem
- IFS Files Subsystem
- Jobs Subsystem
- Objects Subsystem
[+ Program Verifiers
“ Table View
Logging
Passwords
[=- Remote Systems LPEX Edit
=] iSeries Parsers
M- CfCH+
o CL
- COBOL
[ ILE RPG
RPG400
Screen Designer (Technical
S5L

=] B3
Command Execution = E

~Preferences for compiles and user action variables
Object ibrary; | *SRCLIB ]

Iv Replace chject
I I~ Compile in batch |
~Preferences for batch compiles, commands, and user al

Job description library: FLIEL [=
Job description: *USRFRF :I

SBMIOB additional parameters: I

[~ Add batch compiles to the iSeries Job Stakus view ‘
[~ Add batch commands to the iSeries Job Status view
|

~Preferences only for compile commands
Compile member types in this order:

PF 2
LF Move Lip

DSPF

PRTF

ICFF

RPGLE

CLLE =

Maye Down

—Preferences only For user action variables
[ Runin batch

-
( L|—I Restore Defaults ] Apply |
) 0K I Cancel I

® oo o

check box.
f. Click OK to return to the Remote System Explorer perspective.

You will now use the prompt for the CRTBNDRPG command to specify your
compile parameters. All entry fields pertaining to names are already filled in

with the correct information.
2. To compile source:
a. Right-click the PAYROLL member in QRPGLESRC.
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15 Remote Systems. X W) = O)(# pavroLLRPGLE 5 N2 =D Ezoxt \TEL
£ & | a|Es = Line 398 Column &
- L QDDSSRC.*fle,pf-src - Hllopcode (B) #Fac|| o T, obal oo
B 5 QRPELESRC. *file.pf-src 039800 ENDSR Al @[ Files
B PavROLL. gl GoTo » i .‘:'T Fields
O pavROLLG.Ipg ra kAR R AL LR | #Lg Indica
£ QRPGLESRCP #fils  OPen With M verifies - || - ManProc
-0 pavROLL.rpgle  Browse With *blections.
q—] PAYROLLG.rpg o ok e ok ok ke e ke e
‘ | Rﬂ i
@[5 REFMST  *file.pf-dl I . Jergs
@[] RSNMST . *File,pf-di = “OP¥ —
. MYCOMPILE. *cmd *5* Move... Lr display o
. B User libraries 2 Delete... _l'l-J
#-BY i5eries Commands . » P
@ @ iseries Jobs e seeioes gram acticg
2 E IFS Files ®) Find String. . [ | T T
Ly Qsficll  Verify |iser... [Rem.., [@ser... 53\ =T
< | " erify (Prompt)... VFEVENT(PAYROLL) 3¢ 3 - <
' properties 52 _Remote Scratchp.  Compile A e Te b [ imasin li7n
S .
g8l Compie (Prompt) v [ CRTBNDRPG. ..
S User Actions ¥ [ CRTRPGMOD...
Property | value e
Attribute SRC Add To iSeties Project... 1}, Work With Compile Commands...
Name PAYROLL Make Available OFfline T T ™

Click Compile (Prompt) > CRTBNDRPG on the pop-up menu. The Create
Bound RPG Program (CRTBNDRPG) dialog opens.

In the Debugging views list, select the *ALL parameter.
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# Create Bound RPG Program (CRTBNDRPG) F3

Program: > | PAYROLL = Narme
Library: > | RSELABXX | Name
Source file: > | QRPGELESRC | Name, QRPGL
Library: > | RSELABIKX = Narne
Source member: > | PAYROLL | Name
Source stream file: :I
Generation severity level: [0 0-20
Text ‘description’s [ *SRCMBRTRT x| character val
Default activation group: MYES -
Advanced Parameters
Compiler options: > _—'—‘_—E‘ fild
HEVENTF
[Debuming views: >
Replace program: = | *YES
4] |

I Advanced(s) I all Parameters(s) [~ Keywords(7)

CRTENDRPG PGM(RSELABXX{PAYROLL) SRCFILE(RSELABX%/QRPGLESRC) SREMBR(PAYROLL) OPTION(*EVENTF) j

| oK ] Restore defaults | Cancel

If you want to see the other parameters available, click Advanced.
d. Click OK when you are finished.

The progress bar on the workbench (bottom right corner) will indicate that
the compile runs. Then the error list will be shown, with no errors, just
information messages.

If you are not sure that the compile was successful, you can check the
iSeries Commands log.
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Remote System Details fLIMT T e iAW O (Series Indent | Remote Search | [SeriesErrorlist| . © — &

s400a

Cause , . . .. Compilation Failure normally occurs when the severity of issued messages exceeds the value specified _|
for the GEI\I_\'I_ parameter an the CRTBNDRPG command. See the compiler listing or the job log For error messages.
Recovery ...: Correctthe errors or change the value specified For the GENLYL parameter, Compile again,

CRTBNDRPG PGM{RSELABXX/PAYROLL) SRCFILE(RSELABYX/QRPGLESRC) SRCMBR(PAYROLL) OPTION(*EVENTF)
DEGVIEW{*ALL) REPLACE(*YES)

AUT and USRPRF parameter values were ignored,

Cause . ., ..: The AUT and USRPRF parameter values were ignored because REPLACE(*YES) was specified.
Therefore, the existing object was used as the source of authority. Al private and public authorities, the USRPRF
attribute and the USEADPAUT attribute were copied from the existing object to the new object PAYROLL type *PGM in
library RSELABXY. Recovery ... : Display the object authority (DSPOBJAUT command) to determine if the authority
for object PAYROLL type *PGM in library RSELABXY needs to be changed, Grant object authority (GRTOBIAUT
command) or revoke abject autharity (RYKOBIAUT command) to change the authority For object PAYROLL type *PGM
in library RSELABXX If needed.

Replaced object PAYROLL type *PGM was moved ta QRPLOBI,

Cause . .. ..: Replaced object PAYROLL type *PGM from the RSELABXY library was renamed to Q226903009 and
moved to the QRPLOB] library, Recovery . . . ¢ If the replaced object is needed, you can use the Move Object
(MOYOB]) command to move the object from the QRPLOB] library into another library, The QRPLOB] library is cleared
during the next initial program load (IPL) of the system. The QRPLxeao: library (where “oooed! is the number of a
primary auxliary storage pool (ASP)) is deared during the next vary on of the ASP device.

Program PAYROLL placed in ibrary RSELABXY, 00 highest severity, Created on 12/27]06 at 20:15:09,

Cause , .. ..: Program PAYROLL was successfully created in library RSELABXX. The highest message severity that
resulted was 00, The program creation date and time are 12/27/06 and 20:15:09.

|
Command !Normal :J | _‘_'_l Prompt.; | 57'»”-'

e. Click the iSeries Commands log tab at the bottom of the workbench. This
log shows a list of all commands run on the remote system and the
messages returned for each command.

You have set compile preferences, invoked the compile command, checked for a
successful compile.

Lesson checkpoint

You learned the following:
* About compile preferences
* How to invoke the compile command and check for a successful compile

Submitting iSeries commands in the iSeries Table view

You can use the iSeries Table view inside the Remote System Explorer to submit
commands to the iSeries. You can run commands from the Commands field
beneath the iSeries Table view, and view messages in the Messages field. After you
populate the table, you can enter a command and click either Prompt to specify
parameters and then Run or just click Run. When you run a command, the
Messages field is populated with the messages from the command. When you
select a message, the Details button is enabled. When you click this button, the
message and its help is displayed.

Also note that besides the iSeries Table view, you can also use the Remote Systems
view to run commands and programs. Which one you choose depends on your
personal preference. In the iSeries Table view, you can see the properties of all
items at the same time; they are displayed as rows across the table. In the Remote
Systems view, you have greater ease of navigation; you can work from your
Library list in the iSeries Objects subsystem, and you can see the contents of many
items before selecting the one you want to run.
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In the Commands field, you select where you want to run the command. The
choices are Normal, which means that the command will run in the RSE
communication server job, Batch or Interactive.

To change the library list:

File RSELABXY/QDDSSRC (5 Members)

L

Name | Type | Attri.., | Text | Last modfied | | |

C-jEmpMsT PR SRC July 23, 200...

CiMSTDSP  DSPF SRC July 23, 200...

CypRaMST PR SRC July 23, 200...

CLREFMST PF SRC July 23, 200...

CoRswMST PF SRC July 23, 200...
b

'
Command |Narmal ﬂ lchgcurlib rselabixx -:]] Prompk... I Run ||

Messages |Pfograrn PAYROLL placed in library RSELAEXX, 00 highest severity, Created on 12;’:;] Details. .. | Show Log |

1. Click the iSeries Table View tab from the views at the bottom of the
workbench.

2. In the Command field type, CHGCURLIB RSELABxxfor example.

Tip: Use a library that is on your iSeries system.
3. Click Run.

If you haven’t used the iSeries Table view to show iSeries objects in this view
you will see an error message because the iSeries Table view is not linked to an
active connection.

If you see this message, click OK.

a. In the Remote Systems view, right-click QRPGLESRC.

Delete...
€0 Remote System Explorer - PAYRO »

File Edit Source Compile(G) Navigat PRy

| P& - - ~ Cathe file Descriptions
s et ‘f. . . % B Find String. .
5 Change...
Save...
Restore...
User Actions 4
%50 QULSRC. *file,pF-src Add To iSeries Project. ..
[ QCMDSRC. *file.pf-«__Make Avaiable Offline

(i)

5 QDDSSRC. *file.pl

- f-5  properties(H)
Eo 2

Rem... |iSer...
; I
-0 PAYROLLG.rpgle m@

=] (50 QRPGLESRCP, *file.pf-src > || Mame
| >

-

4

b. Click Show in Table on the pop-up menu. The iSeries Table view is now
populated with the member in the selected source file.

c. Run the CHGCURLIB command again.

The command will run on the iSeries and after completion you will see the
completion message on the bottom of the iSeries Table view.
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Remote System ... |Series Comman. .. | iSeries Indent | Remote Search | Series Error List f{

File RSELABX/QRPGLESRC (2 Members)

Name | Type | Attric., | Text |tastmodiied | | | |

G- pavROLL RPGLE  SRC December 2...

- PAYROLLG RPGLE  SRC October 20,...

b4
Command ]I\Iormd j I j Prompti I Rur I
[Massagas ]Current library changed to RSELABXX, :l Details. .. I Show Log I

4. Back in the workbench in the Remote Systems view, right-click Library list and
click Refresh.

e
ol
J57

q

& New Connection -
Ej' Local
(& s400a
=@ iseries Objects
IT:'E; Work with libraries. ..
A7 work with objects...
= 7-’6 Work with members, ., —
= i Library list
v-Bl Q5YS2924.*ib.prod-sys
B Q5YS.*ib,prod-sys
B Q5Y52,Mib.prod-sys
B QHLPSYS.*ib.prod-sys
B QUSRSYS. *ib.prod-sys
=0, WFLABXX. *iib.best-usr

RSELABX. *Ib.prod-usr

=

5. You will see a small green asterisk beside the RSELABxx library to indicate it as
your current library.

6. You can also connect to other than iSeries systems with the Remote System
Explorer and launch commands for these systems as well, for example, your
local system, or Linux®.

You have submitted a command to change the current library in the command line
of the iSeries Table view.

Lesson checkpoint

You learned the following:
* About submitting commands in the iSeries Table view
* How to submit a CL command in the iSeries Table view

Running commands and programs

As you know, you can run programs and commands from the Remote Systems
view or the iSeries Table view in three ways:

1. In the Remote System Explorer communications server job. (Your current
method)
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2. In a batch job.
3. In an interactive job (to test 5250 applications).
4. In a server job

Using the first option lets you run the program in the same job as the
communications server. With batch and interactive jobs, you cannot monitor the
status as easily, however, you do not tie up your communications server and you
are notified when the program command ends. Batch jobs work as you would
expect and do not require any initial setup. Running an application as
multi-threaded, interactive programs require a 5250 emulator, and you need to first
run a STRRSESVR connectionName command to associate the emulator with a
particular connection in the Remote System Explorer communications server. A
multi-threaded debug session creates a new server job and this way keeps the RSE
communications server job free for other tasks.

1. To start an interactive connection:
a. Start a 5250-emulation session.
b. Sign-on to the iSeries with your User ID and password.

Tip: Instead of the Enter key, you may have to use the Ctrl key in your
5250-emulation session.

=1 Session A - [24 x 80] : -0 x|
File Edit Wiew Communication Actions “Window Help

) ] 2% B ] [t &et| 5] @O

1HIN 05/408 Main Menu

|2f" 1902 - Session successfully started

c. In the command line, type the command STRRSESVR connectionName

d. Press Enter. The connectionName parameter is the name of your connection
defined in the Remote Systems view. This associates the interactive job with
the Remote System Explorer communications server.

Now you are ready to run the program that you just compiled.
Return to the workbench.
2. To run the program:
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Go To L2 =<

N 5 Show in Table |
oo - Column
+l CLCL. *pgm.cle  Refresh |> iAo g
] CLR1.*pgm.clle e e o o ok i!
MYCOMPILE *pgm,cle = REname... ;
PAYROLL *pgm.rpole RS i

| PAYROLLD. *pgm.chlle [ Past:

=L@ Global Defin|

| Fields
Bk [ndu:atog
- Main Proced|

[ 50 QCLSRC. *file pf-src

¥ |55 QDDSSRC *file.pf-sre  Run{Prompt) b % Batch
- [%) QRPGLESRC.*file.pf-s  Debug(Service Entry) ’E

B nastnmi emala Debug As(F) =
I »

5 A 5 e ppcan n s b

% Multi-threaded

t [E PAYROLLG, *pam.rpalé <t Move... ekl

[+ :'_-(j COMPARE.*file.pf-src 42 pejete, *  INDI

=[] EMPMST *file. pf-dta 50 -

[ (51 EVFEVENT *file.pf-dte  Update. .. D

& 5] MSTDSP. *file. dspf Change...

[ O] MSTDSPZ, *file dspf Save.., [
#-[5 PRIMST *file.pf-dta Besbrrs i e
&[5 QCBLLESRC.*file.pf-st LJser Actions b | fisere ([ iser.. 82T O

1 Properties 22 . Remote Scratchpad Debug (Prompt)(3) —

a0 o

e o

J-
k.
l.

Right-click the PAYROLL program.

Click Run As > Interactive on the pop-up menu.
Switch to your 5250-emulation session.

You will see the payroll program menu.

-ioix

File Edit Wiew Communication Actions ‘Window Help

D] 2% B ] 0| &

IEARET IR

onnected to remote sarver;fhost toras pdl0l on psprintl:pd101 i

':J‘ ic

Type x beside Employee Master Maintenance.
Press Enter.

Type 234 for the Employee Number.

Type A for the Action Code to add employee 234.
Press Enter.

Type any information you like about the employee.
Press Enter.

Play in the application as much as you like.

m. Press F3 to end the applications.
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n. To get control of the interactive job, right-click iSeries Objects and click
Release Interactive Job on the pop-up menu.

You can also choose to disconnect a session. You would right-click the
connection and click Disconnect on the pop-up menu.

You ran programs and commands from the Remote Systems view or the iSeries
Table view.

Lesson checkpoint

You learned the following:
* About run commands
* How to run programs

Module summary

In this module you learned how to verify and compile RPG in the Remote Systems
LPEX Editor. When errors were found by either the verify or the compile step, the
iSeries Error List appears. The iSeries Error List is a powerful tool that manages
errors found by verify and compile utilities. You became familiar with these tools,
the various capabilities of the iSeries Error List and the RPG program that you
created.

Lessons learned

* Check for semantic errors on your workstation

» Start the Program Verifier tool

» Use the iSeries Error list to locate each error in the source
» Use content-assist to fix an error

* Save your source

* Re-verify source

» Change compile preferences

* Invoke the compile command

* Change the current library using the Command field in the iSeries Table view
« Start an interactive connection

* Invoke the payroll program

Assessment

* What tool checks for semantic (compile) errors on your workstation?
* What view identifies each error from a compile?

* How do you sort the entries in the iSeries Error List view?

* What can you do in the iSeries Table view?

* What are the different ways to run a program?

* How do you verify source?

* How do you compile source?

Debugging a program

This modules teaches you how to debug a CL and ILE RPG program.
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You will learn how to start the debugger, set breakpoints, monitor variables, run
and step into a program, view the call stack in the Debug view, remove a
breakpoint, add a memory monitor, and set Watch breakpoints and all from the
Debug perspective.

Learning objectives

* Inroduce the debug features

» Start a debug session using a service entry point
* Add a breakpoint

* Add a conditional breakpoint

* Edit a breakpoint

* Monitor a variable through the Monitors view

» Step into your payroll program

» Show a Listing view

» List the call stack entries in the Debug view

* View all breakpoints

* Remove a breakpoint

* Monitor memory

» Set a Watch breakpoint

* Close the debugger

* Invoke the debugger from the Launch Configurations window

Time required

This module should take approximately 60 minutes to complete.

Introducing the Integrated iSeries Debugger

The Integrated iSeries Debugger is a source-level debugger that enables you to
debug and test an application that is running on an iSeries system. It provides a
functionally rich interactive graphical interface that allows you to:

* View source code or compiler listings, while the program is running on the
iSeries system.

» Set, change, delete, enable and disable line breakpoints in the application
program. You can easily manage all your breakpoints using the Breakpoints
view.

» Set Watch breakpoints to make the program stop whenever a specified variable
changes.

* View the call stack of your program in the Debug view. As you debug, the call
stack gets updated dynamically. You can view the source of any debug program
by clicking on its call stack entry.

» Step through your code one line at a time.
» Step return, step into or step over program calls and ILE procedure calls.
» Suspend program execution and get control back to the debug session.

» Display a variable and its value in the Monitors view. The value can easily be
changed to see the effect on the program’s execution.

» Locate procedure calls in a large program quickly and easily using the
Modules/Programs view.
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* Debug multi-threaded applications, maintaining separate stacks for each thread
with the ability to enable and disable any individual thread.

* Load source from the workstation or a different iSeries system than the program
runs on — useful if you don’t want the source code on a production machine.

* Debug client/server and distributed applications.

The Debugger supports RPG/400® and ILE RPG, COBOL and ILE COBOL, C, C++
and CL.

Now you know the basic features of the debugger.
Lesson checkpoint

You learned the following:
* About the Debugger

Starting a Debug session using a service entry point
You will be working with the ILE RPG program PAYROLLG.

Note: PAYROLLG is the same RPG program as PAYROLL but without compile
errors. You are using it instead of PAYROLL in this lesson, to accommodate anyone
who decided to skip right to this lesson without completing the editor lessons in
[“Editing source” on page 23|

To make the lesson interesting you will use CL program CLR1 to call PAYROLLG
and you will pass one parameter to CLR1.

In this lesson, you will use a service entry point to start a debug session for your
application. The service entry point feature is designed to allow easy debugging of
applications that invoke business logic written in RPG, COBOL, CL, or even C or
C++. The service entry point is a special kind of entry breakpoint that can be set
directly from the Remote System Explorer. It is triggered when the first line of a
specified procedure is executed in a job that is not under debug. Service entry
points allow you to gain control of your job at that point. A new debug session
gets started and execution is stopped at that location.

Tip: To use a service entry point to start a debug session for your application and
to allow updating of files in production libraries while debugging, the Update
Production Files must be checked in the preferences of iSeries Debug (Window >
Preferences then expand Run/Debug and select iSeries Debug).
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0 preferences

| type Filter bext iSeries Debug @ )
E:::SCache Al [ ¥ Update production ﬂles]
= iSeries
Eache iaci IV Prompt when service entry point is set.
- Command Execution : IRET
- Commands Subsystem LEenes tem s b st
- 1FS5 Files Subsystem
- Jobs Subsystem
L Objects S:bsystern | dnchice bkl senv e bR el e honidiod
ﬂ Program Yerifiers Do not include service programs inkhe followinalbraries:
- Table View o M
Logging — |
Passwords BEMEYE

[

Remate Systems LPEX Edit
Screen Designer (Technical
5L

- Requirement Management
=l Run/Debug
- Compiled Debug

Console

DEB2 Stared Procedurs Deb

Debug Daemon
External Tools

- iSeties Debug

5
®

Java and Mixed Language

Launching =
1 _'IJ

M= B3

Restore Defaults | Apply |

oK I Cancel I

Since you are using test libraries for the exercises, you don’t have to check this
iSeries Debug preference.

To start a debug session using a service entry breakpoint:

1.

In the Remote Systems view expand the Library list filter, if it isn’t expanded

already
" =i
-u.J"| '|.:|'.‘IL-:‘,-v
-2 QUSRSYS. *ib.prod-sys Al
[ =, WFLABYKY. *ib.test-usr
|i B, ADTSLAB.*lib.prod-usr
[=-mey RSELABLY.*ib.prod-usr

#- [5) CLBATCH *pgm.clle
1 *, -

+ I} Qg

m A EE

ol Clie
El PAYROLL, *pgm.rpale
[ PAYROLLCZ *pam.chlle
| PAYROLLD. *pgr.cblle
(4 PAYROLLG. *pam.tpgle
(5 coMPARE *file. pf-src
5 EMPMST #ile.pf-dta

Z|l EYFEVENT *file.pf-dta

CRCEG)

-6 MSTDSP. *file.dspf
-6} MSTDSPZ, *file, dspf =

w5 e masT #60. F dee

2. Expand library RSELABXX, if it isn’t expanded already.
3. Right-click program CLRL1 in library RSELABXX.
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Uset Actions g - e
5 Remote Systems Teamw HE 82 N2 =lm e
— B Run As 4 -
& | Run(Prompt) K Caluza
. [-E QUSRSYS.*ib k| % Set Service Entry Poirt
| [ E\ WFLABXX.*ib  Debug As(F) ¥y Show View
. B = ADTSLAB Mib.  Debug (Prompt)(J) > - =T
- ElEL RSELABXS. "It F* DESC _
| [ CLBATCH, L Visualize Application Diagram F* [+
:‘:: " % CLC1 -*Dg Propeftbsﬂ-[)ﬂ() F o e e A
H |—‘| (sgupupagugs) F* INDI
& MYCOMPILE. *pam.clle | | ooo700 F= 50 - =l

4. Click Debug (Service Entry) > Set Service Entry Point on the pop-up menu to
set a service entry point.

A message displays indicating the service entry point was successfully set.

€0 iSeries Debug Message m

i ) Service entry point is set successfully,
The service entry point can be refreshed through iSeries Service Entry
Paink{s) view if you recompile or update the program or service program later,

I Don't show this message again.

The Service Entry Points view is automatically added to the notebook at the
bottom right. It lists all the service entry points. You use this view to delete,
activate, de-activate, modify and refresh service entry points.

- Service Entry Poi _
= OBET
| Lihrgz I Program I Pr:qgrarn Type | Module ] Procedure Ig ] Cu‘u‘gd:im ] Engh;lgd

| RSELABMY CLRL GM Al *aLL ST... s400a Yes

|

I

/ T
| Remote System Details | iSeries Commands Log | iSeries Indent | Remote Search BE=Ns=1

5. Switch to the 5250 emulation session.

Tip: If your 5250 session is still associated with the RSE server job, you need to
release the interactive session. To do so, in the Remote Systems view, right-click
iSeries Objects and click Release Interactive Job on the pop-up menu.

6. On the command line of the 5250 screen, add the library RSELABXxx to the
library list and invoke the program CLR1: ADDLIBLE RSELABxx and then CALL
PGM(RSELABxx/CLR1) PARM('XX"')

As soon as the program enters the system, the service entry point is hit and the
debug session is started on the workstation and the perspective displays with
the CLR1 source code in the editor. The Debug perspective gives you access to
all available debugger features. Let’s look at some of them.

7. Click anywhere in the workbench to give it focus.

You have started a debug session with a service entry point.
Lesson checkpoint

You learned the following:
* About service entry points
* How to start a debug session with a service entry point
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Setting breakpoints

You can only set breakpoints at executable lines. One way to set a breakpoint is to
right-click on the line in the Source view.

To set a breakpoint:
1. Position the cursor on line 11.
2. Right-click anywhere on line 11.

J MSTOSP.DSPE | / REFMSTPE | // PAYROLL.RPGLE M 24|

Line 11 Column 1 Replace Browse
- 1 t———=2 ' 3 i 4 $-===5
» 000100 atalt TADM Armasam
il s TYEE (* LEN (2
L Syrea Check Line TYIRTeHaR) LRAR)
ooo400 it 10
gopsoon Lepy ) TYPE (*DEC) LEN(5 0
000&00 Faste VALUE ("Claus Weiss'
000700 LoOoE: Selett .') value (&count+1)
ooosoo celacted » lhen(goto loop)
000900 Deealart At VALUE ("Claus"')
001000 g value ("RSELAET *CAT
001100 Epen ' l|avroLrLe)
DBIEUU =Tow all L€ )
001300 Source »
Yigw »
< Add WatcE Brezuint. i | Ll
Run To Location
| Manitay Fyrraczinn l

3. Click Add breakpoint on the pop-up menu.

A dot with a checkmark in the prefix area indicates that a breakpoint has been
set for that line. The prefix area is the small grey margin to the left of the
source lines.

Now you add a conditional breakpoint to stop in the loop when it loops the
99th time.

4. Adding a conditional breakpoint
a. Select line 8.
b. Right-click on line 8.
c. Click the Breakpoints tab in the upper right pane of the Debug perspective.
The Breakpoints view opens.

W\Re@stm | Manitors | Programs |

[¥.2 CLR1.CLLE [line: 11]

Rl L L CLLE (i

s Ga to File

Add Breakpoint 4

Edit Breakpoint. ..

Right-click anywhere within the Breakpoints view.
Click Add Breakpoint » Line on the pop-up menu.
The Add a Line Breakpoint window opens.
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# Edit a Line Breakpoint | x|

Required information

Sets a breakpoint to stop execution at a specific source line

Executable (Optional)
Il
Object (Optional)

Source:
| CLR1.CLLE

Line:

—

@) coack | [nexe>| [[ Fsh | caneel |

Tip: You can select an existing breakpoint by right-clicking it and selecting
Edit Breakpoint.

f. Click Next.

# Edit a Line Breakpoint | x|

Optional parameters

Make the breakpoint conditional upon the Following parameters

-
~Frequency
From: |99

To: | Infinity

Every: |1

Expression: |

0] < Back I Next = | iﬁnlsh [I Cancel I

You only want to stop in the loop when it executes for the 99th time or

more. You can do that by setting the From field of the Frequency group to
99.

g. Under Frequency in the From field, type 99.
h. Click Finish.

You have added a breakpoint including a conditional breakpoint to your debug
session.
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Lesson checkpoint

You learned the following:
* About breakpoints

* How to add a breakpoint and a conditional breakpoint

Monitoring variables

You can monitor variables in the Monitors view. Now you will monitor the

variable &count.

To monitor a variable:

1. In the Source view, double-click the variable &count.
J MSTOSP.DSPE | / REFMSTPE | // PAYROLL.RPGLE m Sorce »
Line 7 Column 35 Replace View 4
d=ssclessshesocdsasmhorsrdans.  addorodvont

» 000100 BGM DARM (&nwum,  Add Watch Breakpoint...
ooozoo DCL VAR (enum)
gooz300 del ename *che S0 e
ooo400 del £11b *cha |t
000500 DCL VAR (&count  Monitor Memory r
000600 CHGVAR Switch View 1
000700 Loop: chgvar count’y TaLlus (e UaIlC T L)

2 0008OD if (scount *1t 100) then(goto loop)
oopos0o CHGVAR VAR (&NAME) VALUE ("ClausT)
goio0oo chgvar var (&lib) wvalue ("RSELAEBT *CAT

2 001100 CALL PGM (&1ib/ PAYROLLG)

001200

001300 ENDEGM

< | 2
I

2. Right-click &count.

3. Click Monitor Expression on the pop-up menu.
The Monitors view opens.

(v s et (TN oo

@ 2COUNT = 00000,

The variable appears in the Monitors view. Its current value is zero.
Now that some breakpoints and a monitor are set, you can start to run the

application.
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mﬁmvef5| [E O] LRz | Ca-ToF

B % tmp [iSeries: Debug Job]
=152 Platform: iSeries(TM)  Connection: TORAS33B:3825
=0 Thread:1 (stopped)
S8 IR1:CLR]:CLR]
_CL_PEP: CLR1 : CLR1
QUICMD : QUICMD : QUICMD
QUIMGFLW ; QUIMGFLW ; QUIMGFLW
QUIMNDRY : QUIMNDRY : QUIMNDRY
QUICMENL ¢ QUICMENL : QUICMENL
= QCMD : QCMD ; QCMD
.| Process: 045905/WLABIB/QPADEVODD Program: CLR1

IIRIRIE

4. Click the Resume “® jcon from the Debug toolbar.

The program starts running and stops at the breakpoint at line 8. (Be patient,
the Debugger has to stop 98 times but because of the condition continues to
run until the 99th time.) Notice in the Monitors view, that &count now has the
value 99.

5. Click the Resume icon again.

The program stops at the breakpoint at line 8 again and &count now has the
value 100.

6. Click the Resume icon once more so that the program runs to the breakpoint at
line 11.

If iou do not see the error message below, go to [“Stepping into a program”]|

Error Handling

If you forget to add the parameter to the CALL program command when you
call the program, you will see this error message.

7o) Debug Engine Message m

- DEGPOOO3E Program received unmonitored exception MCH3601: Pointer not
\l) set For location referenced.

[

a. Click OK.

b. Click the Terminateﬂ icon on the Debug toolbar.

The debug session terminates on the workstation but the exception waits for
input from the 5250 emulation session.

If you closed the Debug view by mistake, you will need to re-open the
Debug view and then terminate the debug session on the workstation.
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# Debug - CLR1.CLLE - IBM Websphere Developm

ent Studio Client Advanced Edition for iSeri... [E[=] E3

Fil= Edit Source Compile{G) Mavigate Search Project Data Run  Window Help

|-

J

{1 | % Debug

o | @ 8 Remote Systs...

1Y 60= yariables 53 . _greakpdnts| =0
B~
Name | value |
lesll WebSphere Application Server ve
=
Ny | M Jia |
Zactcue | ZeamouncuE [ Zaricie 2 N © O[22 outine 8 W T O
Line 10 Column 1 Replace | &
B+ 3 + 2 + 3 | & Ca Labeis
000700 LOOE chgvar var (&coural| 8 Loor
° 000800 if (scount *1t 100) |
ooosoo CHGVAR VAR (-:}[-I.-\J’IE)—J'
001000 chgvar var (&lib)-|
° 001100 CALL PGM (.;l.ij:[
| [ o |
!
| |
& console 52 _Tasks | iSeries Commands Log ] Memory | B X% kil 7BE-r5-=0
<terminated> <terminated> Process: 0283687 [STECKHAM/QPADEVOOOW Program: CLRL
=
i _l_I

File Edit Source Compile(G) Mavigate Search Project Data Run

-,

-

| !
ww#;s-_i}-@f-ch-J

|
|
J e
95 Breakpoints

%5 El console

Sphere Application

- [ pebug Consale
e1]| WebSphere Application |

3] Display

& Frraw o

5 J ' J @ New Editar

Window Help
New Window

Open Perspective

Ale+Shift+Q, B
Alt+Shift+Q, C

Customize Perspective...
Save Perspective As..,
Reset Perspective

Close Perspective

Close All Perspectives

Remember to terminate the Debug session if you haven’t done so already.

c. Go to your 5250 emulator and press

complete.
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=1 Session A - [24 x 80] =10 x|

File Edit ‘%iew Communication Actions ‘Window Help

=" 1902 - Sessian successfully started 4

d. In the workbench, click the Remove all terminated launches icon on the
Debug toolbar to clean up the Debug view.

|Servers m R = b S
= G% <terminated =tmp [iSeries: Debug Jahl
ofF e a— ) Conneclsli &ll Terminated Launches|

@ <terminated> Process: 028387/STECKHAM/QPADEYVOOOW Program: CLR1

e. From a 5250 command line, call the CLR1 program with the parameter XX.
CALL PGM(RSELABxx/CLR1) PARM('XX")

You have monitored the variable &count.
Lesson checkpoint

You learned the following:

* About the Monitor Expression view
* How to monitor a variable

* How to run a program

Stepping into a program
The Debugger allows you to step over a program call or step into it. When you
step over a program call, the called program runs and the Debugger stops at the
next executable statement in the calling program.

You are going to step into the PAYROLLG program.

To step into a program:
1. Click the Step into icon on the Debug toolbar.
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m&ewer:i e |':"-.» el | % & =%

B % tmp [iSeries: Debug Job]
=11 Platform: iSeries(TM)  Connection: TORAS33B:3525
=4® Thread:1 (stopped)

RN
(=
"U
a F.
Fiot
o
2

QUICMD ; QUICMD : QUICMD
= QUIMGFLW : QUIMGFLW : QUIMGFLW
QUIMNDRY : QUIMNDRY : QUIMNDRY
QUICMENU : QUICMENL : QUICMENU

= QCMD : QCMD : QCMD
p Process: 045905/WLAB18/QPADEVO003 Program: CLR1

The source of PAYROLLG is displayed. Depending on the option you used to
compile the program (*SRCDBG or *LSTDBG for RPG, or *SOURCE, *LIST, or
*ALL for ILE RPG), this window displays either the Source or Listing View.

If you specified an incorrect parameter for the CALL program command, or
your library list does not include RSELABxx, you will see this error message.

7o) Debug Engine Message m

i DEGPOOO3E Program received unmonitored exception CPFO001: Error Found
\) on CALL command.

Make sure your library list is correct and complete the same steps as covered in
the section called Error Handling in [“Monitoring variables” on page 81

Right-click anywhere in the Source view and click Switch view > Show
*LISTING on the pop-up menu.

|/ aciale [ // PAYROLLD.CBLLE | / CLRLCLLE W
Line 1 Column 1 Replace Brows:
I1+2+3+4+
» DDDlUU NS "'"‘"'"**********************.‘.il
000200 i > bayroll
000300 Prompt F4 me reporting master fi.
ooo4on Syntax Check Line tternally described worl
oonson R FEXERAEEEAEERLNRARARAEA:
000600
ooo7oo found on CHAIN operatiliol
ooosoo ror condition
poosoon Select play on delete request
001000 schcred requested
oolio00 s e ipplication selection
ool1zoo Filter view b tnployee selection
001300 Stitw e CErI- roject selection
ggi;gg Source 3 ;eason code selection
Dnlﬁﬂn view 5 b R R R R R
oo1700 Add Watch Breakpaint, .. y
001800 Manitor Expression pplication selection di
oo1so0 Monitor Memory » ftion code for all maini_
| ] e— v Show *SOURCE L’_I
Show *LISTING
| Show *STATEMENT

3. Page down in the source and take a look at the expanded file descriptions.
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You don’t have any /Copy member in your PAYROLLG program but these
would also be shown in a Listing view. Switch back to the Source view.

4. Right-click anywhere in the Source view.
5. Click Switch view > Show *SOURCE on the pop-up menu.

You have stepped into PAYROLLG program, switched the view from source to
listing and back to source.

Lesson checkpoint

You learned the following:
* About step commands
* How to step into a program

Listing call stack entries

The Debug view in the upper left pane, lists all call stack entries. It contains a tree
view for each thread. The thread can be expanded to show every program,
module, and procedure that is on the stack at the current execution point. If you
double-click on a stack entry you will display the corresponding source if it is
available. Otherwise the message No Debug data available appears in the Source
view.

In the Debug view, expand the stack entry of Threadl if it is not expanded already.

=] % tmp [iSeries: Debug Job]
=39 Platform: iSeries(TM)  Connection: TORAS33E:3825
i Bk @ Thread:1 (stopped)
B8 F2VROLLG : PAYROLLG : PAYROLLG
_QRNP_PEP_PAYROLLG : PAYROLLG : PAYROLLG
CLR1 : CLR1 : CLR1
_CL_PEP: CLRI1: CLR1
QUICMD : QUICMD ; QUICMD
QUIMGFLY : QUIMGFLY : QUIMGFLW
QUIMNDRY : QUIMNDRY : QUIMNDRY
QUICMENL @ QUICMENU @ QUICMENL
i QCMD ¢ QCMD ¢ QCMD
¥ pj Process: 045905/\WLAB18/QPADEVOD0Y Program: CLR1

i Servers | 3

[NRIRIINTIRRINIIAT

The stack entry allows you to work with and switch between different programs
and/or ILE modules.

You have viewed the call stack entries of your program.
Lesson checkpoint

You learned the following:
* About call stacks
* How to display source from entries
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Setting breakpoints in PAYROLLG

Now you add some breakpoints in PAYROLLG.

To add breakpoints:

1. Select PAYROLLG in Threadl.

2. In the source view scroll to line 57.

3. Double-click the prefix area of line 57.

A breakpoint icon is added to the prefix area of this line to indicate that a
breakpoint is set.

4. Repeat the above step for line 58.

/' REFMST PF | // PAVYROLL.RPGLE | A/ ClRLCUE Miﬂ SE

Line 58 Column 51 Replace Browse

.....CLONO1Factorl+++++++Opcode (E) +Extended-factorft++

2 005700 C EVAL PRJAPL = *BLANK :l
L2 005800 C RSNAPL = *BLANEK

0oss00 c* =

00&000 C* Tirite the SELECT format to display. If end

006100 (o5

ooezo0 c*

006300 (e pou not *INEOD

00&400 (& EXFMT SELECT

00es500 c T IFEQ T

006600 C LEAVESR

006700 c ELSE

006800 C EXESR EDITSL

006300 i END

007000 a3

007100 C* IF the general error indicator *INE0 is on

1| | »

I

5. Right-click in the prefix area of line 87 and click Add Breakpoint on the
pop-up menu.
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-
S REMSTRF | /PAROWLRPGE | FaRLCUE [T
Line 87 Column 37 Replace
..... CLONO1Factorl+++++++0pcode (E) +Effctor2+++++++Resulc
008600 c*
008700 C sErecT L]
008800 c New Y= e
008900 c — = G
L =" Syntax Check Line
009100 c L= '
009200 c Save G
009300 c* ; —
009400 c Cut cErkt L = 'x
009500 c Copy ChrlHInsert G
009600 c Paste Ctrl+v
ggg;gg f' if EC en Select »
- Selected »
Deselect Al
| Filter view »
: Show CErl 44
£l console EZ\Tadts iSeries Com it L5
<terminated> <terminated> Process: 2  Source } Bm: PAYROLLG
View »

To view all breakpoints, select the Breakpoints tab from the top left pane.

1
Registers Monitors | Programs ]

M2 CLRL.CLLE [line: 8]

~[E.® PAYROLLG.RPGLE [line: 57]
2 PAYROLLG.RPGLE [line: 58]
~[¥].2 PAYROLLG.RPGLE [line: 87]

This view shows all breakpoints currently set in your Debug session. This is a
convenient place to work with breakpoints. You can remove, disable/enable,
add, or edit a breakpoint. These tasks are available from the pop-up menu
when you right-click in the view area. Double-click any entry to show the
source where the breakpoint is set.

You have added several breakpoints to PAYROLLG.
Lesson checkpoint

You learned the following:
* How to add breakpoints

Removing a breakpoint in PAYROLLG

It is also easy to remove breakpoints.

To remove a breakpoint:
1. Right-click the prefix area of line 58.
2. Click Remove Breakpoint on the pop-up menu.
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| # REFMST.PF /# PAYROLL.RPGLE & CLR1.CLLE . =)
. Line 58 Column 1 Replace Browse |
I. ...CLONO1Factorl+++++++Opcode (E) +tExtended-factor2+++|
w2 005700 C EVAL PRJAPL = *BLANK ;]
l» 00S880C™,,, = EVAL RSNAPL = *BLANK |
oosgoc =4
00sDOC  Prompt F4 LECT format to displas =and |
gosl0c Syntax Check Line
DO0620C
poe30cC DOu not *INGD
D0g40C yots EXFMT SELECT
DO0650C IFEQ 1 3
ooss0C ok ’ LEAVESR
geezaE "|  ELsE
Yo —— EXSR EDITSL
00Be20C  Fiker view » END
go7oo0C & ' |
007100  spurce y 1l e indicator *INGO on ;
Jo TS | —| .*J—I |
Edit Breakpaint. .. |
| Remove Breakpoint |

The icon is removed from the prefix area indicating that no breakpoint is set on
that line. The breakpoint is also removed from the list in the Breakpoints view.

Now you are ready to run the PAYROLLG program.

Tip: Double-clicking on a breakpoint in the prefix area will also remove that
breakpoint.

3. Click the Resume “® icon from the Debug toolbar.
4. The program starts running and runs to the breakpoint at line 57.
5. Click the Resume icon again.

The program waits for input from the 5250-emulation session.

;JJ 11902 - Sessjon successfully started

=1 Session A - [24 x 80]

File Edit Wiew Communication Actions

Window Help

By 2% B ] e[ &

2| 3| @lel

=10} x|

6. Type an X beside the Project Master Maintenance option.
7. Press Enter in the emulation session. The program runs to the breakpoint at

line 87.
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You have removed a breakpoint from PAYROLLG.
Lesson checkpoint

You learned the following:
* How to remove a breakpoint

Monitoring variables in PAYROLLG

Now lets monitor variables and change them in PAYROLLG.

To monitor variables:

1. In the source view, double-click the variable EMPAPL on line 88.
2. Right-click the variable.

3. Click Monitor Expression on the pop-up menu.

# REFMST PF |i PAYROLL.RPGLE |ICLR1.CLLE M 3::“
Line 88 Column 42 Replace
.....CLONO1Factorl+++++++Opcode (E) +Exteng AddBreakpoint
008300 C* If the prior two tests were not M bestaon:
00gs400 C* reason code malntenance. The pr RunTolocation
gogsoon C* next executable operation. ERFTRER =
00ge00n c* "
= 008700 C SELECT Honkter
008600 C when Switch View
0og=200 [ EXSR EMPTAG
go2000 C*
002100 6 when FRJAPL = X'
o09z200 C EXS8R PRITAG
009300 c*
002400 C when RENAPL = TXT
ooss00 o EXSR RSNTAG
009600 C ENDSL
009700 C* if KC end program
4| | Ll_l
|

4. Click the Monitors tab in the upper right pane. The variable appears in the
Monitors view. Its value is blank because you did not select the Employee
Master Maintenance option.

5. In the same way add the variables PRJAPL on line 91 and RSCDE on line 113
to the monitor. Variable PRJAPL equals X because you did select the Project
Master Maintenance option.

6. In the Monitors view, double-click the variable RSCDE. The value changes into
an entry field.

7. In the entry field, type in the new value X for the variable.

Variables [ Ereakpoints | Registers JLOSFTH 4 Programs

® &COUNT = 00100,
@ EMPAPL =
- @ pRIAPL=1¥
@ RSCDE= []
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8. Press Enter. The variable is successfully changed.

You have monitored several variables in PAYROLLG.

Lesson checkpoint

You learned the following:
* About monitoring variables
* How to monitor variables and change the value

Adding a memory monitor

Adding a memory monitor for a variable allows you to view the memory starting
with the address where the variable is located. The memory can be displayed in
different formats, for example hexadecimal and text.

To add a memory monitor:
1. In the Source view, double-click the variable ERR in line 33.
2. Right-click and select Monitor Memory > EBCDIC on the pop-up menu.

+++++++++ETDsFrom+++To/L+++IDc. Keywords+++

ill add a new re«
1 Hex and Character el
2 Hex
3 ASCIL ps el

# REFMST PF | /# PAYROLL.RPGLE | # CLR1.CLLE
Line 33 Column 11 Replace
..... DName
003300 D 8
003400 O EME Syntax Check Selection
oo3s00 E* Convert Selection To Free-Form
003600 Cx xSy i
003700 C* M| copy Chrl+Insett
003800 C* %4 & EnRces Chl+Y
003200 cx 1
004000 c*r offite
004100 cx e
004200 cr g i Ak H)
004300 C* d  Filter view
004400 o* u Stiow all -y
004500 Crrxx e
004600 c*  HEEE
0p4700 c*
#dd Watch Breakpoint. ..
ll Monitor Expression
| Monitor Memory
= =i |

e

Browse

50 DIM(10) ci4]

50 =

R R

ols the display
on keys describe:
om one maintenan:
ou select on the

4 EBCDIC

S Sigried Integer LILI
& Unsigned Integer
7 Map... I

This will open the Memory view in the notebook at the bottom of the
perspective. The tab shows the name of the variable.
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7.

Comoia|Tasks|lSam Commands Log Debuq(:onsole B |’_E:| 23] "‘T__:\I ggr > T &

Monitors 4 W iy Renderings v B
@ ERR ERR : OxES7FESB0CI069EE0 <ASCII> | ERR : OxE67F6S30C3089E80 <EBCDIC> E4[ >

Address Jo-3]a-7]e-8|lc-kr]| Al
E67F6580C3069F00  FOR MAI | NTEN | ANCE
E67F6580C3069F10 AT TICH
E67F6580C3069F20 COD E NO T EQ  UAL
E67F6580C3069F30 TO ”  L", OR
E67FE580C3069F40 D ADD REQ
E67F6580C3069F50 UEST ED B | UT R | ECOR
E67 oo BRI nean | v ew | ISTS
E67F6580C3069F “ Add Rendering WA
E67FE580C3069F M Remove Rendering 5| RD U
E67FES580C3069F
e e APt 3] L4+ Reset to Base Address =
E67F6580C3069F  G0to Address... 5 | TED
E67F6580C3069F
E67F6580C3069F
E67F6580C3065F  ResizetoFit E | QUES
E67F6580C3069F Hide Address Column 0 RD I
E67F6580C306A0
E67F6580C30640 & Copy Todipboard E | QUES =l

~=- Dwirk

¥ DE

Format...

Use the scroll bar on the right of the Memory view to scroll down. You can see
the current content of the memory.

Right-click in the view area.

Click Reset to Base Address on the pop-up menu to return to the starting
address.

To get the hex content of the memory starting with the selected variable, click
Monitor Memory > Hex. A new page with the hex values is added to the
Memory view.

Click the Toggle Split Pane icon to display the character values as well.

You have added a memory monitor for the variable ERR.

Lesson checkpoint

You learned the following:
* About memory monitors
* How to add a memory monitor

Setting Watch breakpoints

A Watch breakpoint provides a notification to the user when a variable changes. It
will suspend the execution of the program until an action is taken.

To set a Watch breakpoint:
1. Go to the Line number field at the bottom of the source area. In this field enter

116 to go to that line.
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# REFMST PF |I PAYROLL.RPGLE |/cm1.cu.z Ml ZCE

Line 33 Column 1 Replace Browse
I. ...DName+++++++++++ETDsFrom+++To/ L+++IDc. Keywords+++

003300 D ERR s 50 DIM(10) c'4l
003400 D EMESS =) 50 =
003500 E*
Uﬁgﬁuu C:L.+1L.+1L.+1‘:+1‘:*++“-++++*++++++++*+*+*++++1‘.—+1‘7+1‘r=—-k=—-k*-.t—-
003700 C* MAINLINE CALCULATIONS
003800 ChrEdthdhihbdbdbbbbbbdbdbbbbbbbbbbbdbrtrrtrt it
003200 C* This mainline routine controls the display
004000 C* editting. Using the function keys describe:
004100 C* format, you can transfer from one maintenan
go4z200 C* another. The action code you select on the
004300 C* determines if the program will add a new re:
004400 C* update an existing record in the file.
004500 ChhAkhhkhkhhkhhrhrbhhhrhhhhdhrrrrhrrhdarrddrrohhhkh;
004600 C* Housekeeplng, clear display fields and resef
004700 o*
4| | JIJ
116

2. Double-click variable *IN60 to highlight it.

3. Right-click and click Add Watch Breakpoint on the pop-up menu.
The Add a Watch Breakpoint window opens. The Expression field is pre-filled
with the highlighted variable *IN60.

By default the Number of bytes to watch field is set to zero, which means the
variable will be watched in its defined length.

# add a Watch Breakpoint | x|

Required information
Sets a breakpoint bo stop execution when data changes at a specific address

Address or expression;

Number of bytes to watch: |ﬂ :_I

| *INg0

(7)

coack | nexts>  |[ Fnish Cancel

4. Click Finish. The Watch breakpoint is now set.
5. Click the Resume button on the Debug toolbar.
The application waits for input from the 5250-emulation session.

Maintain an ILE RPG application using Remote System Explorer

93



-ioix

File Edit Wiew Communication Actions ‘Window Help
D 2% @ =6 % & 3] @l

Project Mast

| 55" [Connected to remote server/host toras|/pd101 on psprintl:pd101 — .z

6. In the 5250 emulation session, type 123 for Project Code and D (for delete) in
the Action Code field.

7. Press Enter. A message is displayed indicating that the variable *IN60 has
changed.

€0 Debug Engine Message [ %]

- DEGBOOOSI Yariable *INGD has changed in program PAYROLLG, module
oy PAYROLLG, which is running in job QPADEVOODI/WLABLS /045905,

8. Click OK. The program stops at line 465. This line is located immediately after
the statement which caused the variable *IN60 to change.

You have added a Watch breakpoint for the variable *IN60 and run the program to
see the notification that the variable has changed.

Lesson checkpoint

You learned the following:
* About Watch breakpoints
* How to set a watch breakpoint and see the results

Terminate a debug session

To close the debugger:

1. Click the Resume icon on the Debug toolbar. The application waits for input
from the 5250-emulation session.

2. Switch to the 5250 emulation session.
3. Press F3 to end the program. A message Program terminated appears:
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7o) Debug Engine Message m

\i) DEGPOOOME Program terminated.

4. Click OK.

Lesson checkpoint

You learned the following:
* How to terminate a debug session

Starting the Integrated Debugger using the Debug action

You will be working with the ILE RPG program PAYROLLG.

Besides using service entry points to start a debug session, you can start the
Debugger in several ways: directly from the pop-up menu of a program or service
program in the Remote Systems view, or from a Launch Configurations window.
Starting directly from the Remote Systems view without prompt doesn’t allow you
to specify parameters to be passed to the program. The Launch Configurations
window allows you to modify how the program is invoked and to specify

parameters.

CLR1 requires a parameter.

To start the debugger:
1. Select program CLR1 in the Remote Systems view.
2. Right-click and select Debug (Prompt) > Interactive from the pop-up menu.

4E

# B Local
= % s400a

[+

#

B3

[ -

- 4% New Connection

B Q? iSeries Objects

| = 3 Work with ibraries. .
A
M _Eﬁ Work with members...

i B E‘ Library list

Waork with objects.. .

= Q5Y52924 Mib.pro
B Q5Y5.¥ib.prod-sy:
B Q5Ys2.Mib.prod-ss
B QHLPSYS.*lb.prod
B QUSRSYS.*lib.proc

=, RSELAB13.*lib.tesl |

. ooy 1" Visusize Application Diagram
=B cLct. *pam.che
| M [ERN CLR 1 *pom.cle

fai, %] A= OBANT € Frern Al

- B4 CLBATCH.*

" o Move...

®

Copy
te

Delete...

Update. ..
Change...
Save...
Restare, .,
User Actions

Run &s

Run(Prompt)
Debug{Service Entry)
Debug As(F)

Debug (Prompt)(1)

pll ¥ T ¥ ¥

3

2

Column

. .BronDiFact|

=

100 00

* %

=

The

C* two »
»

=8

Fox \ = 0|
= () Global Defin|
#-[4 Files
Al Fields

(5 Indicatol
=L Main Proced|
-5 Subrout|

Properties(H)

=5 Interactive...

(3 Multi-threaded. ..

ﬂ[ | ADDLIBLE RSELABHX *LAST

The Debug prompt window called launch configuration, opens for the

selected program. The connection is prefilled with the name of the current
connection. The program to be debugged is also prefilled with the library,
program and type.
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# My iSeries program E3

Modify attributes and launch.

Ea‘ne: | cLri| i

RPN How To start | T Source | = Common|

Connection: [s400a | mew... |

Programs or service programs to be debugged
Library | Program | Type I Add. ..

[4] RSEL&BLE CLR1 *PEM
Eits |

[V Step into
¥ Terminate debug session on program completion
[ @ Update prodction fies]

Apply

|

Revert |

) Debug

3. In the Name field, type the program name CLR1. This gives your debug
configuration a unique name so you can use it again when you debug this

program.

Note: If you invoke the debugger even without prompting, a launch
configuration with the default configuration named My iSeries program will

be reused.

4. You can leave the Step into and Terminate debug session on program
completion check boxes selected and Update production files check box

deselected, since you are working with a test library.

5. Click the How To Start tab.
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(What T sy PPN - Scarce] ) Comon

Command to start application:
CALL PGM{RSELAB18/CLR1) :_l

[ prompt.. | |

By default, the page contains a call for the program specified in the What To
Debug tab.

6. Click Prompt.
The Call Program (CALL) window opens.

# call Program (CALL)

B3
Program: > |CLR1 hame
Library: > :RSELABIB x| name
Parameters: x| j Add |
IV Advarced [~ 2l Parameters [ Keywords
CALL PGM(RSELABIB{CLR 1) PARM(xx) |
(oK) | Restoredefauks|  cancel |

7. In the Parameters field, type 'XX' where "XX’ is your workstation number.
8. Click OK.

The complete start command for the program appears.
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# My iSeries program B3
Modify attributes and launch.
MName: ICLRl
What To Debug % Source| ) Common |
Command to start application:
AL PGM{RSELABIG/CLR 1) PARM(x') ;J
Prompt... |
Bpply | Revert |
0] Debug Close I

9. Click Debug.
The Debug perspective opens.
If not, you may see this error message.

& EVFC50011 [ x]

i , Mo interactive job associated with this connection. Associate an interactive

job with this connection to continue,
Cancel I << Details l

# request to run an interactive command or program was received for the RSE ﬂ

connection s400a, but no interactive job is currently associated with this
connection, To associate an interactive job with this connection:
1, Open a 5250 emulatat,
2. Run the CL command STRRSESYR NAME(s400a) Rd

The interactive connection has been shut down in the meantime. Go to your
5250 emulator and restart the interactive connection following the instructions
in the message. You don’t have to cancel the message. It will be removed as
soon as the connection between the Remote System Explorer communications

server and the interactive session has been established. The Debug perspective
is displayed in the workbench.

Now that the program is active on the iSeries and stopped at the first
executable statement, the debugger displays the source.
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10.

#0 Debug - CLR1.CLLE - IBM Websphere Development Studio Client Advanced Edition for iSeti... [Ej=] E3
File Edit Source Compile(G) Navigate Search Project Data Run  Window Help

] J.‘=J. il i ! . ! (4] L':ti ‘t&Dehug
] i v 30 Q- -Q - ] B | & 4 ] o ] @ &8 Remate Syste...
] L [ 3 w, * r.;j - -
m\&wersl = 01(e9= yar... B3 \_Bre... |Re.. |l\h |Pro...[ o =l
i e =l
1S BT | Name | Value
© oLlOCALYARS FOR ALL CL, NON-ILE RPE
T
= -
= _CL_PEP:CLR1:CLRL |« | .’_I
= QCMDEXC : QCMDEXC ; QCMDEXC =
~= executeCommand : QRSEMAIN | R o -
4| = | 3 R ¥
#PAROLRPGLE [/ clri.cue 2 2 =05 outine 2\ = O
Line 1 Column 1 Replace e
l + 1 + -2 + 3 B L Labels
® 000100 DGM pan'm-(‘;anil -[8 Loop
000200 DCL VAR (&nu;
ooo300 del &name *
000400 del &lib *c
- -
« | _>|’I
I
E console 53 \‘\Tasks|15eries CcrmmmdsLoq!Debug Camole]Memary| S
Process: 045938 WLAB18/QPADEVIO0S Program: CLR1 m o | B 5F| e = [
=
A il

| |

You have started an interactive debug session.

Remove all breakpoints. In the Breakpoints view, click the Remove All
Breakpoints button in the toolbar or select Remove All from the pop-up
menu.

Wariables Registers | Monitors ! Programs |

x (&)

= Breakpoints X

= Goto File

Add Breakpoint ’
Edit Breakpoint. .,

W Erable

Re ¥

Select Al Chri-A
1=/ Copy Chri+C
B Faste CErl Y
25 Export Breakpoints. ..
o5 Import Breakpoints. ..

11. Click Resume.
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PAYROLLG is called and waits for input from the 5250 session.
Only Terminate and Suspend buttons are available on the Debug view toolbar.

12. To get control back to the Debug session, click Suspend LU
You can now set breakpoints and use all the Debug features.

Tip: Suspend is a valuable feature to debug a looping program.
13. Click Terminate to end the Debug session.

The Debug session is terminated, but this does not end the program.
14. Switch to the 5250 emulation session and press F3 to end the program.

Tip: You can edit, delete and create debug configurations by clicking the

arrow beside the Debug icon on the workbench toolbar and selecting Debug
from the list.

O Remote System Explore|

File Edit Source Compile(G

Debug As L4

% Debug. ..

Organize Favorites. ..

# Remote System Explore|

File Edit Source Compile(G
(5=

J | |
|35~ O - Q-
| By tcrt

Sezcct

Debug As »

| % Debug...

Organize Favorites, ..

You can also click Run on the workbench menu and select Debug.
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The Debug Launch Configurations window opens.
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# Debug

Create, manage, and run configurations

RUER Hl=EE:

' type filter text
B Hostcjc+ A A

93, Host Java App
|_’¢F iSeries: Debug
= QF iSeties: Debug
R Tals

[ B and

+ % iSeries: Debug
13 iseries: Debug
(39 Java and Mixe
- ] Java Applet

I (3] 3ava applicatic
87 Java Applicatic
-@ Java Bean
Ju Juri

~-Ju JUnit Plug-in T
[f_', Remote Java £
5] SWT Applicatic
B Test

o ‘WebSphere Ac
® webSphere Ap
rs[‘E ‘WebSphere vE
[ websphere vE
1@ ‘WebSphere vE
“ B wsL Transform =

N b

Name: |CLR1

MHM?OS&&Q% Source | | Common |

Connection; |s400a

Programs or service programs to be debugged

Library | Program | Type |
RSELABXY CLR1 *PGM
V¥ stepinto

¥ Terminate debug session on program completion
V¥ Update praduction files

=l Naw...l

Add...

Remaove

i

#Apply

| Revert |

(7)

Debug |

Close I

Here you can see the CLR1 configuration that you just created. This is your
saved configuration to debug CLR1 as an interactive application. You could
now modify this configuration to use a different parameter, copy this

configuration, or create a new one. Notice the list of configurations you can

choose from.

You are now ready to remove the service entry point you created earlier and
close the debug perspective.

15.

To remove the service entry point and close the launch configuration:

a. In the Remote System Explorer perspective, expand library RSELABXxX, if it
isn’t expanded already.

b. Right-click program CLR1 in library RSELABxx and click Debug (Service
Entry) > Remove Service Entry Point.
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M QHLPSYS *lb.prod:  pebug As(F) e
6B QUSRSYSYib,prod- | pepu (Brompb0) =
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P E
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»
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»
»

[ CLBATCH.*pgm L™ Visualize Application Diagram

# B cuct *pom.clle
B-E Properties(H)

T - R ———— " 17 (= N ] ==

The service entry point is removed.

You have started the debugger using a debug action, and removed a service entry
point.

Lesson checkpoint

You learned the following:

» About other ways to start the debugger

* How start the debugger using a debug action
* How to remove a service entry point

Debugging a Job

In addition to being able to debug a program, you can also debug a job.

To debug a job:

1. Open the Remote System Explorer perspective by selecting Window » Open
Perspective » Remote System Explorer

2. Under your active server connection, s400a, expand iSeries Jobs » My Active
Jobs » QINTER.
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=& New Connection
ﬂ Windows...
‘ﬁ Linux...
- £y Power Linux...
-"uﬂ.x Unix...
E‘x ALX...
E-E Local...
+- l;" Local
(E) B s000
- ﬁ._, iSeries Objects
I 92 iSeries Commands
a iSeries Jobs
[+ ﬁ’ Active jobs
.‘a My active jobs
5 £9 qivTer
-8 263969/SCHWABEA/QPADEVODOD
22 QUSRWRK
@ My jobs
: & My host server jobs
.,.; My WebFacing jobs
i ﬁ’ My VisualAge RPG DDM jobs
l w:* TFS Files
fr Qshells

3. Right-click the active job under QINTER, and select Debug As > iSeries Job.

Elﬁ s400a
ﬁi iSeries Objects
£ .;. iSeries Commands

EI ﬁ iSerles Jobs
I: G(’ Active jobs
E'ﬁ/ My active jobs
- B2 QTer
Bt} 25 SCHWABEA /QP ARBUSESE
B J“ QUSRWRK GoTo '
E$ :‘f .:"J:St - q)s}:; Refresh
)y Y SL server =
: Jetails | Tasks | iSeries T
Edlﬁ My WebFacing jobs End » -
&-@° My VisualAge RPG DDM jobs Hold
fi IFS Files Release HE I E"
- Qshells Add To Job Status View | PAYROLLG *PGM
Display job log
User Actions 4
[ Properties £2 . Remote Scratchpad | Convert job log >
Property I Value
Current user idh SCHWABEA Pr
Entered syster Mon Mar 05 14:30:00 EST...

The debug session begins. From here you can set breakpoints, monitor
variables, and memory in the same way that you did with a program.
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= @ My iSeries job [iSeries: Debug Job]
EE_,@ Platform: iSeries(TM) Connection: torasbec: 3825
B Thread: 1 (stopped)

i PAYRC : PAYROLLG : PAYROLLG
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QUICMD : QUICMD : QUICMD
QUIMGFLW : QUIMGFLW : QUIMGFLW
QUIMNDRY : QUIMNDRY : QUIMNDRVY
QUICMENU : QUICMENU : QUICMENU
= QCMD : QCMD : QCMD

-

E

4. Terminate the debug session by right-clicking My iSeries job and selecting

Terminate.

B Jﬁ Thread: 1 (stopped)

=0
— -
S| | % e
-
Ctrl+C il
Crl+F
PAYROLLG : PAYRC 5§ Orop To Frame
_QRNP_PEP_PAYR(
QUICMD : QUICMD  “3_Step Into
QUIMGFLW : QUIM =y 5ter ey
QUIMNDRYV : QUIMI _Step Returm
; QUICMENU : QUICH s
== QCMD : QCMD : QC J*iise Step Filters Shift+F5 |

-
# PAYROLLG.RPGLE I3 I R=sume
Line &4 Column 1 M 5uspend

rowse

B .. .cLonoiFacto ++++Result
Gl %, Terminate and

i=s on (ec

(=
006500 C * TNEC ]
006600 c - Disconnect
FE— c *Remoue Al Terminated
006800 C
006300 c @ Relaunch
007000 c* B3Edit My iSeries job...
E C* IF the & EditSource Lookup...
— C* progran ¥ Terminate and Remove
[ [[@ Terminate All

Properties

Z
E console £2 . Tasks | iSeries Comn

Process: 263363/SCHWABEA/QPADEVO( ¥ (2 Show Running Threads
©Step-by-Step Debug

The debug session is terminated.
Lesson checkpoint

You learned the following:
* How to debug an iSeries Job

Module summary

In this module, you learned how to debug a program using the Integrated iSeries

Debugger.
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Lessons learned

Start a debug session using service entry points
Add a breakpoint

Add a conditional breakpoint

Edit a breakpoint

Monitor a variable in the Monitors view

Step into your payroll program

Show a Listing view

Display source from call stack entries

View all breakpoints

Remove a breakpoint

Monitor memory

Set a Watch breakpoint

Close the debugger

Invoke the debugger from a Launch Configurations window

Assessment

How do you start a debug session using service entry points?
Where can you only set breakpoints?

How do you set a breakpoint?

What is the Monitors view?

How do you change variables and indicators?

How do you step over or into a program?

What actions can you perform on breakpoints?

What is the Memory Monitor?

What type of breakpoint provides a notification to a user when a variable
changes.

Customizing the Remote System Explorer

This module teaches you how to use the Remote System Explorer perspective to
work with the iSeries objects that you used in the previous modules. You will learn
how easy it is to define filters, perform actions and define your own actions. In
short, you’ll see how Remote System Explorer can organize and integrate your
work and make that work easier.

This module also teaches you how to move, re-size or close existing views. You
learn how to open other views that you want to add to the perspective. You then
save the customized layout as a new perspective.

Learning objectives

Know the features of Remote System Explorer

Move, dock, rearrange, resize, hide, close, reopen and add views
Save and reset a customized perspective

Create a filter to show specific iSeries libraries

Change the filter to add more iSeries libraries

Create a filter to show all the source files in a library

Access members to edit from your filter
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» Create a user action that copies a source file with data to a new source file in the
same library

» Specify user action parameters

» Specify a restriction on a user action

* Try the user action

» Create a user action for iSeries jobs

» Create a user action for IFS folders and files
* Create your own compile command

» Edit an existing compile command

* Using run configurations

Time required

This module should take approximately 60 minutes to complete.
More about the Remote System Explorer

The Remote System Explorer is replacing PDM (Program Development Manager)
on the workstation. It currently doesn’t have all the function of PDM but will over
time eventually be a full replacement for PDM.

Remote System Explorer allows you to:

1. Simplify your work by giving you quick access to lists of iSeries libraries,
objects, members, IFS files, UNIX® files, and local files.

2. Use the context-sensitive pop-up menus on these lists to perform actions such
as start the Remote Systems LPEX Editor, CODE Designer, or Integrated
Debugger or other common iSeries actions.

3. Use the Work with User Actions option to create and manage your own
user-defined actions and have them appear in the pop-up menus.

4. Use the command support to increase your productivity by allowing you to
enter and repeat iSeries or local commands without switching to an emulator
session.

You have read the list of Remote System Explorer capabilities.
Lesson checkpoint

You learned the following:
* About Remote System Explorer

Customizing the perspective

Perspectives can be modified to fit your work style. You can move, resize, or close
existing views. You can open other views that you want to add to the perspective.

This is the familiar default appearance of the Remote System Explorer perspective.
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1. To move the Outline view:

a. From the Remote Systems view double-click member MSTDSP in the

QDDSSRC source file.
The Remote Systems LPEX Editor opens.

b. In the Remote Systems view, double-click member PAYROLL in the

QRPGLESRC source file.

This member will be loaded into the editor as well.

Your perspective will look something like:
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Notice the two tabs in the Editor window.Now let’s customize the

perspective.

Click the title bar of the Outline view in the workbench window and drag
the view across the Workbench window. Do not release the left mouse

button yet.

While still dragging the view around on top of the workbench window,
note that the various drop cursors appear. These drop cursors indicate
where the view will dock in relation to the view or editor area underneath
the cursor when you release your mouse button. To see the drop cursor
change, drag the view over the left, right, top, or bottom border of another

view or editor.
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e. Dock the view in any position in the Workbench window, and view the
results of this action.
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f. Click and drag the view’s title bar to re-dock the view in another position in
the Workbench window. Observe the results of this action.

g. Finally, drag the Outline view over the Remote Systems view. You will see a
stack cursor.
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h. When you release the mouse button the Outline view will be stacked with
the Remote Systems view into a tabbed notebook.
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You can also move a view by using the pop-up menu for the view.
Left-click on the icon at the left of the views title bar, or right-click
anywhere else in the view’s title bar.
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Tip: A group of stacked views can be dragged using the empty space to the

right of the view tabs.

You can rearrange the order of views in the tabbed notebook.

i. Click on the Outline view tab and drag it to be in front of the Remote

Systems view tab.

w Cutline X

#- = Fields
. @ L2 Indicators
L& Main Procedure

j- Release the mouse button when the Outline view tab is in the desired
location. The view that you selected is now moved.

@mwﬂvml °S
.'_f;‘""

=)L Global Definitions:

- = Fields
L5 Indicators
[+-L& Main Procedure

2. To resize the Outline view:

a. To resize the Outline view, select the right border and drag the mouse
pointer to the right to increase the size of the Outline view. Notice that the
Editor and iSeries Commands Log got smaller.
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b. Click on any of the other tabbed views such as Remote Systems view and

you will see this view has the same size as the Outline view.
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3. To hide a view:

You can create fast views to quickly open and close frequently used views.
They work like other views except they do not take up space in your
Workbench window.

To create a fast view:

a. You can dock views on the shortcut bar at the bottom of the workbench.
Click the title bar of the Outline view.

b. Hold the mouse button down.

c. Drag the view to the shortcut bar at the bottom left of the window and
release the mouse button. A toolbar button for that view that you dragged
now appears on the shortcut bar.
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d. Click the toolbar button on the shortcut bar to look at the view.
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e. Click somewhere else outside the view to hide the view again.

Tip: You can also create and restore fast views by selecting Fast View from
the context menu of the view’s title bar.
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Right-click the toolbar button on the shortcut bar and click Fast View on the

pop-up menu to deselect it. This will show the view again for the next

lesson.

4. To dock a perspective: By default, the shortcuts for the open perspectives are
displayed at the top right of the workbench. You can dock these shortcuts
somewhere else in the workbench.

a. To dock the shortcuts, right-click in the top right area of the workbench and
select Dock On > Left.
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The view is docked on the left of the workbench.
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Once you are familiar with the short cut icons for the open perspectives,
you can remove the text to save space.

b. Right-click the shortcut for an open perspective and deselect Show Text on
the pop-up menu.
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The text for all shortcuts for the open perspectives disappears.

& Remote System Explorer - PAYROLL.RPG!

File Edit Source Compile(G) MNavigate Sean
- | | '

* Ll = -

Sl =

[ Fields
3 L Indicators

L4 Main Procedure
- L5 Subrautines

[}~

5. To close, reopen and add other views:
You can remove views, reopen views and add new views to a perspective.

a. To remove the Outline view from the Remote System Explorer perspective,
click the Close icon in the top right-hand corner of the tab.
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Remote Systems | Team
; .
-} Fi

F - Fields

- Bl Indicatars

=] L4 Main Procedure
#-L & Subroutines

Reopen the Outline view by clicking Window > Show View > Other.
The Show Views dialog opens.
Expand General and select Outline.

E=> General
[ [0 Bookmarks
p 4" Classic Search
| E consale
(3 Internal Web Browser
T Mavigator
5= Outline
D palette
~|% Problems
L[5 Project Explorer
=| Froperties
[ Quick Edit
" Search
. KI_-I Snippets
V] Tasks

| oK I Cancel I

Click OK. The Outline view opens in the workbench at the location where

it resided last.

You can add views to the perspective.

To add the Breakpoints view, click Window > Show View > Other. Expand

Debug and select Breakpoints
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21| & Line 1 Column 1 ~ Replace
& | = | F i b LEE e B Cler e
’E i ooo100 F******:&****f*****t****ﬂ

® ooozo0 F* PROGRAM NAME - Payr

| @ LY Indicators 000300 F* DESCRIPTION - Time

() 148 Main Procedure 000400 F* exter

#-Lg subroutines 0oosoon PrAES kAR a ARk RRKRRRARELRR

ooo0s00 F* INDICATORS USED

0oo7oo FP* 50 - No record four

oposoon F* 60 - General error

ooo900 F* 90 - Protect displs

001000 F* KC - End of job rec

Q| | »

I
L —— : = RS
Remote ... | Tasks | Series T... |iSeries ... | Breakpaints 52 . = O
AP - Wi BEET

[ ® cc1.CLLE [line: 11]
[ @ Qct.CLLE [ine: 8]

= Properties 32 - Rums:ratd'npad| e
[5 % 0~
Property | vahue |

at

| i |

f. To add more iSeries views, click Window > Show View > Other.

g. In the Show View dialog, expand iSeries and choose a view from the list of
views, for example iSeries Job Status.

#0 Show Yiew | x| I

| type filker text

&-{= Help A
= (= iSeries
il = i:-E i5eries Commands Log
Lz, iSeries Data Table View
----- O i5eries Error List
[ Series Field Table View
[ iSeries Indent
. (2 5eries Java Transform and Run
~® iseries Job Log

- [ iseries Listings
28 iSeries Project Navigator
- wsz iSeries Service Entry Points
_@ iSeries Source Prompter
L, Beries Table View
# (= dava hd

h. Click OK.
The iSeries Job Status is added to the perspective.
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Line 1

ooo1lo0o
oooz2o0
ono300
ooo400
ooosoo
ooo&enon
000700
ooosoo
0oosoon
001000

4|

|/ WsTDSP.DSPE | # PATROLLRPGLE £

B Lt 2 Bkt

~

= m

Column 1 Replace

F'J(*1(*1(*'}(*1(*1(*1(*1(*1(*********************1{3
F* PROGRAM NAME - Payroll
F* DESCRIPTION - Time reporting master

E* externally described w
F****-k*********:k************************

F* INDICATORS USED

F* 50 - No record found on CHAIN operat
F* 60 - General error condition

F* 90 - Protect display on delete reque
F* KC - End of job requested

| o

(RemuteSyrstc.” |Tasksli5=r{esTable.‘. |ISerIcsComm... iBreakpohls

iF iSeries Job St..,

: [iSeries Job Status
Date/Time Submitted | 30b | Connection | Status I
< | |
_‘_I JﬂReFresh Interval: Never

Now you know how to add, move, hide, and close views. Manipulating the RSE
perspective allows you to work with a highly flexible, and customized workbench.
For example, you could change the perspective so that the editor takes up most of
the space, the iSeries Table view resides below the editor and all other views are
either closed or moved to the bottom as fast views, as shown here:
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# MSTOSP.OSPE | PAYROLLRPGLE 32 =Hml

Line 1 Column 1 Replace
| [ DO O MR e U A SR O N T
uualun F‘-t‘.*\"k‘)-".‘r‘k‘-’.'***t:**ti’:ﬁ'#‘)—'*‘!‘***1‘-’***1"##‘)—'*t***?#**?***t*t**?ﬁl
000200 E* PROGRAM WNAME - Payroll
000300 F* DESCRIPTION - Time reporting master file mainte
000400 E* externally described workstation
DDDEDD E‘*ﬁ.‘ﬁ--‘r."ﬂr**—4—*4—.4'1**.‘-.'.“"E."ﬂr++“'*+.+ﬂ'+*f++ﬂf+++*+*4’+*+++*‘!""+:"f"
0o00s00 E* INDICATORE USED
000700 F* 50 - No record found on CHAIN operation
000800 F* 60 - General error condition
ooosoo F* 90 - Protect display on delete request
001000 F* KC - End of job requested
4| | 3
|
| WS SO (Series Commands Log | [Series Job Status &E & et m)
File RSELABXX/QDDSSRC (5 Members)
Name Last modfied =
b IMSTDSP | | November 14, 2005.,.. | |
0 pramsT PF SRC November 14, 2006 .., _J
0 REFMST PF SRC November 14, 2006 .., =
o :
Cammand |Nc-rma1 _:J I :I Prompt... I F.urrl
Messagss| :J fetals,. | Showlog
| 0% % « & |

You have customized the Remote System Explorer perspective.
Lesson checkpoint

You learned the following:
* About customizing the Remote System Explorer
* How to customize the Remote System Explorer

Saving the perspective
If you have modified a perspective by adding, deleting, or moving (docking)

views, you can save your changes for future use.
1. Click Window > Save Perspective As.
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ﬁ) Remote System Explorer - PAYROLL.RPGLE - 1BM Websphere Development Studio Client Advanced Edition for... [l[=] E3

Fle Edi Source Compile(G) Navigaste Search Project Data Run I—m Help

|t N o © o NewWindow 347 | | @
| ) s s s New Editor
£l |/ MsTosPDsPE |/ PAVROLLRPGLE 52 Open Perspective =5)
| Line 1 Column 1 Replac ion View
= . SR R P~ SO S - R
F‘i 000100 Frerxrxrxtrrtrrrrrrersd P?‘P‘e‘-?-}-:‘-e‘-e‘-?e‘-ﬂ
ooozoo F* PROGRAM NAME - Pay
000300 F* DESCRIFTION - Time r file mainte
000400 F* eute  Close All Perspectives workstation
Guosuﬂ E‘:":‘r:‘r*:‘.’:‘r:":":‘r":‘.’:‘r*’:":‘r'ﬂ-:":‘r“’:"ﬂ = Akttt dh
000&00 g INDICATORS USED
ooo7o0 F* 50 - No record foul: WorkingSets ation
oooBOoO F* 60 - General erro:
000900 F* 90 - Protect disp]llfeieh uest
001000 F* KC - End of job re  Preferences...
« | _-J"|
r

2. Type a new name for the perspective into the Name field.

Enter or select a name to save the current
perspective as.

Name: | Remote System Explorer 2|

Existing Perspectives:

“=Plug-in Development ;I
(T_~ Profiling and Logging

EERarnote System Explorer (default)

[ "_,Jquuif&u'nent

[~Resource

14! Rule Builder

[F] Screen Designer (Technical Preview only)
E;GTe.arn Synchronizing

[E Test

@ Web

I'=|\§ WebFacing

| oK I Cancel I

3. Click OK.

The name of the new perspective is added to the Select Perspective
windowWindow > Open Perspective menu then select Other.
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# Open Perspective | x|

9 Crystal Reports

%}CVS Repository Exploring
[EData

?Debug

| # Generic Log Adapter

iSeries Projects

4% jopE

a"llava

:3 Java Browsing

ng:lava Type Hierarchy

“=Plug-in Development

(U Profiling and Logging

ERemote Systemn Explorer (default)
Eaﬂemote System Explorer 2

|1 J|Requirement —
[|.';|Resource

%! Rule Builder

[T Screen Designer (Technical Preview only)
-r-:DTn:m Sumrhenmizinm -:]

s

You have saved the perspective.

Tip: You can also make the new perspective the default by selecting Window >
Preferences, expanding Workbench and then clicking Perspectives. You then select
the new perspective and make it the default by clicking Make Default. The next
time you open the workbench, this will be your default perspective.

Lesson checkpoint

You learned the following:
* About saving a perspective
* How to save a perspective

Resetting the perspective
If you have modified a perspective and don’t like the changes that you have made

you can reset the perspective to its original layout.
1. Move some views around in the current perspective.
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/ PAYROLLRPGLE 52 . =0
Line 1 Column 1 Replace
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{5eries Commands Log | ¥ iSeries Job Status 55 & = 0]
Date/Time Submitted [ 30b | Connection | Status | Task =
|
|
i
|
_‘__] l L4 lRefrssh Interval: Never |

2. Click Window > Reset Perspective.
The following message dialog appears.

% Reset Perspective

Do you wartkt to reset the current Remote System Explorer 2 perspective to its

\‘-:/ defaults?

3. Click OK.
The perspective returns to its original layout.

4. Click Window > Open Perspective and select Remote System Explorer. This
opens the default Remote System Explorer perspective, ready for the next
exercise.

You have reset the perspective.
Lesson checkpoint

You learned the following:
» About resetting the perspective
* How to reset the perspective

Expanding files and folders

Typically you start using the Remote System Explorer by just expanding libraries,
then objects, then source files and then members. You can also expand the Home
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directory to see folders in \home in IFS. But sometimes this produces lists that are
too big. You really want to keep lists small, to a few hundred at most.

One very quick way to reduce the amount of items in a list is to use the Expand
To object for libraries. It allows you to expand a library to see only objects of a
particular type. This subsetting remains in effect forever, even when you expand

with the plus sign, until you subsequently choose All or any other expand-to
criteria.

To expand files and folders:
1. In the Remote Systems view, right-click library RSELABXX.
2. Click Expand To > Source Files from the pop-up menu.

€0 Remote System Explorer - PAYROLL.RPGLE - IBM Websphere Development Studio Client Advanced Editig
File Edit Source Compile(G) Mavigste Search Project Data Run Window Help

| A % C i |80 -Q- B |4
= 0|/ rarolLreelE B N1 < 0| 25 outine &
= - Line 1 Column|
LI I........l.... El"r;'nGl_obal
ey || =88 s400a 000100 praxxxac @l | gD
Ea = b” iSeries Objects 000200 F* PROn | - Fi
& A work with libraries. ., 000300 F* DE&! [ Elgn
1 5 work vith objects. .. 000400 E* S
1“4 Work with members. .. 000500 Fhxxkik HLlg s
A = ¥ "
=g Library list | 000600 F* TIND:
| H-B QSYS. Mib.proc New » FE* 50 -
B B QsYs2Mbpre oo i
[ m, QHLPSYS. *lib.| - g

- ml QUSRSYS. *ib, Expand To

e, o 5] Data Files
- s+ Refresh H
R, WSSLABKK Mt e
& = User libraries - Luzevm ﬁl:isl
£ E: iSeries Commands o |_] ess5age Files
£ ﬁ iSeries Jobs =l 27 5ave Files
-2 IFS Files W e 2] Programs And Service Programs
2 Qshells 3 Delete... S Moddes
4 | Add Library List Entry... .4 Binding Directories
" prooertes. 20 Famors o ™ Remove From Lbrary List (Jipeta Queves
s SEEES e 4+ Move Up In Library List . pData Areas
< L Move Down In Library List v Al
Property | value 1. pove Within Library List... l
fkkrib ke TEST-l ISR

All the source files display.
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HEEEEEEEEEEEEEEEER

[ cLBATCH. *pgm.dle
-[# cLc1. *pgm.dle

[® cLr1,#pgm.dle

[# MYCOMPILE. *pom.dle
[E paYROLL. *pgm.rpgle
[ PAYROLLD.*pgm.cblle
[# PAYROLLG.*pgm.rpale
(55 COMPARE. *file.pf-src
& EMPMST. *file.pf-dta
5l EVFEVENT. *fle.pf-dta
65} MSTDSP. *file.dspf
& MSTDSP2, *file.dspf
-[El PRIMST. *file.pf-dta

(5 QCLSRC. *file.pf-src
-E8 QCMDSRC, *file.pf-src
-[5h QDDSSRC. *file.pfsrc

| | B8 Y

|53 QCBLLESRC. *file. pf-src

=

Right-click RSELABxx and click Expand To > Data Files on the pop-up menu.
All the data files display.

4]

#-& Local
=B sq00a
= E.“, iSeries Objects

H 75_; Work with libraries. ..

A% Work with objects...

= Xﬁ Work with members. .,

Ei f.-_ Library list
LT._ B QSYS.Hib.prod-sys
-2 QSYS2.¥ib.prod-sys
[+ -2, QHLPSYS, *lib.prod-sys
- QI..ISRS\'ﬁ *iby. prnd-sys

EMPMST. *file, pf- cta

-IE)l EVFEVENT *file.pf-dta

-5 PRIMST. *file.pf-dta

REFMST *file, pf-dta
B-1E) RSNMST, *file.pf-dta

| I: B, WSSLABKYK, Hib. prod-usr

B | kear Itl'\rari:r

of

Right-click RSELABxx
All the files display.

and click Expand To > All on the pop-up menu.
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CLCL *pgm.clle

CLRA *parm.clle
MYCOMPILE. *pgm.clle
PAYROLL, *pgm.rpgle
PAYROLLD, *pgm.chlle
Gl PAYROLLG. *pgr.rpgle

~[5 EMPMST #file pf-dta

|55 COMPARE, *file. pf-sre

~[5] EvFEVENT *file.pf-dta
6] MSTDSP, *file dspf

S} MSTDSP2.*file dspf

=) PRIMST. *file.pf-cka
[5h QCBLLESRC.*File.pf-stc
[Eh QCLSRE *file.pf-sre
(50 QCMDSRE *file, pf-sre
|___0 QDOSSRC, *file.pf-src

| O S _[Bh rogm espr il rfaerr
4 1 4

You have learned how to expand source files, data files and all files in the
RSELABxx library.

558 5 5 556855

Lesson checkpoint

You learned the following:
* About expanding files
* How to expand files

Introducing filters

Eventually you will find the need to see a subset list. That is what filters offer and
the Remote System Explorer has extensive filter support. On each subsystem you
can create filters. In the iSeries Objects subsystem you can create a library filter, an
object filter and a member filter. In the iSeries Commands subsystem you can
create a command set filter. In the iSeries Jobs subsystem you can create a job filter.
In the IFS Files subsystem you can create a filter.

You can also use the Work with libraries, Work with objects and Work with
members prompts under iSeries Objects to create filters.

There are several predefined filters as shown below under the Remote Systems
view.
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Line 1 Column
I........i...- [SREEN
# & Local 000100 F******'ﬂ B0
= B s400a 000200 F* PROI 228 o
¥ T e
5 ?1‘3; e— = Lbrary...
E5 o ork with libraries,”
; Go Into 2
A7 work with objects... sitlrsy st Al
I Go To Ll 4
+] 1 Il
[ Library st mber... % Object Fier!
[+ User fibraries Goen e 24 Member Fikter,
B 3 !?Ienes Commands F Showy in Tble E* an
- o0 Your commandis) S Ko -
L % Add library to library list Wark wWith » F\\\ ’LI
w5 Change current library = e
[+ ;L:{ Remave library From library list " Refresh ] New Filter
£=] g:-:- Create lbrary Change Password. . Actions
! w Create source fils B ilenee Intaracive dak —
[# ¥ Create source member pioie s [l28ne
| el : > Yerify Connection, . s
B g Create duplicate object j Disc o | af o ]
B - iSEries ?Oh? Cleat Password —L————w—-—l—-—ﬂpwmt file | Remote &
l_if] @ m""e_]ﬁt'? pleiades Local
& a;:- My active jobs Remote Servers L& pleiades iSeries
 @" My jobs
@ My host server jobs Show Log
@ My WebFacing jobs Run Command...
(@ My Wisualdae RPG DDM iobs Pronattis

f= Properties &3 \"‘\_jl.emote 5aatchpaﬁ‘ ] ]

You have learned what predefined filters exist in each subsystem and how to

create a filter.

Lesson checkpoint

You learned the following:
* About predefined filters

* How to create a filter

Creating a library filter

In the Remote System Explorer perspective, you now need to get to the iSeries

objects you want to work

In the previous modules you have worked with the Library list. Now you wiill

with.

create your own library filter. Library filters list a set of libraries from your iSeries
system in the Remote Systems view. But first let’s understand what filters are all

about.

Filters allow you to easily organize elements within your system. You use the filter
function to list iSeries native file system objects (such as libraries, objects, or

members).
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[# & Mew Connection
# Bl Local
=B s400a

E

j H _.}a‘ﬁ Work with members. .,
i #H i Library list

[+ §~ User libraries

E: iSeries Commands

&% i5eries Jobs

¥ IFSFiles

B Qshells

-
E

To create a library filter:

1. In the Remote Systems view expand the connection that connects to your
iSeries system if its not already expanded.

2. Expand iSeries Objects if its not already expanded.

3. Expand Work with Libraries. (You can also right-click iSeries Objects and click
New > Library Filter on the pop-up menu).

Expanding Work with libraries corresponds to the WRKLIBPDM command,
plus creates the filter in the Remote Systems view.

The Create a new iSeries library filter page opens:

Library Filter _’1

Create a new iSeries library filer

Library: lRSE"‘ _:] d Browse. .. |

7 < Back I Mext > I Firiish | Cancel I

You are going to create a filter to specify the libraries you want to work with,
so they will show in iSeries Objects. You want to create a filter that shows all
libraries on the iSeries with the name RSExxxxxx and VARXXXXXXX, XXX being
any character.

Note: You may need to select different libraries that appear on your system if
libraries with the above names do not exist.

You specify the first filter string that selects the libraries starting with RSE.
4. Type RSE* into the Library field, using the * wild card character.
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5. Click Next.
The Name the new filter page opens.

Library Filter 1
Mame the new Ffilker =,
=5 |

Filters are saved for easy re-use, Specify a unique name for this filter, This name will appear in the
Remote Systems view, and will be expandable,

Filter name: ﬂ All RSE and VARPG libraries| ]

[~ Only create Filter in this connection

Select a profile ko own the new filter, This determines if it is unique to you, or sharable by the team. It will
be placed in the default filker pool for that profile.

Select the profile whose default filter pool is to contain the new filter: |pleiades :J

=)

= Back l Mext = | iﬂnlshl I Cancel I

Tip: You can choose between creating the filter for all connections or for this

specific one only.
6. In the Filter name field, type A11 RSE and VARPG libraries.

You give your filters a name because the Remote System Explorer saves them

for future use, unlike PDM, which does not save filters.
7. Click Finish.

Back in the Remote Systems view under iSeries Objects you will see the new

filter. Expand it to see the list of all RSE* libraries.
Now you need to add the VARPG libraries.
8. To change the library filter:
a. Right-click the filter All RSE and VARPG libraries and click Change.

Team = 0| # parroLLRPGL

| = r__? ‘7| Line 1
# zu User libraries :“
SB=R 41| RSE and VARPG libraties 000100
[+ B, RSELAEET *lib.prod  New 4
[#]- B, RSELABETZ *lb.pro  Go Into
[# B\ RSELABDY . *lib.test Go To 3

[ B\ RSELABSQL.*ib.prc __
G ik RSELABXX, *Ib.test =4 Open in New Window
¥ B, RSELABOD. Mlb.prod
¥, RSELABOL *ib.test
) B\, RSELABOZ *ibtest [FYNFaumm—_
BB RSELABOS, *ib.test
[ B\ RSELABO4. *lb test | Rename..,
| [ mA RSELABOS ib.test 1| Copy
«| - e 1+ Move. ..
3 Delete. ..

- Refresh

|r 2 Properties 53 “. Remote Sicratchp.
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The Change Library Filter window opens.

# Change Library Filter | x|
Filter name: &l RSE and YARPG libraries
Parent filter pool: Pleiades Filter Pool
Filter strings:

Mew Filter string:

[Lbrary: Im :]] Browse. ., I

Test | [create] | Revert [

[ew Filker string
ke

- | Cancel |

Select New filter string from the Filter strings list.
In the Library field, type VAR=*.
d. Click Create.
The VAR* filter string is added to the list.
e. Click OK.
You are now back in the Remote Systems view.

e o

= |m
roa T =S |
= 185~
[ B, RSELABS7.*lib.test -]

B RSELABYS,*ib.test
=, RSELABSY, *ib.test
[+ B, RSEXDETES.*iib.prod
[+ -2 VARLABXX.*fib.prod
I't ‘B, YARLABOD. *hib.prod
[+ =, YARLABDL, *lib.test
[ = VARLABZ1.*ib.test —]
[+ B, YARLABZ22.*lib. test
[# -2 YARLAB23.*lib.test
B, YARLAB24.¥ib.test
¥, YARLABZS, *hb.test

' [ B, YARLABZG. *ib.test =
" sl [ ﬂ,_l

You will see the list expanded to include your filter. Now you can work
with the libraries directly and can drill down to the object you want to
work with.

You have created a filter to show a specific iSeries library and changed that filter to
add more iSeries libraries.

Lesson checkpoint

You learned the following:
* About library filters
* How to create and change a library filter
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Creating an object filter

Now create an object filter. Object filters list a set of objects from your iSeries host
in the Remote Systems view.

To create an object filter:

1. In the Remote Systems view, expand your connection and then expand iSeries
Objects if not already expanded.

= |ml

£ | EES

[ A5 work with objects... | A
- B A7) Work with members. .,

i # ﬂ; Library list J

.- E) User libraries
LB g.;lﬂ All RSE and YARPG libraries
It ‘B, RSELABST.*lib.prod
[ B RSELABBTZ. *fb.prod
[ = RSELABDY.*ib.test
[*-m, RSELABSOL."iib.prod
[# -2y RSELAEKY,*lib.best

H: ‘B, RSELABOO,*|ib.prod
¥ -2 RSELABO1.*ib.test

' [ B, RSELABOZ,*ib.test =
4 —_ i Ll—‘

2. Expand Work with objects. You can also right-click iSeries Objects and click
New > Object filter on the pop-up menu.

Tip: Expanding Work with objects corresponds to the WRKOBJPDM
command.

The Create a new iSeries object filter page opens:
Now create a filter to show all your source files in your RSELABXxx library.

Object Filter
! A

Create a new iSeries object fileer # ] g
;] ﬂ Browse. ., |
Object: I =~ ﬂ Browse.., |
Obiject bype: |"‘ ;' ﬂ | Browse.‘l |
Object atbributs: |“ ;i ﬂ Brows

More Types>3 l

Library:

(=)

ceack [ mext> | Frist | cancel

3. In the Library field, type RSELABxx.
4. Click Browse beside the Object type field.
The Select Object Type window opens.
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# select Object Type | x|

Select an object type:

*CHTFMT ]
*CLD
*Cls
*CWD
*CHAL
*COSD
*CSI
*CSPMAP
*CSPTBL
*CTLD
*CRG
*CRQD
*DEYD
*DOC
*DTAARA
*DTAQ
*EDTD
YEXITRG
*ECT
*FLR
*ENTTBL

*ENTSRC ;I
HECRMNE

| OK I Cancel I

5. Select *FILE under the Select an object type list.

6. Click OK.
The Create a new iSeries object filter page displays with the object type
updated.
Object Filter 1
Create a new iSeries object filker # 3
=d

Library: IRSEL.ﬂ.Bxx ;] j Browse. ., |
Object; I* ﬂ ﬂ Browse. ,, |
Object type: | *FILE 8| eowse.. |
Object attribute: [* 1] [owse.] |

More Types:>» |

< Hack l Mext > I Finlish | Cancel I

7. Click Browse beside the Object attribute field.

The Select Object Attribute window opens.
8. Select PF-SRC from the Select an object attribute list.
9. Click OK.

I‘\-J 1]
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10.

11.
12.

# Select Dbject Attribute [X]

Select an object attribute:

BSCF38
CMNF38
DDMF

DFU
DFLUEXC
DFUNOTEXC
DKTF

DSPF
DSPF3&
ICFF

LF

LF38
MKDF38
PF-DTA
PF38-DTA
PF38-5RC
PRTF
PRTF3E
SAVF

TAPF

| oK I Cancel

Click Next.
The Name the new filter page opens.

Object Filter
’ -p |,
=5 j'

Mame the new filter

Filters are saved for easy re-use, Specify a unique name for this filter, This name will appear in the
Remote Systems view, and will be expandable,

Filter name: | My source Files|

[~ Only create Filter in this connection

Select a profile to own the new Filter, This determines if it is unigue to you, or sharable by the team. It will
be placed in the default filter poal For that profile.

Select the profile whose default filter pool is to contain the new Filter: |plefades ‘j

|-qJ ]}

<Back | mext> |[ Fmish | cancel

In the Filter name field, type My source files.
Click Finish.

The new object filter displays in the Remote Systems view under iSeries

Objects:
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) QCBLLESRC. *file.pf-src

0 QCLSRC, *file.pf-sre

0 QCMDSRC. *file.pf-stc

) QDDSSRC, *file,pf-src

) QRPGLESRC *file. pf-src

57 QRPGLESRCP. *file pf-stc
50 QSQLUCD *ile.pf-src

I.*.-i--E: iSeries Commands

-8 iSeries Jobs

#-T% IFS Files
¥ Qshells -
4| | 3

Note: If you end up with too many filters, you can create filter pools. They
allow you to group filters. You will learn about filter pools later.

Now you know how to create filters and tailor your development
environment. Filters can also be specified for non iSeries servers and your
local system.

Now you can work with the objects you have in your Remote Systems view
like you worked in PDM with a subset of libraries, objects, or members.
Let’s assume you want to edit the member PAYROLL in the source file
QRPGLESRC using this object filter.

13. To edit a member from your own object filter:
a. Expand QRPGLESRC.
b. Right-click member PAYROLL.
c. Click Open With > Remote Systems LPEX Editor on the pop-up menu.

This will download the source member and open the editor with this
member. After you have edited the member you could save it and then
compile it from the Remote Systems view by using the pop-up menu
options on this member. You can also create your own actions in addition
to the default actions. You will learn about creating user actions later.

You have created a filter to show all the source files in your library and accessed
members to edit from your filter.

Lesson checkpoint

You learned the following:
* About object filters
* How to create an object filter

Showing Filter Pools

If you have been using the Remote System Explorer for some time, your
workspace might contain too many filters to navigate easily. Or, you might just
want to keep groups of filters separate if, for example, you need to represent two
distinct iSeries environments in the Remote System Explorer, regardless of how
many filters you have. In either case, you can group filters into filter pools.
Without filter pools, all of your filters appear together in all connections. When
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you create filter pools, however, any filter you create within that filter pool is
distinct to that connection, and will not appear in any other connections.

1. Create a connection to the same host. (Expand New Connection then iSeries).
Give your new connection the name s400b.

2. To illustrate the use of filter pools, Click the menu button on the toolbar for the
Remote Systems view, and select Show Filter Pools.

st |[# pavrolLrpae 2 N1 = O
T Line 1 Colunn
B, cource Files New Connection. .. i
= e de k.
J‘J COMPARE . *file.pf-src I Yith Profiles A
#-[5 QCBLLESRC *file. pf-src PROI
[ QCLSRC. *file.pf-src Refresh Al DES:
£ QCMDSRC, *file.pf-sre : "
- [55 QDDSSRC.*file. pf-src .- Hasmies Ahak
. B » Show Filker Pools 2 :
# E) QRPGLESRC. fie.pf-src = - TND
1[50 QRPGLESRCP, *file. pf-stc . | 50
-5 QSQLUCD Hfile.pf-src ki a0
- B iSeries Commands Stop Communications Dasmon an
g teies Jobs 001000 F* KC
#-TF IFS Files -
LI Qehels = = |
<| | » I
(Y | =7

3. Under iSeries Objects you can now see your filters listed under Connection
name Filter Pool.

e =
£ B

[# & New Connection

# B Local

B- ﬂg, iSeries Commands
| @ Bo Pleiades Fiter Pool
=g iseries Jobs
& T Pleiades Filter Pool
-2 1F5 Files
-3 Qshells

4. Right-click iSeries Objects and select New > Filter Pool.

'/ eAYROLLRPGLE 32 ™A
Line 1 C
[#-.4" New Connection I- e
# ?EﬁLotal ggg;—gg Fi*'
= 54003 F*
R Obiccts nAnN3nn ok
5t peindes 7 T - i
=B iseries Comma Go Into «# Filker Poal..
- o PleiadesFi GO Filter Pool Reference »
:| ﬁlSemsJobs 00700 T
e Open Member, .
i B Eo Pleiades Fi %Omnhl\bw'ﬁhﬂow ooeon F*
-8 175 Fles o 00900 F*
L £5] show in Table
B 01000 F
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5. Enter a pool name and click Finish. (You do not need to change your profile
selection.) Your new filter pool displays underneath your connection.

# New Filter Pool | x|
System Filter Pool _)"
Define a new pool For filkers Q0

-

Pool name | myfikerpool|

Profile |pieiades ﬂ

H-J il

Finish I Cancel I

The filter pool is added only to the connection from which it was created.
6. Right-click your new filter pool and select New > Library filter.

7. Complete the wizards as you did before. Use *LAB* as the generic library name
for the library filter. Give your filter any name you like. Click Finish.

8. When you are finished, you can see your new library filter displayed
underneath the new filter pool.

[# & Mew Connection ﬂ
Bl Local
=B s400a
- 8% iseries Objects
B Pleiades Filter Pool
= "o myfikerpool
= & [
F B, ADTSLAS Mib.prod
[+ B, ADTSLABKUA b prod
[+, ADTSLAB1.*lib.prod
[+ B, BLWSSLAB. *lib.prod
(B, EWRSELABO1, b, test
[+ B, EWRSELABOZ,*lib,prod
[ B, LABUSERS. *lib.prod I

If you decide not to work with filter pools anymore, click the menu button on
the toolbar for the Remote Systems view, and select Show Filter Pools again to
clear the check mark.

For each filter pool, you can right-click and select from a number of actions.
For example, you can rename, copy, move or delete a filter pool.

You have learned how to group filters into filter pools and how to create a new
filter pool.
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Lesson checkpoint

You learned the following:

* About filter pools

* How to create a new filter pool

Sharing filter pools

You can share filter pools among many connections through the use of a filter pool
reference. A filter pool reference is a mechanism that displays a filter pool from
one connection in any other connection, so that when you make a change to the
original filter pool, your change is reflected in your filter pool reference. Before you
create a filter pool reference, ensure that you have already completed the
following: You have defined more than one connection to the same iSeries server
You have defined more than one filter pool You have enabled Show Filter Pools
from the Remote Systems view toolbar .

To use filter pool references:
1. Make sure you have another connection established.

2.

a filter pool that exists in another connection.

profile > pool name.

In the Remote Systems view, expand the connection where you want to display

Right-click iSeries Objects and select New > Filter Pool Reference > your

-
]

[+ Windows. ..
=0 Linw...
#H A Power Linux. ..
- tnis Ui, .o
B ALK,
#H B Local...
F-E Local
B s400a
= E‘a 540033
ISR iSeries Objects
- P

£ ] Ep iSeries Commar
L] "

|

i HEFCOCORT T R

R] Connection created successfuly. = |

/7 OpenMember... |

Team = 0|/ pavrolLrpGLE 2 N1
[BS ~ Line 1 Column
| B e
000100 FAXAAA4 &
ooo200 F*  DPRO
000300 F* DES:
0oD400 B*
000500 e
000600 F* IND
poo7o00 F* 50 -
oooBoo F* 60 -
0oog0o0 F* 90
= Lbrary... \1"‘: »
Go Into B Filter Pool,.,. LI—I
GoTo Lg

:E\'

= Outine 52

=

L& Global Definitions

® [ Files
[ Fields
#Lg Indicators

%‘} Main Procedure

& Lg subroutines

4. Look under iSeries Objects again and you will see the filter pool reference.
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.1;__E<n_am_o,;§ Systems X

£ & # | BSY
?ﬁ s400a -
| B8P iseries Objects
.‘ _-§° Pleiades Filker Pool
= :i':ﬂ myfilber pool
_ & g0 MYLIB
5B iSeries Commands
2] ﬂ iSeries Jobs
#-TF 1FS Files
=@ s400aa
£l @ iSeries Objects
IE }:“ Pleiades Filter Poal
=-Be
_ g MYLIB
-8, iSeries Commands

ﬁ iSeries Jobs -
4| ' | ,

Next, you make a change to the filter pool in order to see that change also
occur in the filter pool reference.

5. Add new obiject filter called RPG. Right-click your new filter pool and select
New > Object filter. Complete the wizards. When you are finished you will see
the referenced filter is available in both connections.

5

B s400a ;’
- &7 iseries Objects
[+ __3':"-‘ Pleiades Filker Pool
= }{0 myFilkerpool
H-E0 MYLIB
=-@F RPG
H By iSeries Commands
@9 iSeries Jobs
#-T* IFS Files
- Qshells
= s400aa
- B iSeries Obijects
: }{0 FPleiades Filter Pool
= He myfikerpool

6. To delete a filter pool reference, right-click it and select Remove reference.
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MNew »
Go Into
Go To L4

£ open in New ‘window
Show in Table

o Refresh

[ Rename...
= Copy
«i—o Maove...

M Remove Reference

# Delete...

1 MoveUp
,', Move Down

Froperties

7. You can also move your filter pools up and down with the pop-up menu.

MNew L4
Go Into
Go To »

£ open in New ‘window

" Refresh

¥ change...

[ Rename...
|{=| Copy

o1s Move..,
W Delete...

E5 Show in Table
# Find String. ..

1L Wisualize Application Diagram

Properties

You have learned how to share filters.
Lesson checkpoint

You learned the following:
» About sharing filters
* How to share filters

Creating a user action

In PDM you can create user actions in addition to using the pre-supplied system
actions. In Remote System Explorer you can do the same. You define user actions
through the Work With User Actions window. User actions can be defined for
iSeries libraries, objects, members and jobs as well as folders and files in any
remote UNIX, Windows, Linux, Local, or IFS system.
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To open the Work with User Actions wizard:
1. Expand your iSeries connection and expand iSeries Objects if not already

expanded.
|[# pavroLreate 22 N1 T O[S outine 88\
Line 1 Column
I' ERC I l- P HL{E‘E Glubal Dﬁﬁl‘l
=B iseries Objects nnnann f‘******' a [} Fles
= $o Pleiades Fiter Pool il F PROI ) {— Fields
w3 work with lioraries. . GoTo *k DES L3 Indicate
- 57 work with objects. . EcaTo y [F =1 Main Procec
1"] 1‘5 wark with members. ., eIt PR ¥ L Subrout
= mb Library list v Refresh = TND
| E-ER Q5VS.Mib.prod-sys = o 50
| BB Q5YS2.Mbprod-sys | REname. . - 60
= 90
5 £ KC
H -
f Ll_'
# = User libraries Add Library List Entry. .,
# m% All RSE and VARPG librarie 3% Remove From Library List
1.
i @ My source files Mave i In Ligrary List
i a — L el TE TasksaiSeriesTd:Pe...liSeriesCu‘nm
| | .. Mave Down In Library List — |
o [ i A i | @R e i
i e — o el R e [ Parent profie | Remote sys... [ co
| 5% Show in Table pleiades Local 5o
Property | value %" Find String... pleiades iSeries Sa
Attribute TEST-USR Change... pleiades iSeries Mo
Marme RSELABXX Save(B)...
Murnber of childre O Restore, .,
e Q915 User Actions &y \With User Actions. ..
Status oK -
4| T | Create iSeties Project |

2. Expand the Library list filter if not already expanded.

3. Right-click RSELABXx.

4. Click User Actions > Work with User Actions on the pop-up menu.
The Work with User Actions window opens.

# Work with User Actions | x|

Parent profile: {[3

= &% New
{5 oObject action
0¥ Member action

Close |

5. In the right pane of the Work with User Actions window, expand New in the
list, if it is not expanded already.
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6. Select Object action.

You want to create a user action that copies a source file with data to a new
source file called QIUNKSRC in the same library.

Parent profile: |pleia=:les

=B New
[ Object action
117 Member action

# work with User Actions | x|
Action name: i Copy source file
Comment: I Copy source file with data
Command: ]Nnrmat command _:l
lCRTDUPOBJI | |
< LH
Insert variable. .. I Edit... | Browse... I
™ Prompt first I~ Refreshafter |V Show action
[ Single selection only [ Invoke once
Resource types for which this action will appear
Defined Types Selected Types
Add>
=RemovelE)
Edit(H)...
Create I Revert{J} I

Close |

7. In the Action name field, type Copy source file for the user action name.

8. In the Comment fiel

9. In the Command field, type CRTDUPOBJ for the command to execute.

d, type Copy source files with data.

10. Click Prompt to open the command prompter for this command.
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# Create Duplicate Object (CRTDUPOBI) | x|

From object: BN j Mame, generic*
From library: & _‘_] Mame

Object type; e :-Jl Add I
To library: *FROMLIB | Mame

New abject: QIUNKSRC ¥ | Hame

From ASP device: * > | Hame

Tao ASP device: *ASPDEY =] name
Duplicate data: hd

Duplicate constraints: | *vEs =

Duplicate triggers: !"\'ES =

I advarced v gl Parameters [ Keywords

CRTDUPOB] OBJ(&N) FROMLIB(EL) OBITYPE(&T) NEWOBJQIUNKSRC) DATA(YYES)

=]
=

ok | Restoredefouks|  cancel |

This is the command you will be running:
CRTDUPOBJ OBJ(&N) FROMLIB(&L) OBJTYPE(&T) NEWOBJ(QJUNKSRC) DATA(*YES)
11. To specify user action parameters:

a. In the From Object field, type &N to indicate to use the name of the
selected object in the Remote Systems view.

b. In the From Library field, type &L to pick up the library name from the
selected object.

c. In the Object Type field, type &T to pick up the object type from the
selected object.

In the New Object field, type QJUNKSRC.

Select the All parameters check box to see the additional Duplicate data
parameter.

Now the Duplicate data parameter is also shown on the prompt window.
f. Select *YES from the Duplicate data list.
g. Click OK.

You return to the Work with User Actions window.

Tip: You can use the Prompt button to enter the variables or you can type
the command directly and when you type &, you see a pop-up selection
list, or you can use Ctrl+Space or press the Insert Variables button. From
the list, you can then double click to insert the selected variable, at the
cursor position.
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& Work With User Actions x| N 5
Parent profile: |pleiade; :j
= g New Action nama; | Copy source file butline 52
- Object action
“..[3% Member action Comment: | Copy source file with data
Command: INurmaE command ;I | &% Global
s
RTDUPOB] OBJ mi s
&G - Job description library, from Command Execution properl a |
&H - Job description name, from Command Execution properti
l 8I5] - SBMIOB additional parameters, From Command Execut
&J - Job description library/name, from Command Execution p
Insert variable &L - Object or member library name
=== &MF - File name of temporary member, containing selected re
Prompk... &ML - Library name of temporary member, containing selectec—
&MM - Member name of temparary member, containing select
&N - Name of selected resource
™ Prompt first &0 - Object library, from Command Execution properties b
I single selectic 4] | |

h. Select the Refresh after check box, so that the Remote Systems view gets
refreshed after the action has been run.

# work with User Actions 5]
Parent profile: |pleia=:les :J
B a5 e Action name: | Copy source file
ff&i Object action .
(1% Member action Comment: lCopy source file with data
Command: {Normeal command =l

CRTDUPOB] OBJ(&M) FROMLIB(EL) OBITYPE(EFROMLIE) TOLIB(C LI

. ull

Insert variable, .. l

Edit... | Browse... I

Prompt. ..

™ Prompt first

I Single selection only

Resource types for which this action will appear

¥ Refresh after| [V Show action

Invoke once

LIB
MSGF

Defined Types Selected Types
FILE_DSPF - Add> I]FILE_SRC |
FILE_MERS _| I [ I
=RemavelG)
(e | —; -
hd

FILE_SRC: *FILE:PF*-SRC

G=e) |

Revert{J) I

Close |

Tip: Clicking the Insert variable push button displays a list of valid
replacement variables with the explanation of what they do.

This user action is only valid for Source physical files. You need to specify
this restriction so this user action will only show in pop-up menus when
you right-click on a source physical file.

12. To specify a restriction on a user action:

a. Under the Defined Types list box,
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b. Click Add beside the Defined Types list box.

FILE_SRC is now one of the selected types. Actually since you only
selected this one it is the only one.

c. Click Create then Close.

Now, only when you right-click on a source file, will this user action
appear on the pop-up menu. For any other object type it will not appear.
Back in the workbench and the Remote System view, give it a try.

Tip: Remember to close all the source members if you opened any earlier.
13. To try a user action:
a. Locate your filter My source files.

] = 8| ZeavroreaiE 52 Nt OJ[EE outine 32
== Line 1 Column
;I I ........ 1 S s 3._{%}.;|Fba||:
f) COMPARE. *file.pf-src 000100 Fraxxxxalll | @0 Fe
) QUBLLESRC *files.pf-sre goozoon F* PROI i H '!j Fiek
0 QCLSRC.*file.pf-src 000300 F* DEBS: ¢ B-lg Indi
£ QCMDSRC, *file.pf-stc 000400 E* & L8 Main Pre
0 QDDSSRC.*file. pf-src gposoon Fkok ok bk H-Lg sub
GLESRC, *file.pf-src = e S o 5 F* IND
- 55 QRPGLESRCP. *file. pf-sr i F& &
50 QSQLUCD. *file pf-src Go To E F* &0
: o myfilterpool & Refreh F* ag
l't'_'"-g? {Series Commands e F* KC
Wﬁ iSeries Jobs 1 Rename.., _lﬂ
- 1FS Fles = Copy ’
[P qshells o
W Foste
= B sq0022
=g iSeries Objects & Move.., = T
. - | | % Delete... _Tasks | iSeries Table .. | iSeries Cc
= [ 25 & |
. c i | RN
= Properties 5% . Remote Scratchpad & Showin Table
= b 5 % Cathe Fie Descriptions I Parent profile I Remate sys... |
B 5P E:, ? Find String, . pleiades Local
Propetty | value charal) pleiades iSeries
Attribute PF-SRC S pleiades i5eries
Name QRPGLESRC
Mumber of childre 3 Resto... - .
Source RSELABYX User Actions B Copy source file
Skars OK Add To iSeries Project :
o e e o g Work With User Actions...
4] | _ Make Avalable Offine T

b. Expand the filter My source files, if it is not already expanded.
c. Right-click the QRPGLESRC file.
d. Click User Actions > Copy source file on the pop-up menu.

The file gets duplicated and the list gets refreshed. Your new source file
will show in the list. You can check the messages of the CL commands you
are running in the RSE communications server job by looking at the iSeries
Commands log view in the bottom right of the workbench.

Remote System Detais ! Tasks | iSeries Table View
54003 ]

CRTDUPOB] OBMQRPELESRC) FROMLIB(RSELABRX) OBITYPE(*FILE) NEWOBJ(QILUNKSRC) DATA(*YES) =]
Object QIUNKSRC in RSELABXX kype *FILE created.

1 obgects duplicated,
Cause .., ,.: Alltheobjects with supported object bypes specified on the Create Duplicate Object (CRTDUPOE]) command
were duplicated, See low level messages to determing if any objects were not duplicated.
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created is not there.

e. Try other objects such as *pgm or *lib. Notice that the action that you just

] Q: iSeries Commands

4 [

< Move Down In Library List
<1+ Mave Wikhin Library List...

P MSTDSP.DSPF 52 = O/ 5% outline 53
el ol Line 1 column| @ E§ ms
o T —— BT S
3 ¥ W » * -
: B WSSLABRR, Mib.pr A*F3TS
- g0 User lbraries s Ml ax g9/
B &> AllRSE and YARPG BBl Expand To p| AxEEAKA
=@ My source files A* THI
[+ 5y COMPARE . *file.pf ' Refresh A*  TIM
B 50 QCBLLESRC *file, A*x
(50 QCLSRC.*file.pf-< | Rename... a*
B (5 QCMDSRC. *file.pl =1 COPY DA KA
e L—T‘p QDDSSRC. *file.pf [l Past= A*2LEC
- 5 QIUNKSRC *file.r 3¢ Delete.., A
0 QRPGLESRC. *file. -
{) QRPGLESRCP,*file  AddLibrary List Entry... _>|_I
1 56 QSOLUCD. *file.pf ™ Remave From Library List
& po myfilterpool 4 Hove Up In Lbrary List

liseries Table ... |ﬁ|:iSarissCornm...

BLESRC) FROMLIB(RSELAB®®) OBITYP
DATACMYES)
ISELABYY, type *FILE created.

- I Prarmg

[ Properties 52 . Remote Scratchpad 5 Showin Table
=il £ Find String. ..

_Property | value Change...

Attribute TEST-USR SavelB)...

MNarne RSELABXX Restare. .,

Number of childre 23 ler Be

Source QsYs

Status Ok Create iSeries Project
| Properties(J)

QJUNKSRC.
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15 Remote Systems X 0 || # mstosp.sPF 52
=h‘-'\(:| ;.,_.||:]<_}==|;;‘V Line 1 .
B- E’ﬁs{lﬂa ;I I-“+i,
= ﬁ iSeries Objects A’;
E 1_. Work with libraries. .. '
E A7 work with objects... An
125 Work with members. .. s
Ea Library list a*
E_"'L User libraries A*
B --J‘-’ My source files A=
5 coMPARE. *file.pf-src A=
QCBLLESRC, *flle.pf-src n
"3 QCLSRC. *file.pf-src A
# QCMDSRC. *file.pf-src A
A
A
. A
#- [ QRPGLESRCP. "ﬁ GoTo - =
= .ﬁ. iSeries Commands (.“‘,.q" Fene
[+ 53 iSeries Jobs
T} IFS Files 1 /Rename...
£ Properties 53\ Remote Scratc =) CoPY
r |‘f=1' Paste
oe-o Movee
os | E—
Attribute PF-SRC I
Name QIUNKSRC | £} Show in Table [
Muimbar Af Ahildran 0

g. Click Delete on the pop-up menu.
The Delete Confirmation dialog opens.
h. Click Delete.

You have created a user action that copies a source file with data to a new source
file, specified user action parameters, specified restrictions on the user action and
tried the user action.

Lesson checkpoint

You learned the following:
* About user actions
* How to create a user action

Creating user actions for jobs

You can also create user actions for Jobs, which will appear in the User Actions
popup menu for jobs in the iSeries Jobs subsystem under a connection. The
substitution variables include variables for the selected job’s number, user and
name.

To create a job action:

1. In the Remote Systems view, expand your iSeries connection, if not already,
right-click iSeries Jobs, and select Work with > User actions.

You can also right-click on a file in one of your filters, and select User Actions
> Work With User Actions.
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= 0| # msTose.0sPF 2

& : N Line 1 Cy
L] EQ QUMDSRC. *file,pf-src :' ; I' SohAFL
- [5 QDDSSRC.*file,pf-src .| 0ooool A*%%
- By QIUNKSRC. *flle.pf-src pooooz A*
- 53 QRPGLESRC. *file. pf-src oooooz AFHEE
-5y QRPGLESRCP. *file.pf-sre ooooo4 A*
- -0 QsQLUCD. *fike.pf-src 000005 AF
& Be myfilterpool noonneag A*
S 3;' iSeries Commands oooooz7 A*
#H ams i5eties Jobs » D008 A*x**
- TF 1FS Files hew 009 A*%S
4 Qshells SR
| > 010 A
El EE s400aa SoTa r
= % %:ri:;'onglt 6 open in New Window
- p ia ilker
= :u::: s 5 Show in Table l
| x E{' MyLIE \ d 7. Filcer Pools
= —— 5 rare
T Properties 52 . Remate
“——— °T Select Filter Pools... I‘

Select New Job action.
Type the text to display in the Action name field. For example, ENDJOB.
This is a brief label for the action.

Type a longer, more descriptive text description for the action in the Comment
field. For example, End Job Immediately.

Type the actual workstation or iSeries command string to run when a user
selects this action. For example, ENDJOB JOB(&IJR/&IJU/&IJIN) OPTION(*IMMED).

This command can use action substitution variables when you run the action.
These variables are used when defining the command string to run for a
particular action. Substitution variables keep you from having to explicitly
code command parameter values.

Click Insert variable to view and select valid variables.
Here is your completed job action:
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# work with User Actions [ X |

Parent profile: lpleiad&c ;l
&2 New job action... Action name: | ENDIOE
Comment: IEm:I job immediately
Command: |M0rrnd command ﬂ

NDIOB JOB(RIIN/EIIU/EIIR) OPTION{*IMMED) d

‘ o

Insert variable... I Edit.., I Browse. ., I

[ Prompt First I Refresh after ¥ Show action
™ single selection only | Invoke once

create | Revertd) |

Close I

7. Click Create then Close.
Now let’s try this job action that you just created.

8. Make sure you have a 5250 session. Expand iSeries Jobs. Expand My active
jobs. Expand QINTER.

9. Right-click the 5250 job and then select User actions > ENDJOB from the
pop-up menu.

N ~ N =
’ ! # MSTDSP.DSPF 53 = O || 5= outline 23
£ o Sl M= s Line 1 Column| & B ms
) QCMDSRC *file.pf-src = | ST PR
- [5) QDDSSRC. *Flle. pf-ste 0oooo1 ATHITS i]
i[5 QIUNKSRC. *file. pf-sre oooooz A% BRY
&5 QRPGLESRC. *file. pf-src ooooos AERERLRS
-5 QRPELESRCP *file.pf-src 0oooo4 A*  THI
&[5 Q5QLUCD. *file.pf-src 000005 A% TIM
L Bo myfilkerpool gooooeé A*
If@ iSeries Commands 000007 A*
Bl ﬁiSeriesJOhs 0oooos AkrEAEA
= :‘i’." Elfiade*.s FiIFer Poal ooooooe A*LLREC
i g\ Active jobs 000010 A
[=]@" My active jobs -
i o | 3|
L B2 quswrk GoTe v
 E @Y My jobs ‘
= £ My Jo | , o Refresh Series Table ... | (Tt iseries Comm...
f=! Propetties 33‘.\‘-\ Remote SCfatChpadl =p g
E -#i HBH
i |5 Reledse
Property | Yalue Add To Job Status Wiew  ELESRC) FROMLIB(RSELABNY) OBITYP
Current user iden STECKHAM Display job log PATA(VES) o
Entered system  Sat Dec 30 09:23:00 EST 2 [Jypemps
Job bype Interactive
Narme QPADEVOODW Convert job log ¥ L work With User Actions...
Nurnber 023387 Debug As L& = e

10. Switch to a 5250 session to verify that the job has ended.
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Tip: Similar to user actions for objects and jobs, you can also create user

actions for IFS.
You have created a user job action.
Lesson checkpoint

You learned the following:
* About user job actions
* How to create a user job action

Customizing compile commands for iSeries Objects

In additional to user actions, there is specific support for creating compile
commands too. You use the Work with Compile Commands window from the
iSeries Objects subsystem under an iSeries connection to change IBM or vendor
supplied compile commands or your own compile commands.

To create your own command:

-
Team = O || # msTDsP.DSPF Ez\jmmou.m.ﬁ
e Y | = \=:="> ~ Line 1 Column 1 Replace
S N TS S SR
& =
= [ pRMST Sfle pfdta 4 A*33TS DD 19990303 233157 cOI
(- QBLLESRC. *fie.pf-src A* 89/04/10 16:28:41  SING
-5 QCLSRC. *fle.pf-src BT S T W W A S
#- 50 QCMDSRC. *file.pf-src A* THIS DISPLAY FILE PROVIDES Mi
#-[5 QDDSSRC. *fie.pf-src A* TIME REPORTING MASTER FILES -
&= L—'o QRPGLESRC. *file.pf-src e
fu‘u PAYROLL pdle A*
EERFAYROLLG.rpolg Ak WA AARANAARRNAARNNAARANAARANY
) QRPGLESRCP *fle. GoTo *Ec
- REFMST.lepfdt ooy 5
3 & RSNMST. *file.pfdt e N
ltL SAVFTST, *file.savf
“ B MYCOMPILE.%amd | [ Rename...
ry ihrari .
E ;i; iser ||brar|:: ‘= | Capy
" Source nies %
| gg;l o <1+ Move... Bo/03/02 12:07:25 DOUG
& iSeries Commands
ﬁ iSeries Jobs ¥ Delete... _I
[+ f-: IFS Files Web Services »
[ Qshells
=% Fmdstrng .
F] Properties 53 "\ Remote Saatchpad | |_—.}.|SerlesTable View 23 iSeries Comm
5)
[ Type | Attribute
_Property | value PF SRC
Attribute SRC ¥ [514 CRTBNDRPG...
Name PAYROLLG ) CRTRPGMOD
Mumber of children 0 o :
Source RSELABXX/QRPGLI Add To iSeries Project.. rk '\'-.h'.‘|'| Compile Commands...
Status oK Make Available Offiine 4
Text NehonfService Fatrv) P F 1T

1. In the Remote Systems view, expand RSELABXxx, expand QRPGLESRC and

right-click PAYROLLG.rpgle.

2. Click Compile (Prompt) > Work with Compile Commands in the pop-up

menu.

The Work with Compile Commands dialog opens.
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# work with Compile Commands | x|

Parent profile: Iple’lades ;I

Source type: |RPGLE _:] Md...l Remove

Compile Commands:

Mew command New complle command:
CRTENDRPG

CRTRPGMOD Lahel: Il

Command:

H
< o

Insert variable. .. J Edit. .. I Browse. ., I

Frompts..

Close |

Tip: You can also work with compile commands from the Compile option
(Compile > Work with Compile Commands).

3. New command is already selected for you in the list of commands.

Tip: To edit an existing command, first find it by selecting the member type it
applies to (or add a new member type if necessary) at the top of the Work
with Compile Commands dialog, and select the command in the list of
commands on the left. Edit the command and apply the changes. You can also
right-click on a command to delete it, copy and paste it or re-order it. You
cannot delete IBM-supplied commands, but after editing them, you can restore
them to their shipped value.

4. In the Label field, type CRTBNDRPG - no debug command.

5. In the Command field, type CRTBNDRPG command.

6. Click Prompt.
The Create Bound RPG Program (CRTBNDRPG) dialog opens.
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@ Create Bound RPG Program (CRTBNDRPG) B

Program: > | 8N ;] Name
Library: = |&0 3 Name
Source file: » | &F i Mame, QRPGLESRC
Library: = |8 = Mame
Source member; > | &N ﬂ Name
Source stream file: j
Generation severity level; 10 0-20
Text ‘description’ *SRCMERTXT x| Character value..,
Default activation group: "YES EI
Advanced Parameters
Compiler options: B
HEVENTF
P’
Debugging views: [: O] ]
Replace program: = | *YES

I Advanced(s) [ Al Parameters(s) | Keywords(7)
CRTBNDRPG PGM(80, &) SRCFILE(RL{&F) SRCMBR{EMN) OPTION(*EVENTF) DEGYIEW(*NONE) REPLACE(*YES) ;‘

| oK | Restore defauts cancel |

7. Change the Debugging Views option to *NONE.
8. Click OK.
The Work with Compile Commands displays.
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10.

11.

12.

13.

14.

# viork with Compile Commands | x|

Parent profile: Iple’lades
Source type: |rPGLE =] ad.. |
Compile Commands:
Mew command el conpg e commianes
CRTENDRPG
CRTRPGMOD Label; | CRTBNDRFG - nio debug
Command:

CRTBNDRPG PGM(&:0/&M) SRCFILE(&LJ&F) SRCMBR(AN) C « |

4 | _’JLI

Insert variable.. . I Edit... I Browse. ., I

Create I Revert I

Close I

Click Create to create this new command.
Click Close.
Right-click PAYROLLG.rpgle.

The new command is added to the list of available compile commands for
members of the type specified in this command. The checkmark appears
beside the last used compile command for the selected member’s type.

Click Compile > CRTBNDRPG - no debug on the pop-up menu and change
the program name to PAYROLLN.

The member is compiled and the program object is created.

Any errors produced by the compile are displayed in the Error List window,
where you can double-click to open the editor and position it at the error.

Right-click the program PAYROLLN and click Debug As > Batch. If you don’t
see the program in the list, click the Refresh icon in the Remote Systems view.

An error message displays indicating that PAYROLLN cannot be added to
debug since it does not have debug data.

DEGPOO04I Program PAYROLLM could not be added to debug since it does
nok have debug data.

Using predefined commands

For some of the frequently used commands, the Commands subsystem
provides you with a number of predefined command sets. You can use these
command sets or create new ones of your own. For example, to run the
ADDLIBLE command set:

a. In the Remote Systems view, expand the iSeries Commands subsystem.

b. Right-click Add library to library list and click Change.

152  Maintain an ILE RPG application using Remote System Explorer



C.

Tip: There is a Preferences dialog that has many preferences which effect

8|/ # mstosp.0sPF &
e ol [HE s = Line 1
B unix Unix, .,
Gy Al%... 000001
- BB Local... gooooz
Bl Local goopoz
=i s400a oooood
| B-@ iseries Objects 0onoons
= BY i5eries Commands ogooooe
| B 6o Pleiades Fiter Pool oopoonzy
= :='-' Your command(s)... ooooos
BB 2. ibrary bo lbrary list nAnAna
& ¢ Change current library Go Into
# £ Remove library from lib GoTo L4
) }'\ Create library
#-45% Create source file I Run{Prompt)
Bl P Create source member L8 open in New Window
| . 3] ;%- Create duplicate objec! Show in Table
« | g
2% Change...

[ = Properties SE.“'\-\LRemate Scratchpadl

| el TR

The Change Command Set window opens.

# Change Command Set E3
Mame: Add library to library list

Command pool: Pleiades Filter Pool

Commands:

@ Selected command:

Command:
| aopLiBLE =1 ﬂ

Browse. .. Promgt... |

¥ Prompt when run

Specify if the command should run in the Remote System server job, be submitted
’V('" Normal " Batch " Interactive ‘

ok | cancel |

From here you can now modify the existing command or create a new
one.

Click Cancel.

substitution variables for user actions and compile commands. Click Window

> Preferences and then expand Remote Systems, then expand iSeries and

select Command Execution
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0 preferences

I type filter text

#

&
®

Java _A_l

Jython
Logging

|- LPEX Editor

Model Validation
Maodeling
Package Maming Preference:

Command Execution

~ Preferences for compiles and user action variables

[¥ Replace object |&R var

I~ Compile in batch I&P—I
var

Object [ibrary: |"‘5R-C'-IB . &0 var| 5

=1l

E ;:":—:;r Geveonment Preferences for batch compiles, commands, and user action variable
| orocms Job descripton lbrary:
[# Profiling and Logaing Job descrioti *
: scription: USRPRF | -
[=l- Remote Systems i ] &G var —I
. Communications SEMIOB additional parameters: |
- E‘Iebd'-clg L [ Add batch compiles ko the iSeries Job Status view &ISJ var
le Cache
Files I Add batch commands to the iSeries Job Status view
[=I- iSeries
~ Cache .
I _ommand Exacution Prefarences only for compils commands
- Commands Subsyste Compile member types in this order:
] Files Subsystem FF -~
Jobs Subsystem LF Move Lp I
- Objects Subsystem DSPF
[+ Program Yetifiers ?gFT,’:
Table Yiew RPGLE I
Logaing CLLE :j
Passwords
[+ Remote Systems LPEX Et
g;rleen Designer (Techni|  —prafarences only for user action varisbles
™ Runin batch
: Requirement Management |t el &E var
[= Run/Debug
: Compiled Debug
- Congole
DBZ Stored Procedure D
Debug Daemon
External Tools
3 iSeties Debug =
( (AW ENENEL Y| '""rw" -v“ﬂ-—l Restore Defaults | Apply |
7 ok I Cancel I

You have created a new CRTBNDRPG command and looked at predefined
command sets.

Lesson checkpoint

You learned the following:
» About predefined command sets
* How to create a new command

Using Run configurations

Run configurations are for powerful re-use. If you want to run a program that
takes a number of parameters, or is not straightforward to launch, you can

predefine this information into a named configuration. Once created, the

configuration appears in the configuration list, and can be selected from there.

Every configuration defined can be accessed from the pull down menu of the Run

tool bar button through the Run option. Clicking the Run tool bar button will run
the previous configuration again.
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To change an existing run configuration:
1. Right-click CLR1 then Run (Prompt)

> Interactive on the pop-up menu.

=y RE’!amE.n
Remote Systems X Tez = Eﬁ\\f PAYROLL.RPGLE
4 o | T ) Cepy Column 1 Replace
i I Paste =
B3 Work with obs S L NS~ SIPIN .
=l S
- A*33TS DD 19990303 233!
t]-240 Work with memk o b oleta. . A* 89/04/10 16:28:41
[=l-g& Library list 3 4 e e e o ok o e ko o e Y
F-E QSYS.Sb.pr Update... A% THIS DISPLAY FILE BROY
E-m, QSYS2.%ibr  Change... A* TIME REPORTING MASTER
Bk QHLPSYS. S save... A
[+ B, QUSRSYS. ™ "
4 Q Restore... A
!‘,\NFLAB}:X.‘I User Acti » I8 v e ol vl vl ok ol ol ol ke ol o e e e ok e e e ol o e o Y
[#--ml WSSLABXX.* A*E3EC
(- Bl WFLABXXXX a
(B, WFLABXX. ™ d %08 iSeries application in RSE Job...
[+}--E), ORDLIB. *lib Debug(Service Entry) ¥ % Batch...
[+}-E&\ WRKSPLFRP  Debug As(F) 3
[+]-El WFLABXXX."  Debug (Prompt)(K) r -
= B R K, :
EIE‘ CLBATCIgEmHnwﬁme A e/ US/Us 1TUTUZ0
#-[H et ) A
3 Properties(.
- < T
The Run configurations window opens.
# My iSeries program for run ]
Modify attributes and launch. ;E
MName: I My iSeries program For run
(PPRTET ! Common|
Connection: |s400a = mew.., |
Command to start application:
CALL PGM{RSELABX/CLRL) |
=
Prompt. |
Apply I Revert ]
7 Run I Close I

My iSeries program for run is the default name assigned to a configuration

created on the fly when you select Ru

n from the pop-up menu of a program.

To save a configuration for later use, you would change this default name.
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2. Change the name of the configuration to CLR1Run.

3. Click Prompt.

The Call Program (CALL) window opens.

# call Program (CALL) E3
Program: > |cLri hiame

Library: > IRSELA.BKK _:J MName
Parameters: I gt

I advanced [ 2l Parameters [ Keywords

CALL PGM(RSELABXX/CLR 1) PARM{.K)

=

OK

| Restore defauts |

Cancel I

4. In the Parameters field, type 'XX', where XX is your workstation number.

5. Click OK.

The complete start command for the program appears.

# My iSeries program for run

Modify attributes and launch.

MName: I My iSeries program For run

(PTRPETT,. ! Common

Connection: |s400a

Command to start application:
CALL PGM{RSELABK/CLR) PARM{"EX) _:I
Prompt... |
Apply | Revert I

(=)

Run I Close

6. Click Run.
The program runs.

If not, you may see this error message.
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# EVFC50011 [ x]

3 | Mo interactive job associated with this connection. Associate an interactive

- job with this connection o continue,
Cancel I << Details l

& request to run an interactive command or program was received for the RSE ﬂ

connection s400a, but no interactive job is currently associated with this
connection, To associate an interactive job with this connection:
1, Open a 5250 emulatat,
2. Run the CL command STRRSESYR MAME(s400a) |

The interactive connection has been shut down in the meantime. Go to your
5250 emulator and restart the interactive connection following the instructions
in the message. You don’t have to cancel the message. It will be removed as
soon as the connection between the interactive connection and the interactive
session has been established.

The program runs and waits for input from the 5250-emulation session.

o1 sessona-[zaxon R -lojx]

File Edit ‘Yiew Communication Actions ‘Window Help

) ] B || ] (%] & 5] @O

41902 - Session successfully started

Press F3 to end the program.

Tip: You can edit, delete and create run configurations by clicking the arrow
beside the Run icon on the workbench toolbar and selecting Run from the list.

& Remote System Explorer - MSTDSP.DSPF - 16M Websphere Development Studio Client Advanced Edition fd

File Edit Source Compile{G) MNavigate Search Project Data Run  Window Help

| w | 30 ) - | 5

| \ v b= T B 1 My iSeries program For run
= O| # ms1osr.0sPF 22 punae »
= AT Line 1
al B . oroenize Favorites..,

You can also click Run on the workbench menu and select Run.
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# Remote System Explorer - MSTDSP.DSPF - IBM Websphere Development Studio Client Advanced Edition for

Flle Edit Source Compile(G) Navigate Search Project Data | Rum Window Help

B | |

)
)
4
]

B QSYS Mib.prod-sys
B Q5YS2.*lb.prod-sys
B QHLPSYS. *lib.prod-sys
B, QUSRSYS. ™Mb, prod-sys
B, RSELABYK. *lib. best-usr
# [ CLEATCH. *pam.cle
B act *|:g11 clle
F- [ [ f

:'+1 -

0-#-H

e lEJ PAYROLL. *parn. rpg!

4 |

E..' =
EEE = ﬁ iSeries Ob]ects
i) 1 fo Pleiades Filter Pool
E &3] A_. Waork with libraries. ..
.B @ A7 work with objects. ..
- & A7 Work with members. ..
) m¢ Library list

E Ed mycompILE *pgm clle

. EPResume
P ysp BTE
i 3.Step Into
L e oy
0ot _PStep Retumn
0o -IL R tolne
| pOf  .UseStepFikers Shift-+F5
000 @, Run Last Launched Ctrh+FLL
g g E . Debug Last Launched Fi1
oot Run Histary 3
= oot Run s
. 00 t
{ oot Debug History 3
LI_. Debug As »
Debug...
[ i~/ Launch the YWeb Setvices Explorer
lﬂ’s (3, External Tooks »

The Run Launch Configurations window opens.
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& Run E3

Create, manage, and run configurations ;E

B TN e,
(5 %55 Name: [ CLRIRun

I type filter text - —
: (How To start N
e Equinox 05GIF 4]
[ Generic server Connection: |s400a | mew... |
: Ei BEneric Server
BB Host cic++ A
i a_J. Host Java App

BB iseries: Run Af Command to start application:

b Ek iSeries: Run Bz CALL PGM{RSELABX:/CLRL) PARM("¥x"D _:J
:J & iSeries; Run In

¢ B clRiRun

fi‘ iSeries: Run M
-] 1ava dpplet
[ Java Applicatic
EJ Java Applicatic
{15 Java Bean
- JET Transform
o Ju it =l
~JU JUnit Plug-in T
- [l sw Applicatic Prompt... |
E Test
o WebSphere Ac
rﬁ ‘WebSphere vE
- (&% websphere v
1@ ‘webSphere vE
[ ¥sL Transform | |

3 | | Ll— Aoy
) Run I Close I

Revert |

Here you can see the CLR1Run configuration that you just created. This is your
saved configuration to run CLR1 as an interactive application. Notice the list of
configurations you can choose.

You have created and saved a run configuration.
Lesson checkpoint

You learned the following:
* About run configurations
* How to create a run configuration

Module summary

In this module, you learned how to work with some of the many features of the
Remote System Explorer perspective.

Lessons learned

* Know the features of Remote System Explorer

* Move, dock, rearrange, resize, hide, close, reopen and add views
* Save and reset a customized perspective
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Create a filter to show specific iSeries libraries
Change the filter to add more iSeries libraries

Create a filter to show all the source files in a library
Access members to edit from your filter

Create a user action that copies a source file with data to a new source file in the
same library

Specify user action parameters
Specify a restriction on a user action
Try the user action

Create a user action for iSeries jobs
Create your own compile command
Using run configurations

Assessment

What is the Remote System Explorer?

What filters list a set of libraries?

What is the purpose of a filter?

Can you create filters for all connections or a specific connection?
Can you give filters a specific name for future use?

What filters list a set of objects?

What is the purpose of a filter pool?

Can you define filters for non iSeries servers and your local system?
What is the purpose of a user action?

Can you specify a restriction on a user action?

Designing screens and reports

This module teaches you about the various aspects of the CODE Designer while
modifying a display file to add a screen and creating a simple printer file. You will
step through each part of the CODE Designer tool interface and update some DDS
as well. In the workbench, in the Remote System Explorer perspective you will use
the connection that you used in the module before.

Learning objectives

Open a DDS member for edit with CODE Designer

Show file-level keywords and record keywords

View the details of records, record-level keywords and field-level keywords
View the design of the payroll application main menu

Create a group from an existing record format

Create a new group and add a subfile record and a subfile control record
Add columns to the subfile record

Add fields to the subfile control record

Copy existing fields

Set indicators to handle field errors

View and update record and field properties

View keywords and the properties of a keyword

Insert a keyword
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* View help for a keyword

* Check there are no semantic errors in the DDS source
* View help for an error

* Launch the editor in read mode from the error list

* Launch the editor in write mode to fix the error

* Find a keyword in the source

» Save source changes

» Compile your source changes

* Create a printer file report

* Close the Designer

Time required

This module should take approximately 30 minutes to complete.

Opening a DDS member in the Remote Systems view

Using an editor to create and maintain DDS source for your display, printer and
physical files can be a frustrating and difficult task. What would be great is a
graphical design tool that let’s you design your screens and reports visually and
then generate the DDS source for you. Well, that’s exactly what CODE Designer
does for you.

CODE Designer helps the novice DDS programmer create screens, reports and
databases quickly and easily without worrying about the details of the DDS
language, while at the same time letting the expert DDS programmer get access to
all the features and power of the language.

Tip: Make sure MSTDSP is closed from the previous LPEX Editor lessons.

To open a DDS file member from the Remote Systems view:
1. Expand the Library list filter if it is not already expanded.
2. Expand the QDDSSRC file in library RSELABXX.

rstems. Team = O)[ £ msTose.oser N = lfl-] (95 outine 5% N =
£ & | 2l BIS T Line 1 Column|| ® E& msTosP.DsPF
| @ [ pavROLLN, *pgm.rpoleal || B..orar.1. 8
&[5 COMPARE. *file.pf-src & oooool A*%3TS ﬂ
- B [ EMPMST. ¥fle.pf-dta opoooz A* 83/
- @[5 EVFEVENT *file. pf-dtz 000003 AR ExxL
| @8] MSTDSP. *file. dspf 000004 A* THI
- -6 MSTDSP2, #File, dspf 000o0ns A* TIM,
- @[5 PRIMST ke pf-cka 000006 A*
. B [0 QUBLLESRC *file.pf-s1 ooono7 A*
| - QCLSRC, *ile. pf-src onoonos AkFkEES
B L_n QCMDSRC, *file . pf-src oonooe *LEREC
' =[5 QDDSSRC. *File.pf-stc 000010 A
- Oy EMPMST pf = 2
8Y sTDSP. depf 5 L
€ PRIMST.pf il |
O REFMST of Open Wit ld 7 Remote Systems LPEX Editor
|| O RsNmsT.pf Browss With » (ol CODE Editor
< | £ Rerane 15 CODE Designer
| Properties 52N _ Remote Scratchpad | 1= Copy %) Screen Designer (Technical Preview anly)
ro;;_ 2 s Move... '
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3. Right-click the MSTDSP member.
4. Click Open with > CODE Designer on the pop-up menu.

The member MSTDSP will be downloaded to the workstation and loaded into
CODE Designer. CODE Designer is a separate tool not integrated into the
workbench.

You have opened the DDS source member MSTDSP in the Remote Systems view
using CODE Designer.

Lesson checkpoint

You learned the following:
* About CODE Designer
* How to open a source member in CODE Designer

Viewing the DDS tree

What you are looking at now is basically an Explorer view of the DDS. The DDS
tree view on the left-hand side of the Designer displays the DDS source in its file,
record, field, and keyword hierarchy. It is a familiar and intuitive way to see the
overall structure of the DDS source and to navigate through it quickly. Don’t worry
if you're not a DDS expert, everything will be explained to you.

The DDS tree shows groups of records, which represent the screens or reports you
are designing, as peers of the file in the tree hierarchy.

In this view, you can create groups, and copy or move keys, keywords, fields, and
records. If any DDS object contains an error, the icon representing it displays a red
X.

To show file-level keywords and the record SELECT in the DDS tree:
1. Expand the <Servername>RSELABxx/QDDSSRC(MSTDSP) folder.
Expand the File Keywords folder.

Expand the SELECT record.

Expand the Record Keywords folder.

Expand the EMESS field.

o~ DN
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U JELAE,

[=1-fom File Keywards

e PRINT
T TNDARA
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G CADY
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i -G BLINK
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. @A TimeR...System’

- @@ roatE

. #- A 'Mainte,, ection’

(B rTvE

- #-A Enter ...intain'

. [ EMPAPL
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L[ PRIAPL

- ®B-A Projec...enance’

[ RSMAPL

- A 'Reason...enance’

B EMESS

i -...Ga¢ DSPATR

. @A F3-End of Job'

4% EMPSEL

-4 EMPMNT

G143 PRISEL

43 PRIMNT

#1484 RSNSEL

(-4 RSNMNT

-3 maTN_MENU

The DDS tree now shows you a summary of the file-level keywords and of the
record SELECT.

You have seen the file-level keywords and the record SELECT in the DDS tree.
Lesson checkpoint

You learned the following:
* About file-level keywords
* How to view file-level keywords

Selecting the DDS object

In the upper right-hand side of the Designer is the Workbook with several different
tabbed pages. The Workbook is the area of the CODE Designer where you design
display files, printer or physical files. You can view this notebook on the top
right-hand side of the CODE Designer window. The top page is called Details and
it provides a detailed view of the DDS objects selected by the DDS tree. You can
view this page in either details mode or list mode by clicking View > List from the
CODE Designer menu.

In the Details page columns display information about the selected DDS object.
You can use this page to display for example, details of all the fields in the record
SELECT or keywords and conditions of a field or record.

The Listing page is a listing of the source statements generated by the Program
Verifier.
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In the bottom right-hand side of the Designer is the Utility notebook. This
notebook contains several pages: Selected DDS, Web Settings, Comments and Error
List. The Selected DDS page in the notebook shows the actual DDS source for the
currently selected item.

Tip: The Web Settings page allows you to specify attributes that are used by the
WebFacing tool.

To work with the DDS record SELECT:

1.

2.

In the DDS tree click the SELECT record.

The Details page lists all the fields in the record SELECT and summarizes some
of their properties. The Selected DDS page shows the DDS for the SELECT

record.

Detalls | MaIN_MENU | Source | Listing|

Record SELECT fields
Field | Positi. | Len.. | Type | Shit | Usa... | Sample -~
A PRGO 25 5 Test const... PRGO
A Time R.. Spster 2,30 21 Text const., Time Reporting Syste
@y oate 2,70 B Date const... MMADDAYY
A Mainte, ection’ 330 21 Text const.. Maintenance Selectic
@ TIME 370 6 Time const... HH:MM:55
A Enter .intair 6,14 54 Text const... Enter an X besidz the
I EMPAPL 8.25 1 Alphanumenc & - Alphanum.. Both B
A Employ.. enance’ 9,28 27 Text const.. Employee Master Mai
I PRJAPL 10,25 1 Alphanumeric A -Alphanum.. Both B
A Frojec._enance' 10,28 26 Text const., Project Master Mainte
11,25 1 Both B b
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In the DDS tree click Record keywords immediately below SELECT.
The Details page shows the current record-level keywords. The Selected DDS

page still shows the DDS for the SELECT record.

Detalls | MaIN_MENU | Source | Listing|
Record SELECT keywords

Kewword | Conditioni... | |
e BLINK
SwALARM B0

Selected DDS |Cleale kepwords | Wieb Seltings | Comments | Error st |

o]

89-03-02 12:07:25 DouG REL- =

THE SELECT FORMAT ALLOWS SELECTION OF

MASTER FILE THE OPERATOR WANTS TO MAIl
R SELECT

A
h*®
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BL]
ALZ
2 5'FF

2 30'Tig
.'_I_I

60

i1 1 [ (D I

4| |

In the DDS tree click the EMESS field.

The Details page shows its field-level keywords. The Selected DDS page now

shows the DDS for the EMESS field.
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Selected DDS | Creale keywords | Web Settings | Comments | Ermor list |
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Even this relatively small and simple DDS source member demonstrates how
much easier it is to use the Designer to navigate through your DDS source. The
syntax is being interpreted in intuitive graphical ways making it an ideal tool
for learning DDS. But to get orders of magnitude improvement in your
productivity what you really need is to work with your screens and reports in
a WYSIWYG fashion, completely independent of the DDS required to make
things appear the way they do. You need the Design page.

You have seen the details of the record SELECT, the record-level keywords and the
field-level keywords.

Lesson checkpoint

You learned the following:
» About viewing the details of a record
* How to view the details of a record

Designing the DDS screen

You will spend most of your time creating, updating, and designing your DDS
screens and reports in the Design page. The Design pages allow you to design
your screens or reports visually using an intuitive graphical user interface. The
Design page shows the DDS source as it would appear on either a screen (for
display files) or a printed page (for printer files). It allows you to design your
application’s screens or reports by laying out records and fields in a graphical user
interface.

On the Design page, you can easily create, edit, resize, and move DDS objects
graphically. You can create new records, fields, and constants directly on the
Design page by using the palette push buttons to the left of the Design area or
from the pop-up menus. The toolbar above the Design area allows quick access to
many of the editing features as well as information about the currently selected
object.

Click the MAIN-MENU tab in the workbook.
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Details @NN_MENQ, Source | Listing |
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In order to understand where MAIN_MENU came from, you need to understand
the concept of a group. A group is simply a collection of one or more DDS records
that represent how a screen or report would be assembled at runtime. It allows
you at development time to work with screens or reports as they would appear
when they get assembled by your programs at runtime. To work with groups in
CODE Designer you need to tell CODE Designer which record formats make up a
screen. In this case this has been done for the screen you see in the Design page. A
group MAIN_MENU has been created for you and CODE Designer has saved this
information in the DDS source in comment lines. Any groups that you create are
persisted as comment lines in the DDS so you can re-use these groups in
subsequent CODE Designer sessions.

The groups you create will appear in the tree view as well as in the workbook as a
Design page tab for each group defined, to allow quick access to each group of
records.

You have seen the concept of a group, specifically the MAIN_MENU group.
Lesson checkpoint

You learned the following:
* About groups
* How to see a group in CODE Designer

Creating groups from existing records

If you are working with existing DDS, you will want to create groups that will
correspond to how the records are being used. In this example you will create a
group for the next screen, where the user selects which employee in the payroll
database to maintain. The screen is made up of the record format EMPSEL.

To create a new group:
1. Scroll to the bottom of the DDS tree and expand the MAIN_MENU group.
The SELECT record appears as the only record in this group.

2B MAIN_MENU

= @ EEE

2. Right-click the MAIN-MENU group.
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3. Click Insert group on the pop-up menu.

A Group Properties notebook opens and a blank Design page for the group
SCREENL1 also opens.

Detai | an_meu-

| Listing |

(]

i e 1 i

The Properties notebook lets you view and update the properties of the
currently selected DDS object. You can open this notebook from any view,
pop-up menu, or menu of the CODE Designer. The Properties notebook is
modeless. When you change an object’s properties, the selected object changes
immediately.

4. In the Group Properties notebook, select the EMPSEL record from the Available
list and click the >_>| button.

For simplicity this is the only record you will add for now. The Design page
now shows you what the record EMPSEL looks like.

[ [femeseL EERD
Igmm all indkcalors

5. In the group field, type EMPL_SELCT over SCREEN1 to rename the group.
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6. Close the Group Properties notebook. Click the X in the top right corner of the
Group Properties notebook.

You have finished creating a group. You could now work in the Design page
with the record formats contained in this group. Instead you’ll create a new
record format.

It appears that this is one of those unusable applications where you have to
know the employee number ahead of time instead of being able to browse
what is in the database. What we really need is a subfile. But aren’t those
difficult to code, you ask? Not with CODE Designer.

You have inserted a new group using the existing record EMPSEL.
Lesson checkpoint

You learned the following:
* About inserting groups
* How to insert a new group

Creating new screens

To create a new record screen on the Design page you need to create a group that
will create an empty page you can work with.

To create a new group:
1. Right-click the new EMPL_SELCT group in the DDS tree.
2. Click Insert group on the pop-up menu.

A Group Properties notebook appears and a blank Design page for the group
SCREENL1 also appears.
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3. Rename the group to EMPL_LIST and close the Group Properties notebook.

4. You can create things on the Design page by selecting the appropriate tool from
the palette on the left-hand side and then click on the Design page where you
want it to be created. Right now, most things are disabled in the palette
because there is no record in which to create fields. The only two buttons
available are Create standard record and Create subfile record. If you leave
the mouse over a button for a second or two, flyover help will appear
describing the indicated button.

&

344 lanore all indicatars

5. Click the Create subfile record button and then click in the dark gray area.
A subfile and a subfile control record pair are created.
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You have created a new record screen.
Lesson checkpoint

You learned the following:
e About new screen records
* How to create a new screen record

Adding fields to the subfile record

Now you add some columns to the subfile using the Design page. The subfile
should be positioned on row eight. You use the cursor to specify the location of the
part you want to put on the screen, in this case your subfile.

To add fields on the subfile:

1. Click the Create named field button & and then click somewhere on row 8.

Six fields appear in a vertical column. This is because the subfile you created,
currently specified a SFLPAGE (visible list size) of six.

2. Click the top field and hold the mouse button down and move it to row 8,
column 5.

Note the current row and column appear just above the field as you move it.

3. Move the cursor over to the right edge of the field. It turns into a
double-headed arrow. Hold down the mouse button and move it to the left.
The size of the field will be reduced. The current size will appear just above the
field. When the size is 3, let go of the mouse button.
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The toolbar at the top of the Design page is a very convenient place to monitor
and manipulate the currently selected parts.

Rename the record from RECORD1 to EMPLSTSFL and the field from FIELD1 to
OPCODE by typing over the text in each list.

g EMPLSTSFL 9 = ]

| %l lgnare all indicators -

Click the Color palette BRI button and select pink to change the color of the
field.

Click the || button to change the usage of the field to input.

m

Now you will create an additional column in the subfile.
To create an additional output column:
a. Position the cursor at row 8, column 9.

Tip: The bottom right of the CODE Designer window shows the current

cursor positionl 8307 .

If you can’t see the field with the cursor position on your screen, click the
Maximize button in the top right corner of the screen. You can use the
cursor keys or the mouse to move the cursor.

b. If you are creating a long field with an exact length, the SDA syntax can be
easier. Type: +0(30) and then press the back arrow (not Backspace!) to
select the text you created.

Notice from the Selected DDS page that you have created a text constant
containing +0(30).

c. Click the Convert string to field® button on the toolbar or press F11 to
convert the SDA syntax into a character output field of length 30.

JEMPLSTSFL j|<§|4|r

Ilgnue all indicators

El

d. Rename the new field to ENAME using the toolbar. This will show the name
of the employee.
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e. Position the cursor to 8, 41.

f. Now you will add a field for the employee’s salary. Type $666,666.66 and
then press the back arrow.

Now wouldn’t it be better if we could just tell the Designer what we wanted
the number to look like and then have Designer generate all the cryptic
EDTCDEs to make it happen?

g. Press F11 to convert this field into an output numeric field with comma
delimiters, two decimal positions, a currency symbol and no sign. Look at
the Selected DDS page to see what was generated for you. Impressive!

Detais | MAIN_MENU | EMPL_SELCT EMP

= EEEE e =R L

%l lgrore all indicators

guice I Listing |

F elecleaDD | ‘Web Settings.] Eurrments.l Ermor Iisl]

| EA SALARY 8Y 20 8 41EDTCDE(1 SE S

h. Rename the field to SALARY and change its color to yellow, using the
toolbar.

i. The subfile seems compacted to the left. It would be better to space it out

evenly. Just select a field and click the space horizontally 1 putton on the
far right side of the toolbar. The other alignment buttons will align fields,
left, right, center and top.

15 EESE . = B == s B (z]ol8]
’legnmeallhdﬂcalols :! EBE 2 E ' L
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Just below the palette on the left there are three spin buttons. The top one,
Subfile size, specifies the total number of entries in the list that will be filled
in by the application. The second one, Subfile page size, is how many
entries appear on the screen.

j- In the Subfile size field, type 300.
k. In the Subfile page size field, type 9.
I. Click in the Design page.

Detais | MAIN_MENLU | EMPL_SELCT EMPL_LIST |Sourte| Listing |
[EEevrests [ <]=]]
l'_7°l Ignore all indicators L

=B

|

The Design page is updated accordingly.
You have added some columns to the new subfile record screen.
Lesson checkpoint

You learned the following:
* About adding fields to a subfile record
* How to add fields to a subfile record

Switching between multiple records

Now let’s fix up the subfile control record. The group you created contains 2
records. You can verify this by looking at the record list in the toolbar:

EMPLSTSFL

RECORDICTL
1. Change the current record by selecting RECORDI1CTL from the record list or

click next record ®| or press Alt+End.

The fields in the subfile still appear so that column heading can be lined up,
but they appear at half-intensity so that they can be distinguished from the
fields of the current record.
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2. Rename the record to EMPLSTCTL using the toolbar. Let’s provide a 'Position to’

entry in the subfile control header.

3. Position the cursor at 4, 9 and type: Position to:

Detals | Ml EMP_SELCT EMPL_LIST | Source | Listing |

& evrLsTCTL ) <[ <] =] Szl
] el

L4 lanore al indcators

-

Now you need an employee name field.

You could create a named field with the right characteristics like you did in the
subfile, or you could create a source reference using the Create source reference

field 2| button in the palette, or you could reference the original database field
using either the Create database reference field button or the & Create

database reference field(s) by selection &3 button. But there is an even simpler
way. Use copy and paste!

4. To copy the employee name field:

a. In the DDS tree expand the EMPMNT record.
b. Click the ENAME field and press Ctrl+C.
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(The pop-up menu or Edit menu shows the Copy menu item as well).
c. Position the cursor to 4, 23 and press Ctrl+V. Now that was easy!
d. Click the field and change the name from ENAME to POS_TO.
Details | MAIN_MENU | EMP_SELCT EMPL_UST | Scurce | Listing |

@[gmmsm!_ ~|[E[ <] Fos_T0 ) ~[=
’zllgnomalmdlcdms | D)

You have fixed up the subfile records to add an employee name field with a
position to entry opposite this field.

Lesson checkpoint

You learned the following:
* How to fix up the subfile records to add an employee name field
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Adding field error handling

Let’s put in some error handling for the ’position to employee name’ field. If the
employee name is not found in the database, the program will set on indicator 60.

In this case the field should turn red, reverse image and position the cursor to it.
Now wouldn’t it be better if you had something easier to remember than some
arbitrary number from 1 to 99.

To set indicators:

1. Click the Change named indicator sets #| button on the Design page toolbar
(or press F7.)
The Named indicator sets window opens.

2. In the Settings name field, type: Not Found.

3. Click Create.

x|
Indicators
70 20T amE Aa T s 60T 70T 80 I 80
I= 01 iE 2= LB 4 e G E 61 TS LTI 81 a1
IF 6200 207 225 32 427 6200 62 72 82 T 182
D AT A3 23 33 A 53 62T 73 e a3
I O LA 24T 34T 44T s T B4 T 74T 84 T Ead
mhieEl L e El s ] e e e ]
e e s e e s e e e
mliers mlii @b mhar i mises @it mlined sl miEsr
[T BT 16 28 38 C 48[ G876 78 [T BaiT &8
[Coaf 19 29 38 48 64 63 731 eaf ad
Checked indicators are: & 0 & [
Settings mmé INot Found Create |
lgnore all indicators
i s are off
Delete
foply | Cancel | _Help |

4. Select the check box next to 60 and click OK.

The Not found indicator set is now in effect. The Design area is shown as if
indicator 60 was on and all other indicators were off. The Design page toolbar
shows the current indicator set in the Select named indicator set list on the
bottom left.

‘,_gEMPLSTCTL :]|E‘—;‘;'|q|p||ms_ﬂ3 RE
7 (I E— 7. T
5. Now select the POS_TO field.

6. On the toolbar, select the color red and the display attributes reverse image
and position cursor. (The set of toolbar buttons representing the current
display attributes is found just below the Color button).

The toolbar should look as follows:

BT =5 E EeE [
< AEE - E e T e

7. Examine the DDS generated in the Selected DDS page.
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Selected DDS |Web Settings | Comments | Erorlist |

A POS_TO R B 4 23
A 60 COLOR(RED)
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& B0 DSPATR(RI)
A 60 DSPATR(PC)
L4

Notice that all the new keywords were created with a condition of 60. (The
DSPATR(PR) was pasted with the field originally).

8. Now let’s try it out! From the Select named indicator sets list, select All
indicators are off.

9. From the Select named indicator sets list, select Not found.
The field appears red and reverse imaged.

You have added error handling to the position to employee name field.
Lesson checkpoint

You learned the following:
* How to add error handling

Accessing field properties

Second to the direct manipulation and the toolbar on the Design page, the easiest
and quickest ways of getting access to the properties of a field, record, or entire file
is the Properties notebook.
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The Properties notebook lets you view and update the properties of the currently
selected DDS object. You can open this notebook from any view, pop-up menu, or
menu of the CODE Designer.

The Properties notebook is modeless. When you change an object’s properties, the
selected object changes immediately.

You can get to a Properties notebook from the Selected menu, by pressing F4, or
double-click on anything in the DDS tree or the Details page or Design page.

To open the Properties notebook:

1. In the DDS tree, click the record SELECT and press F4 to see the Record
properties.

21

|*€ Record properties

{Basics | ca/cF | Styles |
Recard [SELECT
Type |Standard

Modified |EB?291'92
Number of fields [T4 ™ Ina window

Description |

As you select different items, the Properties notebook will continuously update
itself to show you the properties of the selected item.

2. Click the *DATE field in the SELECT record. (You may have to move the
Properties notebook out of the way.) This field has a different set of pages
describing its properties.

. 2 o File Keywords

: & PRINT
G INDARA
e CAO3

i o CADY

| o SELECT

: =] fo Record Keyword:
O BLINK

O ALARM

A PREOL
#-A 'Time R...System
=@
#-A 'Mairte, .ection’
R *TIME

3. Change the year from 2 to 4 digits. Select the Length of year check box.
4. Select 4 digits from the list.
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g Field properties

Basics | rs‘-\.ttri:utesl Color | Ediling| 1ndicatul§|

[™ Source of date
v Length of year |EHal

Sample
|MMJDDNYYY

 Position
Size Row  Column

2axg0 [ 254 [ 70
ot R | B

Description |

l

Notice how the sample is updated on the Properties notebook.
5. To test the Design page, click the MAIN_MENU tab in the workbook and look
at the upper right corner of the screen. The year now has 4 digits.

6. Click the EMPAPL field in the SELECT record. On the Field properties
notebook click the Basics tab. On this page you can change the field’s name,
usage, length, type, and screen position. The other pages give you quick access

to other properties of this field.

2]
iE xl Altrbutas] Calor ] Indcalars] Slylas]
Field
|EMPARPL | i o
Uzage Shift
ZlolB[ulPImM] [4-Achanmeic £
Length - Position
Total Dec Size  Row  Column
[ B 5 || 2eso [ SH[ 26
[~ Continued [CNTFLD] 271 :;;-I_ZE I_-E

\whidth

Description |

I

You have seen the record properties for the record SELECT and changed the length

of year to 4 digits.
Lesson checkpoint

You learned the following:

* About the record properties for the record SELECT
* How to change the length of year to 4 digits

Adding new keywords

CODE Designer helps you manage the visual aspects of your displays and reports.
But you also need to access the full power of DDS. You need to access keywords.

To add keywords:
1. Click the EMPAPL field in the DDS tree.
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2. Press F5 or right-click and click Insert keywords on the pop-up menu.

5 @) <ROS400A>RSELABXX/QDDSSRC(MSTDSP o || Details | Me
e A ==
GGt seiec

- [ o= Record Keywords Keyword
#-A 'PRGOL
- A 'Time R...System'
- [ *DaTE
#-A 'Mainte...ection'
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# A Projed
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5 A Reaso Uk Ctrlx
#- EMESS Copy Chrl+C

You see the Details page for the EMPAPL field and the Create keywords tab is
added to the Utility notebook. This page shows you the subset of keywords
that are allowed for the selected file, record or field and it takes into account
the field’s type, usage, shift and what record it is in. It is very powerful to
know exactly what your options are. This information cannot be quickly
ascertained from the Reference manual.

Selected DS Create keywords | web Setiings | Comments | Erorlist |

Insaﬂl Subset IAI _:I
(S ALIAS S« CHECK(M11)  S=CHRID SwFLDCSRPRG  Sw'WRDWRAP
(S~ BLAMNKS S CHECK(M10F) @CULU%» S |GCALTTYVP S LINKMNOWN>
(O CHANGE S« CHECK(M11F) S COMP S INDTKT 32>
o~ CHECK (28] &~ CHECK(RE) S DFT SwMSGID>> >
[ CHECK[ER) S CHECK(RL) S DFTWAL SwMNOCCSID
> CHECK[FE) S CHECK[RZ) @ DSPATR»>> S« OVRATR
[T CHECK(LC) S CHECKVM) S« DUP S« OVRDTA

[e~ CHECKME) SwCHECK(VNE)  S~ENTFLDATR  S~PUTRETAIN
1o~ CHECK[MF) S CHGINPDFT S=ERAMSGy»> S RANGE
Sw CHECK([M10) S« CHKMSGID S ERRMSGID>»>>  SwiALLIES

1| | [12
3. With the EMPAPL Properties notebook at the Basics page, click the numeric
field E button to change the field to numeric type.

ield properties _?_l_}_(_]
{Basies™| attibutes | Color | Indicators | Styles |
Field :
[EMPAPL |
Shift 3
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Notice that the list of keywords in the Create keywords page has changed.

4. Click the éd button to change the field back to alphanumeric.
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Notice that the list of keywords in the Create keywords page has changed
again.

5. Click the ALIAS keyword and press F1.
The DDS Reference help for the ALIAS keyword appears.

Tip: CODE Designer has lots of on-line help. Press F1 anywhere you want to
see help for an item, icon or notebook. You will see help relevant to what you
are currently trying to do. From the Help menu you have quick access to the
DDS Language Reference as well as several other useful sources of information.

Contents () o A
-

@ Remote System Explorer DDS Reference Pt
@ Classic iseries tools inforr,
© Remote System Explorer

ALIAS {Alternative Name) Keyword for Display Files

Uge thig field-level keyword to specify an alternative name for a

field. When the program is compiled, the alternative name is

brought into the program instead of the DDS field name. The high- —
level language compiler in use determines if the ALIAS name is 1
used. Refer to the appropriate high-level language reference manual

for information about ALIAS support for that language.

The farmat of the keywaord is:
ALIAS (alternative-name)

| | i

-] | =7 Refer to DDS Syntax Rules for ALIAS naming conventions. ~|

6. Minimize the Help window.

7. In the Create keywords page, double-click the INDTXT keyword. (You may
have to scroll to the right to find it).

The keyword is created with default values which can be changed when you
want.

8. Double-click the INDTXT keyword again.
The keyword is created with the same default values creating a conflict.

_Keyword | Parame... | |
SwEDTCDE 3

SwINDTXT 017

SwINDTKT 01'?

9. Close the Keyword Properties dialog.
You have seen the help on the ALIAS keyword and added INDTXT keywords.
Lesson checkpoint

You learned the following:
* About DDS keywords
* How to see help on a DDS keyword

Verifying the source changes

You have just added a new record and some new fields to your DDS source.
Everything that the CODE Designer adds to your DDS source is certain to have the
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correct syntax. Now you need to make sure that there are no semantic errors. You
just introduced one in the last exercise by creating two INDTXT keywords
describing the same indicator.

To verify your source:

1. Click Tools > Verify file (or click the verify M button on the main toolbar) on
the CODE Designer menu.

m <ROS400A >RSELABXX/QDDSSRC{MSTDSP) - CODE Designer

Fila Edit Wiew Insert Selected Tools Help
EEEEEE - EP B0 me)

The DDS source is checked using the same verifier that the CODE Editor or
LPEX Editor uses. A message appears on the status line at the bottom of the
Designer stating that the verify process completed with errors.

2. In the DDS tree, there is a trail of red X’s leading to the problem.
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The file icon has a red X, as does the SELECT record, the EMPAPL field and
finally the second INDTXT keyword.

3. Click the MAIN_MENU tab in the workbook.
The EMPAPL field is highlighted in red.

4. Click the Listing tab in the workbook.
This page shows you the listing generated by the most recent program verify. A
warning message is buried somewhere in the listing but it’s not easy to find.

5. If there are problems, they will show up in the Error list page in the Utility
notebook. It behaves exactly like the Error list in the CODE Editor or LPEX
Editor. Click the Error list tab.

6. Double-click the warning DDS7861 in the Error list. (Press F1 to see detailed
help on the message).

The Source page appears and the cursor is placed exactly where the error is in
the source. The Source page is a tokenized read-only view of the current state
of the DDS source. Read-only? Wouldn’t it be great if you could just clear the
error right here. There are some things that are just plain faster in the editor
and many others that are faster in the visual environment. It would be great to
switch between the two modes at the push of a button. Well, let’s just do that.
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You have verified your DDS source and have identified an error in the source.

Lesson checkpoint

You learned the following:
* About program verifier
* How to verify DDS source

To switch between the Design mode and the Edit mode:

Switching between designing and editing the screen

1. Click the Edit DDS source @l button or click File > Edit DDS source from the

Editor menu.

You now have access to the full power of the editor.
2. Explore the Edit and View menu items.
3. Press Ctrl-F to open the Find/Replace window.
4. In the Find field, type INDTXT and click Find.

Editor - Find and Replace

Find INDTXT =l
Replace with |

& Heplace this occurrence v Case sensitive
" Replace, then find pext [~ Pattern match
" Replace all occurrences v Wrap

m Replace _D_ptiuns-..l Cancel | Help

5. Press Ctrl-N to find the next occurrence.

6. Delete the second INDTXT line. Type D in the number column and press Enter.
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You have edited the source to fix the error by switching to the editor.
Lesson checkpoint

You learned the following:
* About switching between design and edit mode
* How to edit the source to fix an error

Compiling your source changes

Now you will compile the source on the iSeries just as you did in the Remote
Systems LPEX Editor.

To compile your source:
1. Click File > Save from the Designer menu to save your source to the iSeries.
2. Click Tools > Compile from the Designer menu and then click No prompt (or

click the compile ﬂ button on the CODE Designer toolbar).

3. A message indicates when the compile is complete. Click OK in the Message
dialog. If you re-compile and run the payroll program, you will see the 4 digit
year change you made to the opening screen of the program.

Tip: You will also see the message CPD7886W Field overlaps another field
with no conditions specified. You can ignore this message.

You have compiled your source changes.
Lesson checkpoint

You learned the following:
* How to compile source changes

Creating a report and closing the Designer

Now you create a simple printer file as well as explore checkpoints, which can be
used for all DDS created or maintained with CODE Designer. You will begin by
looking at the physical file specification for the database file that the printer file
you will create will use in CODE Designer.

To create a printer file:

1. In CODE Designer open the member REFMST in file QDDSSRC in library
RSELLABXX.

2. Take some time to explore the fields and information for this physical file. You
may want to refer back to this information as you work through the exercise.

Now that you are familiar with the file REFMST, its time to begin creating a
printer file.

3. In CODE Designer, click the Create new PRTF file button IE on the toolbar.
An initial printer file is created and the design page in the workbook is blank.

4. Click the Create absolute record button @ at the left of the design page and
then click on the first line of the Design page.

The Design page will now change to a white background and you will also
see the text “Start of page 1” at the top of the Design page.
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IS

10.

11.

Press F4 to bring up the record properties. Change the record name to Title.
This will help you when you create additional records for this printer file.
Close the properties dialog.

You will see your change both in the tree view and in the design page of the
workbook.

Now you will add some fields. On the first line, enter the text Employee
Information. To easily center the text, select the field by clicking on the text
with the left mouse button, then click on the Center horizontally button E .
On line 1, column 122, enter the text Page.

Tip: You can always use your mouse to drag and drop a field wherever you’'d
like it. And when you do this, you will see the current position of your field
next to your pointer. You could also use the properties dialog for the field to
position a field to your desired location.

Select the Create a page number constant button @ and point to the empty
space after the text field you added in the previous step (about column 128).

The page number constant will be added to your Title record.

On line 2, column 110, add a date field by selecting the Create a date constant
button and then clicking on the appropriate column. Bring up the
properties for the date constant (F4) and change the date to a 4 digit year.

You will see your changes appear immediately in the Design page.

On line 2, column 122, add a time field by selecting the Create a time constant

button .

Your report should look something like this.
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At this point it is a good time to save your source.

12. Press Ctrl-S. The Save As dialog should appear.
13. Save your changes so far to “<>RSELABxx/QDDSSRC(REPORT1)”

You will now see a dialog indicating that the source is being saved. You will
also see a dialog indicating that a checkpoint is being saved. Because this is
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the first time you save this source, a checkpoint is created which you could
revert to if you would like to. We will manually create a checkpoint later in
this exercise.

14. To add another record:

The record that you have added so far doesn’t really do much except set up
the header for our report. You will now add a couple more records so that this
report design makes much more sense.

a.

S "o o

Click on the Create relative record button E and click somewhere after
line 3.

The record will be added and you will see it in your DDS tree (if the
group is expanded).

Press F4 to bring up the properties dialog. Change the record name to
COLHEAD.

You will use this record to design the column headers for the report.
Close the properties dialog.

You should see your change in the design page in the record name field at
the top in the toolbar section of the design page. You will also see a hew
field at the left toolbar with a numeric spin box. You will use that later.

In row 5, column 2 add the text Number.

In row 5, column 12, add the text EmpTloyee.

In row 4, column 54, add the text Normal.

In row 5, column 54, add the text Hours worked.
In row 4, column 77, add the text Actual.

In row 5, column 77, add the text Hours worked.
Your design page should look something like this:
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15. To create a manual checkpoint and revert to a checkpoint:

You’ve done quite a bit of work at this point. Rather than just save your
source, it would be a good idea to create a checkpoint so that you can go back
to exactly this point in your design.

a. To create a manual checkpoint, click on the Design page and press Ctrl-M.
b. Name your checkpoint COLHEAD record. Click OK.

Your checkpoint will now be created. To see what happens when you
revert to a checkpoint, try to revert to the checkpoint that was created
when you first saved your source. To do this, select File -> Revert to
checkpoint.
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c. The checkpoint dialog will appear. Select the Initial load checkpoint, and
click theRevert button.

d. Go to the report Design page.

You will now see none of the record you just previously added. Saving
checkpoints is a good idea so that you can go back to a design that you
liked.

e. Now that you have explored checkpoints, revert back to the checkpoint
you created in step 2.

16. To change automatic checkpoints:

Much like autosave in LPEX Editor, CODE Designer has automatic
checkpoints which are triggered by elapsed minutes. You can also configure
the maximum number of user checkpoints.

a. Select Tools > Settings.
The Application Settings notebook appears.

i
General Saving | Wotkhook]

- Checkpoints

Minutes between automatic checkpoints ITE 0-E0

Marimum number of user checkpoints |59 E 0-100

Sequerce numbers

Start at |1_ug 0000.0M - 9399.99
Increment by [7.00 00,01 -99.99

[~ Automatically save changes on exit

Eame]l Help |

b. Select the Saving notebook tab.
You will now see the default settings for checkpoints.
c. If you like, change the number of minutes between automatic checkpoints.
17. To add another record:
Now you will add the record which will be the important part of the report.
a. Add a new relative record on line 5 called EMPDET.
This record will contain the employee detail information.
b. Inrow 7, column 2 add a database reference field by selecting the Create

database reference field button|§ from the toolbar at the left, and then
clicking on the appropriate location in the Design page.

c. Press F4 to change the settings for the field. Enter RSELABxx as the library,
REFMST as the file name and RCREF as the record name. Select EMPNO from
the combobox for the field name.

d. Keep the properties dialog open, but move it out of your way to add more
fields to the Design page.

e. Add another reference field to row 7, column 12, with the following
information: library RSELABxx, REFMST as file name, RCREF as record
name and ENAME as field name.
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f. Add another reference field to row 8, column 12, with the following
information: library RSELABxx, REFMST as file name, RCREF as record
name and EUSRI as field name. For proper spacing, select SPACEA and
leave the spinbox at 1.

g. Add another reference field to row 9, column 12, with the following
information: library RSELABxx, REFMST as file name, RCREF as record
name and ELOCN as field name.

h. Add another reference field to row 9, column 44, with the following
information: library RSELABxx, REFMST as file name, RCREF as record
name and EDEPT as field name. Ensure that the relative column checkbox
is selected.

i. Add another reference field to row 7, column 54, with the following
information: library RSELABxx, REFMST as file name, RCREF as record
name and ENHRS as field name.

j. Add another reference field to row 7, column 77, with the following
information: library RSELABxx, REFMST as file name, RCREF as record
name and EHWRK as field name.

Your design page should look something like this:
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k. You may want to create another checkpoint now and save your source.
18. To increase the number of sample records:

Sometimes it is hard to get a good idea of how a report will really look like.

To get a better idea, you can increase the number of sample records.

a. Select the record EMPDET from the combo box on the toolbar in the
design page.

b. On the left of the design page at the bottom of the palette, you will see a
numeric spinbox, which is set at 0. Increase the number here to see what
your report might look like with many records.

At this point you should ensure that you save your source and create the
printer file for this report.

c. Press Ctrl-S to save.
Your changes will be save to the host.
d. Click the compile button to compile with the default options.
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19. To close the Designer:

a. Click File > Exit from the Designer menu.

You have now successfully created a printer file. You should be familiar with using
checkpoints and you should be able to create your own report layouts using CODE
Designer.

Lesson checkpoint

You learned the following:

About checkpoints
How to create a printer report

Module summary

In this module, you learned how to design screens and reports using the CODE

Designer.

Lessons learned

Open a DDS member for edit with CODE Designer
Show file-level keywords and record-level keywords
View the details of records, record-level keywords and field-level keywords
View the design of the payroll application main menu
Create a group from an existing record format

Create a new group and add a subfile record and a subfile control record
Add columns to the subfile record

Add fields to the subfile control record

Copy existing fields

Set indicators to handle field errors

View and update record and field properties

View keywords and the properties of a keyword
Insert a keyword

View help for a keyword

Check there are no semantic errors in the DDS source
View help for an error

Launch the editor in read mode from the error list
Launch the editor in write mode to fix the error

Find a keyword in the source

Save source changes

Compile your source changes

Create a printer file report

Close the Designer

Assessment

What is CODE Designer?

What is the utility notebook?
What is the Design page?

What is the Properties notebook?
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* What is a group?

* What can you do in the utilities notebook?

* What can you do on the Design page?

* Why do you want to group records?

* What verifier is used to check DDS source?

* Can you switch between Design mode and Edit mode in CODE Designer?
* How do you open a DDS member for edit with CODE Designer?

* How do you show file-level keywords and record-level keywords?

* How do you view the details of records, record-level keywords and field-level
keywords?

* How do you view the design of an application main menu
* How do you create a group from an existing record format

* How do you create a new group and add a subfile record and a subfile control
record

* How do you add columns to the subfile record

* How do you add fields to the subfile control record

* How do you copy existing fields

* How do you seet indicators to handle field errors

* How do you view and update record and field properties

* How do you view keywords and the properties of a keyword
* How do you view and insert a keyword

* How do you check there are no semantic errors in the DDS source
* How do you launch the editor in read mode from the error list
* How do you launch the editor in write mode to fix the error

* How do you find a keyword in the source

* How do you save and compile source changes

* How do you create a printer file report

* How do you close the Designer

Introducing the product and Remote System Explorer (optional)

This modules teaches you about IBM WebSphere Development Studio for iSeries
and its relationship to IBM WebSphere Development Studio Client for iSeries. You
learn which product makes up the host components and which product makes up
the workstation components. You recognize the iSeries application development
tools included with Development Studio Client for iSeries programmers. You then
are introduced to Remote System Explorer the launching point for iSeries
application development tools.

Learning objectives

* Know the goals of the product

* Know the editions of the product

* Identify the host tools and the client tools

» List and describe the iSeries application development tools

Time required
This module should take approximately 15 minutes to complete.
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Introducing Development Studio and Development Studio
Client

Development Studio Client is the ideal set of workstation development tools for
creating, testing, deploying and maintaining traditional and e-business applications
for your iSeries server. Development Studio Client is included with the
compiler-based server product, WebSphere Development Studio. The following
diagram illustrates the interaction between host and client tools:

WebSphere Development Studio

C/C++ COBOL RPG ADTS

WebSphere Development Studio Client [ [ ]

Remote "
iSaries Web Tools
mr Projects for iSeries
IBM Classic tools
Java Tools
WebFacing (CODE and
foriQeries Tool VisualAge RPG)

Development Studio Client is designed to help you:

1. Develop and maintain iSeries applications using the Remote System Explorer.
2. Develop Web-enabled front-ends to iSeries business logic.

3. Create GUI front-ends to iSeries business logic.

Both Development Studio Client and Development Studio Client Advanced Edition
are built on the Rational® Software Development Platform. This platform offers a
fresh look and feel for the Eclipse workbench, and helps make it easier for you to
build, integrate, and extend your applications. The Rational Software Development
Platform offers a tutorials gallery and a samples gallery, to help you get up and
running with the product as quickly as possible. The platform also offers user
roles, which you can select from bottom-right corner of the Welcome view, (and
from Window - Preferences » Workbench » Capabilities) that customize and
simplify the user interface according to your programming role. These are just
some of the new features provided in the IBM Software Development Platform.

The product comes in two editions for iSeries programmers. Both editions of the
product are packaged with an additional base Rational product:

* WebSphere Development Studio Client for iSeries inherits and extends the
robust, easy-to-use IBM Rational Software Delivery Platform (RSDP) and a
subset of IBM Rational Application Developer for WebSphere Software to deliver
an integrated development environment (IDE) with tools for developing Web,
Web services, client/server, and i5/0S server applications using programming
languages like RPG, COBOL, CL, and Java.
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* WebSphere Development Studio Client Advanced Edition for iSeries contains all
of the development tools included in WebSphere Development Studio Client,
plus it inherits and builds on additional premium Web, Enterprise Java Bean
(EJB), and J2EE development capabilities from IBM Rational Application
Developer. In addition, it provides specific advanced System i tools including
Navigation support, ClearCase® integration, and a Eclipse-based Screen designer
technology preview.

You have reviewed the goals of the product and the product editions.

Introducing iSeries Application Development Tools

Now, you know what the two flavors are of Development Studio Client and why
you would want to use each one. Next let’s look at those next generation iSeries
server application development tools. What are they and what do they do?

Remote System Explorer

You can manage your development tasks in the Remote System Explorer. This is an
enhanced and more flexible workstation version of Program Development Manager
(PDM). You can create and manage development projects on your iSeries system
from your Windows-based workstation with the Remote System Explorer and
iSeries projects. With these tools, you can connect to an iSeries remote host, view
iSeries libraries, files, and members. You can also launch the host compilers, the
workstation editor, a program verifier and various debuggers all from the Remote
System Explorer. This tool also supports other system types, such as UNIX(R),
Linux, and Windows.

LPEX Editor

Your program editing tasks are simplified with the Remote Systems LPEX Editor.
This is a powerful language-sensitive editor that you can customize. Token
highlighting of source makes the various program elements stand out. It has
SEU-like specification prompts for RPG and DDS to help enter column-sensitive
fields. Local syntax checking and semantic verification for your RPG, COBOL and
DDS source makes sure it will compile without errors on an iSeries system. If there
are verification errors, an Error List lets you locate and resolve problems quickly.
On-line programming guides, language references, and context-sensitive help make
finding the information you need just a keystroke away.

Shells and commands in the Remote Commands view

You can use the Remote Commands view to run and interact with commands and
command shells on universal systems. A universal system includes Windows,
Linux, and UNIX system types. Specifically, you use the view to:

* Run commands in a command shell
» Display and interpret the output of a program
* Enter input to a program

» Display and manage different commands and shells from the same view.
Multiple commands can be run in a single shell (one command at a time per
shell), multiple shells may be run on a single system, and multiple systems may
be running shells.
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Whenever a command shell is launched or a command is run from the Remote
System Explorer, the Remote Commands view displays the output and provides a
way to work with that output.

Program \erifier

One of the most powerful and unique features of the Remote System Explorer is
the Program Verifier. Before you compile your code on an iSeries system, you can
ensure that there are no errors by invoking the Program Verifier. The verifier
checks for semantic (compile) errors on your workstation so that you can
guarantee a clean compile on the iSeries. Think of the host cycles you’ll save. It is
especially handy when you are writing code but you are disconnected from an
iSeries system. You can do this because Remote System Explorer ported the parsing
and checking code from the iSeries host compilers to the workstation. The Error
List window lists the errors that are found and their severity, display the error
messages directly in the source and helps you to navigate between the errors.

iSeries Debugger

With the Integrated iSeries Debugger you can debug an application that is running
on an iSeries system. It provides an interactive graphical user interface that makes
it easy to debug and test your iSeries programs. It is fully integrated into the
workbench. You can also set breakpoints before running the debugger, by inserting
breakpoints directly in your source while editing. The Integrated iSeries Debugger
client user interface also enables you to control program execution. For example,
you can run your program, set line, watch, and service entry point breakpoints,
step through program instructions, examine variables, and examine the call stack.
You can also debug multiple applications, which may be written in different
languages, from a single debug window. Each session you debug is listed
separately in the Debug view.

CODE Designer

Using an editor to create and maintain DDS source for your display and printer
files can be a frustrating and difficult task. What would be great is a graphical
design tool that lets you design your screens and reports visually and then
generate the DDS source for you. Well, that’s exactly what the CODE Designer
does for you.

The CODE Designer interface was designed to help the novice DDS programmer
create screens, reports and databases quickly and easily without worrying about
the details of the DDS language, while at the same time letting the expert DDS
programmer get access to all the features and power of the language. CODE
Designer is not fully integrated into the workbench, but you can launch it as a
separate tool from the workbench.

Summary

This tutorial has taught you how to maintain a payroll application using the
Remote System Explorer. You learned how to start the product and open the
Remote System Explorer perspective and how to use tools and views in this
perspective to connect to an iSeries system and edit, verify, compile and debug the
payroll application.
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Lessons learned

If you have completed all of the modules, you should now be able to:

» Start the product and open the Remote System Explorer perspective

» Create a connection to an iSeries and select iSeries objects from this connection
* Use the Remote Systems LPEX Editor to edit source

» Verify and compile source in the Remote Systems LPEX Editor

» Debug your interactive payroll application from the workstation

» Customize the Remote System Explorer

* Modify a display file

* Create a printer file

* Recognize the product features and packaging

Additional resources
More information

For more information on the product and the Remote System Explorer, see
http://ibm.com/software/awdtools/iseries.

Notices

© Copyright IBM Corporation 1992, 2007. All rights reserved.

U.S. Government Users Restricted Rights - Use, duplication or disclosure restricted
by GSA ADP Schedule Contract with IBM Corp.

This information was developed for products and services offered in the U.S.A.
IBM may not offer the products, services, or features discussed in this
documentation in other countries. Consult your local IBM representative for
information on the products and services currently available in your area. Any
reference to an IBM product, program, or service is not intended to state or imply
that only that IBM product, program, or service may be used. Any functionally
equivalent product, program, or service that does not infringe any IBM intellectual
property right may be used instead. However, it is the user’s responsibility to
evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this documentation. The furnishing of this documentation does not
give you any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation

North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing

2-31 Roppongi 3-chome, Minato-ku
Tokyo 106, Japan
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The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION "AS I1S” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OR CONDITIONS OF NON-INFRINGEMENT,
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states
do not allow disclaimer of express or implied warranties in certain transactions,
therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

Intellectual Property Dept. for WebSphere Software
IBM Corporation

3600 Steeles Ave. East

Markham, Ontario

Canada L3R 977

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this documentation and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-1BM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.
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All statements regarding IBM’s future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

Copyright license

This information contains sample application programs in source language, which
illustrates programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs.

Each copy or any portion of these sample programs or any derivative work, must
include a copyright notice as follows:

© (your company name) (year). Portions of this code are derived from IBM Corp.
Sample Programs. © Copyright IBM Corp. 1992, 2007. All rights reserved

Trademarks and service marks

The following terms are trademarks or registered trademarks of International
Business Machines Corporation in the United States, other countries, or both.

* IBM

* i5/08S

* iSeries

* Rational

e System i

* WebSphere

Intel® and Pentium® are trademarks of Intel Corporation in the United States, other
countries, or both.

Microsoft, Windows, Windows NT® and the Windows logo are trademarks of
Microsoft Corporation in the United States, other countries, or both.

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the
United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Linux is a registered trademark of Linus Torvalds in the United States, other
countries, or both.

Other company, product or service names may be trademarks or service marks of
others.
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